Ubuntu

Comment 285 for bug 353126

Aaron Plattner (aplattner) wrote :

Right, the code was added for xserver 1.7.0, so Lucid should work since it ships a newer point release of the same server branch.

You mentioned Karmic, which ships xserver 1.6.4: http://packages.ubuntu.com/karmic-updates/x11/xserver-common
I would not expect that to work correctly with Vino+Compiz since it lacks the necessary X server source.