Ubuntu

Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI fglrx driver using X.org

Reported by Andrew Barbaccia on 2009-04-01
This bug affects 416 people
Affects Status Importance Assigned to Milestone
Lucid Backports
Undecided
Unassigned
NVIDIA Drivers Ubuntu
Undecided
Unassigned
X.Org X server
Fix Released
High
fglrx
Invalid
Undecided
Unassigned
maverick-backports
Won't Fix
Undecided
Unassigned
vino
Fix Released
Wishlist
vino (Fedora)
Unknown
Unknown
vino (Ubuntu)
Medium
Unassigned
Declined for Jaunty by Timo Aaltonen
Declined for Karmic by Timo Aaltonen
Nominated for Lucid by Agustin
xorg-server (Ubuntu)
Medium
Unassigned
Declined for Jaunty by Timo Aaltonen
Declined for Karmic by Timo Aaltonen
Nominated for Lucid by Agustin

Bug Description

Binary package hint: compiz

When using the nvidia-restricted or some ATI drivers and compiz desktop effects the vnc server will not refresh the screen. This is being caused by the xserver not getting "damaged" by the nvidia-restricted drivers (see https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/353126/comments/245 for details). Linked bugs confirm this is not an issue on intel chipsets or nv driver.

Steps to reproduce:
Enable desktop-effects (default) with nvidia-restricted, virtualBox's display or some ATI driver like RV610
Enable remote desktop
Connect with VNC

Results:
You see a screen snapshot of your desktop but if you click a menu item there are no updates to the screen.
Notes:
If you close and restart the vnc session, you get an updated snapshot but still no refreshes.

Workarounds:
Use the -noxdamage argument with vncviewer. This is really inefficient and bandwidth hungry since the whole screen refreshes.
Kill compiz and use a different wm (metacity).

[Tested with nvidia] Run compiz with the --use-root-window option, eg:
compiz --replace --use-root-window &

This bug has been confirmed by many others with linked reports. Might be an issue with xorg since there is a report of ATI drivers with similar issues in https://bugs.launchpad.net/bugs/328559 .

this should be fixed with current git mesa/xserver/et al, i believe.

(In reply to comment #1)
> this should be fixed with current git mesa/xserver/et al, i believe.
>

Oh, this is a great news. Do you have any idea when a new tarball (release) will be released?
Thanks,

This seems to still be happening on latest Ubuntu Jaunty Beta with -restricted drivers (tested with nvidia restricted). vnc will show a static image with no refreshes. Monitoring the system will show that actions are actually taking place (or starting another vnc session to grab a new 'snapshot').

More info here: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/353126

Binary package hint: compiz

When using the nvidia-restricted driver and compiz desktop effects the vnc server will not refresh the screen. This is being caused by the xserver not getting "damaged" by the nvidia-restricted drivers. Linked bugs confirm this is not an issue on intel chipsets or nv driver.

Steps to reproduce:
Enable desktop-effects (default) with nvidia-restricted driver
Enable remote desktop
Connect with VNC

Results:
You see a screen snapshot of your desktop but if you click a menu item there are no updates to the screen.
Notes:
If you close and restart the vnc session, you get an updated snapshot but still no refreshes.

Workarounds:
Use the -noxdamage argument with vncviewer. This is really inefficient and bandwidth hungry since the whole screen refreshes.
Kill compiz and use a different wm (metacity).

This bug has been confirmed by over a dozen people in the linked bugs.

description: updated
Changed in xorg-server:
importance: Undecided → Unknown
status: New → Unknown
Changed in xorg-server:
status: Unknown → Confirmed

What's strange about this bug is that I /didn't/ have this problem in Intrepid, but I /do/ have it in Jaunty...

Graham Inggs (ginggs) wrote :

I got this problem after upgrading to Jaunty. It used to work fine in Intrepid.

1 comments hidden view all 327 comments
giruzz (giruzz) wrote :

Same here. All fine in Intrepid but it doesn't work with Jaunty

Teddyber (teddyber) wrote :

same here sine I upgraded too Jaunty. It was fine with Intrepid, Hardy, Gutsy, and Feisty at least (if not even before...)

There is a new version of x11 in jaunty which is probably why this is a problem with the new release.

Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in vino (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed

I've just noticed that turning off desktop effects fixes the problem.

Rocko (rockorequin) wrote :

I also get this problem using VirtualBox's display drivers (see https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/333564 which looks like a duplicate bug): if I am running a VM with desktop effects, I get no updates in vnc, but if I turn desktop effects off, everything returns to normal.

So it seems to be both nvidia and VirtualBox drivers that exhibit this problem. It isn't a problem on another laptop running 3d effects with an ATI card.

jecarterii (jecarterii) wrote :

Just upgraded to 9.04 full release from 8.10 .. used update man gui to upgrade.. have same issue.. have to disable all desktop effects for users to vnc my system (which has vino server).. since im using full release, im guessing this issue got thru beta? any chance its gonna get fixed?..
thanks...

croaker___ (martin-gautier) wrote :

Confirmed as described.

8.10 -> 9.04 upgrade, proprietary nvidia drivers, screen effects on.
Fails on WinXP->tightvnc->9.04, WinXP->realvnc->9.04, WinXP->ultravnc->9.04, 8.10->Remote Desktop Viewer->9.04

Works in all cases when screen effects switched off.

Philip Wyett (philwyett) wrote :

I can confirm this issue and that turning off desktop effects works round the issue.

I ran into the issue after making a machine headless and moving it so had to disable desktop effects in the terminal. Todo this you use the two commands below then restart.

gconftool -s -t string /desktop/gnome/applications/window_manager/current /usr/bin/metacity
gconftool -s -t string /desktop/gnome/applications/window_manager/default /usr/bin/metacity

same problem here very frustrating, is it possible to switch the wm to and from compiz without rebooting?

RM (rmajeed) wrote :

Screen Sharing on MacOS 10.5.6, connected to Ubuntu Intrepid, worked well with Visual Effects set to "Normal". When I upgraded Ubuntu to Jaunty (release), Screen Sharing would no longer show updates. Setting Visual Effects to "Off" immediately caused screen updates to resume. It's unclear what the "nodamage" equivalent would be in MacOS Screen Sharing, or I would report that result. I can provide more detailed information if it would be helpful.

Trurl (trurl-online) wrote :

I can confirm this issue too and that turning off desktop effects helps. I hope a fix will be published soon :(

heggink (herman-eggink) wrote :

After upgrading to Jaunty, I found that my CPU load would constantly be stuck around 60% (which using an E8400 on an idle system is rather strange). Could not find any cause until I replaced vino with x11vnc. After uninstalling vino, not only was my system load back to idle load (few %) but also HD video runs much more smoothly than it ever did + x11vnc works perfectly with (using noxdamage, haven't tried without) all desktop effects enabled.
I run Geforece8500GT, E8400 with 4GB on a shuttle barebone.

heggink wrote:
> After upgrading to Jaunty, I found that my CPU load would constantly be stuck around 60% (which using an E8400 on an idle system is rather strange). Could not find any cause until I replaced vino with x11vnc. After uninstalling vino, not only was my system load back to idle load (few %) but also HD video runs much more smoothly than it ever did + x11vnc works perfectly with (using noxdamage, haven't tried without) all desktop effects enabled.
> I run Geforece8500GT, E8400 with 4GB on a shuttle barebone.

The CPU issue is a different bug that this one.

i know the CPU issue is a different bug. What I said was that vino caused my CPU issue and vino also happens to be the vnc server. Too much coincidence for me.

XCan (xcan-) wrote :

I too can confirm this issue. It worked fine on 8.10, but after upgrading to 9.04, vnc client only displays initial screen. All consecutive actions are carried out (can be seen by restarting the vnc-client and logging in), but the screen on the client does not update.

Dan Smith (mrdanpsmith) wrote :

I too can confirm this bug. There was another bug that was similar in the previous versions, except it would be on subsequent X screens (if you had more than 1). I took it from one of the developers on that bug that there was a small patch he submitted to correct the problem, and that the problem had to be applied to the second screen. If this is the same problem, is there any chance we can make sure that the new fix fixes it for additional X screens? Because last time I couldn't use VNC on my second X server because it wouldn't refresh as long as desktop effects were enabled.

I also was able to use this fine in 8.04 and 8.10, Jaunty killed the support. I'm thinking that someone should take a look at the fix in the other bug.

Dan Smith (mrdanpsmith) wrote :

Here is the other bug report I filed for the second X server problem:

https://bugs.launchpad.net/bugs/309020

Dan Smith (mrdanpsmith) wrote :

Nobody really replied to my bug, the bug that it appears to be the exact same as is linked both in the bug report for my bug, and below:
https://bugs.launchpad.net/ubuntu/+source/vnc/+bug/77442

Dan Burke (dan-burke) wrote :

Can a developer explain why this all of a sudden started in Jaunty and was not a problem in Intrepid? The upstream bug report this is linked against is from mid to late 2007. I assume Jaunty didn't "Upgrade" to an Xorg release from 2007. This problem seems to be affecting a lot of people and is a regression, and the lack of activity suggests that it's not going to be fixed in Jaunty... it'd be nice if we heard something about this, as I'm willing to downgrade to Intrepid over this bug.

If this truly is a problem with the new Xorg, why are we tagging on to the upstream bug report from 2007 and not creating a new bug report for the new version?

Valentin Rocher (bishiboosh) wrote :

I have this error with Nvidia/Jaunty also. Is there some lead on how to fix this ?

Valentin Rocher (bishiboosh) wrote :

Hmmm...As in the duplicate, the importance on this bug must be set to "High", compiz is launched by default and nvidia is present on many computers...This problem renders the vnc server completely unusable.

jose (jose-cybergalvez) wrote :

I don't know if adding more "me too" helps move the importance up or not, but this only started when I upgraded to Jaunty and its a real real real problem. I use the remote desktop all the time. Compiz is on by default, and turning if on and off would be a real pain, and is not really a good solution only a bad workaround. I sure hope this gets fixed soon, I'm considering switching back to intrepid because of this,

You may want to switch to freeNX until this bug is resolved

On Apr 29, 2009, at 6:11 PM, jose <email address hidden> wrote:

> I don't know if adding more "me too" helps move the importance up or
> not, but this only started when I upgraded to Jaunty and its a real
> real
> real problem. I use the remote desktop all the time. Compiz is on by
> default, and turning if on and off would be a real pain, and is not
> really a good solution only a bad workaround. I sure hope this gets
> fixed soon, I'm considering switching back to intrepid because of
> this,
>
> --
> Compiz / vnc screen refresh with nvidia-restricted driver
> https://bugs.launchpad.net/bugs/353126
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.Org X server: Confirmed
> Status in “compiz” source package in Ubuntu: Confirmed
> Status in “vino” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: compiz
>
> When using the nvidia-restricted driver and compiz desktop effects
> the vnc server will not refresh the screen. This is being caused by
> the xserver not getting "damaged" by the nvidia-restricted drivers.
> Linked bugs confirm this is not an issue on intel chipsets or nv
> driver.
>
> Steps to reproduce:
> Enable desktop-effects (default) with nvidia-restricted driver
> Enable remote desktop
> Connect with VNC
>
> Results:
> You see a screen snapshot of your desktop but if you click a menu
> item there are no updates to the screen.
> Notes:
> If you close and restart the vnc session, you get an updated
> snapshot but still no refreshes.
>
> Workarounds:
> Use the -noxdamage argument with vncviewer. This is really
> inefficient and bandwidth hungry since the whole screen refreshes.
> Kill compiz and use a different wm (metacity).
>
> This bug has been confirmed by many others with linked reports.
> Might be an issue with xorg since there is a report of ATI drivers
> with similar issues in https://bugs.launchpad.net/bugs/328559 .

That's not really a workaround...The default vnc server on Ubuntu is vino. What's important is to allow all users to use their machine "out-of-the-box" and, with nvidia being present on many hardwares, it seems to me that it's a real problem.

nhasian (nhasian) wrote :

I'm not sure its exclusive to nvidia. I read a post on the ubuntu forums that a user with an ATI video card had the same problem. can anyone confirm? I dont have any machines with ATI video cards.

Dave Brosius (dbrosius) wrote :

I have an ati card

01:00.0 VGA compatible controller: ATI Technologies Inc RV610 [Radeon HD 2400 XT]

And this exact problem happens for me as well. (only in jaunty)

Aerogt3 (perry-robertl) wrote :

I have this same problem. While a fix would be great, how can I disable desktop effects if I am running the Nvidia driver? I cannot seem to figure it out, and this would solve the issue until there is a proper fix.

Yuriy Voziy (yuretsz) wrote :

Awfull bug I work with vnc alot. Everything worked fine with 8.10 and upgrade to 9.04 made me unhappy with it.

Trurl (trurl-online) wrote :

I installed x11vnc and use this command in the terminal:

x11vnc --noxdamage --passwd XXX -forever

as a work-around until vino is fixed.

Aerogt3 wrote:
> I have this same problem. While a fix would be great, how can I disable
> desktop effects if I am running the Nvidia driver?

System->Preferences->Appearance, Effects tab

reading through the different "workarounds" x11vnc is the best. I can leave compiz turned on and still use vnc to connect ot the machine. Basically you turn off vino (Systems>Preferences>Remote Desktop uncheck sharing) and then I added x11vnc --noxdamage --passwd XXX -forever -shared -alwaysshared to my session. I don't know if shared and alwaysshared are needed options but they seem to make sense. And so far I don't see much of a performance hit with the --noxdamage turned on.

Aerogt3 (perry-robertl) wrote :

What I did was turn off desktop effects using compiz simple-ccsm.

Install simple-ccsm from synaptic and then its under preferences I think.

jose (jose-cybergalvez) wrote :

well there's a bug in x11vnc too, after a while you get a stuck "a" which requires you to restart the xserver so that workaround isn't going to work for me now

Steve (stupendoussteve) on 2009-05-06
summary: - Compiz / vnc screen refresh with nvidia-restricted driver
+ Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox
summary: - Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox
+ Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI
+ fglrx driver
Changed in vino:
status: Unknown → Fix Released
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
affects: compiz (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: Invalid → New
Bryce Harrington (bryce) on 2009-07-20
tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xorg-server (Ubuntu):
status: New → Incomplete
koshari (holto2go) on 2009-09-15
Changed in vino:
status: Fix Released → Incomplete
J N B (wdflr73) on 2009-11-20
summary: Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI
- fglrx driver
+ fglrx driver using X.org prior to version 7.5
summary: Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI
- fglrx driver using X.org prior to version 7.5
+ fglrx driver using X.org prior to release 7.5
Agustin (agustin-bosso) on 2009-12-08
description: updated
Bryce Harrington (bryce) on 2010-04-19
Changed in xorg-server (Ubuntu):
status: Incomplete → Fix Released
koshari (holto2go) on 2010-04-24
Changed in xorg-server (Ubuntu):
status: Fix Released → Confirmed
summary: Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI
- fglrx driver using X.org prior to release 7.5
+ fglrx driver using X.org
Rocko (rockorequin) on 2010-04-25
Changed in vino (Fedora):
importance: Undecided → Unknown
status: New → Unknown
Rocko (rockorequin) on 2010-04-27
description: updated
Bryce Harrington (bryce) on 2010-05-04
Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Sandro Mani (sandromani) on 2010-05-22
Changed in xorg-server (Ubuntu):
status: Incomplete → Fix Released
Changed in nvidia-drivers-ubuntu:
status: New → In Progress
Changed in fglrx:
status: New → Confirmed
Sandro Mani (sandromani) on 2010-05-22
Changed in vino (Ubuntu):
status: Confirmed → Fix Released
247 comments hidden view all 327 comments
Jeff Van Epps (lordbah) wrote :

After installing the ubuntu-x-swat PPA, do I need to:

1. Remove the prior driver, which was downloaded from nvidia and installed via "sh NVIDIA-Linux-x86-195.36.24-pkg1.run"? By doing "sh NVIDIA-Linux-x86-195.36.24-pkg1.run --uninstall"?
2. Launch synaptic and install nvidia-current?
3. Also install nvidia-settings?

VPablo (villumar) wrote :

I had not installed binary from NVidia so I only updated with Synaptic. It will update both nvidia-settings and drivers from 195 to 256.

Later I will test vino with compiz active.

VPablo (villumar) wrote :

OK. With x-swat PPA drivers vino works with Desktop-Effects active in Lucid. I think this bug is solved for Lucid and NVidia.

Jeff Van Epps (lordbah) wrote :

Since installing version 256 I haven't been able to turn on compiz on my system, let alone have it work remotely. System / Appearance / Visual Effects / Extra causes the screen to blink a bit and then "Desktop effects could not be enabled".

From Xorg.0.log it is loading the new driver and seems happy. It initializes the GLX extension. However, System / NVidia X Server Settings on the OpenGL/GLX Information tab says "Failed to query the GLX server vendor". Weird?

System / Administration / Hardware Drivers shows nvidia_current but says "This driver is activated but not currently in use". However, this appears to be a known bug with jockey. I did try Deactivate, Activate, reboot - no change.

dmesg appears happy and references the new version.

"modprobe nvidia" does not find the module. Seems odd.

Jeff Van Epps (lordbah) wrote :

Added /etc/modprobe.d/modprobe.conf with

alias nvidia nvidia-current

and rebooted. Now "modprobe nvidia" no longer complains, but I still have all of the other issues noted earlier.

/lib/modules/2.6.32-22-generic/updates/dkms contains one nvidia file, nvidia-current.ko, dated when I installed from the PPA. Sounds correct, right?

The only other nvidia file I find under that tree is /lib/modules/2.6.32-22-generic/kernel/drivers/video/nvidia/nvidiafb.ko dated 6/3. But that is blacklisted in /etc/modprobe.d/blacklist.conf so I doubt that it is interfering.

glxinfo reports "Error: couldn't find RGB GLX visual or fbconfig". I have no ideas about this.

Anything else I can try? Or do I just have to uninstall this and go back to 195?

Dario Meloni (mellon85) wrote :

Please, stop complaining about nvidia drivers installation not working here.
Open a related bug, don't litter this

Jeff Van Epps (lordbah) wrote :

Okay. I was hoping to be able to confirm this fix, but I"m sure someone else can.

Zygmunt Krynicki (zkrynicki) wrote :

Nvidia proprietary driver version 256.35 claims to fix this issue.

See: http://www.nvidia.com/object/linux-display-amd64-256.35-driver.html

Quote:
Fixed an interaction problem between Compiz and 'screen-scraping' VNC servers like x11vnc and vino that caused the screen to stop updating. Fixes Launchpad bug #353126.

Valentin Rocher (bishiboosh) wrote :

Just backported the 256.35 version for maverick and it WORKS. At last. So maybe we could add a bug in lucid-backports and make it work at last for everyone.

jose (jose-cybergalvez) wrote :

There is an nvidia ppa with the updated drivers, if you use that with lucid then the problem is fixed. I've tested it and it works as expected

Using that PPA i cannot activate compiz lately

On Tue, Jun 29, 2010 at 10:49 AM, jose <email address hidden> wrote:
> There is an nvidia ppa with the updated drivers, if you use that with
> lucid then the problem is fixed. I've tested it and it works as expected
>
> --
> Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI fglrx driver using X.org
> https://bugs.launchpad.net/bugs/353126
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in AMD fglrx video driver: Confirmed
> Status in NVIDIA Drivers Ubuntu: In Progress
> Status in GNOME Remote Desktop: Incomplete
> Status in X.Org X server: Confirmed
> Status in “vino” package in Ubuntu: Fix Released
> Status in “xorg-server” package in Ubuntu: Fix Released
> Status in “vino” package in Fedora: Unknown
>
> Bug description:
> Binary package hint: compiz
>
> When using the nvidia-restricted or some ATI drivers and compiz desktop effects the vnc server will not refresh the screen. This is being caused by the xserver not getting "damaged" by the nvidia-restricted drivers (see https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/353126/comments/245 for details). Linked bugs confirm this is not an issue on intel chipsets or nv driver.
>
> Steps to reproduce:
> Enable desktop-effects (default) with nvidia-restricted, virtualBox's display or some ATI driver like RV610
> Enable remote desktop
> Connect with VNC
>
> Results:
> You see a screen snapshot of your desktop but if you click a menu item there are no updates to the screen.
> Notes:
> If you close and restart the vnc session, you get an updated snapshot but still no refreshes.
>
> Workarounds:
> Use the -noxdamage argument with vncviewer. This is really inefficient and bandwidth hungry since the whole screen refreshes.
> Kill compiz and use a different wm (metacity).
>
> [Tested with nvidia] Run compiz with the --use-root-window option, eg:
> compiz --replace --use-root-window &
>
> This bug has been confirmed by many others with linked reports. Might be an issue with xorg since there is a report of ATI drivers with similar issues in https://bugs.launchpad.net/bugs/328559 .
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/fglrx/+bug/353126/+subscribe
>

jose (jose-cybergalvez) wrote :

I couldn't either until I actually set up xorg. Apparently after installing the driver the xorg.conf file did not get created so it wasn't actually using the driver, even though sysinfo said it was being used
Jose

KruyKaze (kruykaze) wrote :

Can you tell us how you setup xorg so we can get this working?
thanks

On Tue, Jun 29, 2010 at 2:36 PM, jose <email address hidden> wrote:
> I couldn't either until I actually set up xorg. Apparently after installing the driver the xorg.conf file did not get created so it wasn't actually using the driver, even though sysinfo said it was being used
> Jose
>
> --
> Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI fglrx driver using X.org
> https://bugs.launchpad.net/bugs/353126
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in AMD fglrx video driver: Confirmed
> Status in NVIDIA Drivers Ubuntu: In Progress
> Status in GNOME Remote Desktop: Incomplete
> Status in X.Org X server: Confirmed
> Status in “vino” package in Ubuntu: Fix Released
> Status in “xorg-server” package in Ubuntu: Fix Released
> Status in “vino” package in Fedora: Unknown
>
> Bug description:
> Binary package hint: compiz
>
> When using the nvidia-restricted or some ATI drivers and compiz desktop effects the vnc server will not refresh the screen. This is being caused by the xserver not getting "damaged" by the nvidia-restricted drivers (see https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/353126/comments/245 for details). Linked bugs confirm this is not an issue on intel chipsets or nv driver.
>
> Steps to reproduce:
> Enable desktop-effects (default) with nvidia-restricted, virtualBox's display or some ATI driver like RV610
> Enable remote desktop
> Connect with VNC
>
> Results:
> You see a screen snapshot of your desktop but if you click a menu item there are no updates to the screen.
> Notes:
> If you close and restart the vnc session, you get an updated snapshot but still no refreshes.
>
> Workarounds:
> Use the -noxdamage argument with vncviewer. This is really inefficient and bandwidth hungry since the whole screen refreshes.
> Kill compiz and use a different wm (metacity).
>
> [Tested with nvidia] Run compiz with the --use-root-window option, eg:
> compiz --replace --use-root-window &
>
> This bug has been confirmed by many others with linked reports. Might be an issue with xorg since there is a report of ATI drivers with similar issues in https://bugs.launchpad.net/bugs/328559 .
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/fglrx/+bug/353126/+subscribe
>

jose (jose-cybergalvez) wrote :

after I added the nvidia ppa and installe the nvidia drivers, I checked to see if it was installed and running by 1) checking the hardware drivers to see if nvidia current driver was installed and active, I also checked sysinfo which also showed that it was installed. I then ran sudo nvidia-settings from a terminal and accepted the default settings, hit save that writes the correct xorg.conf file, reboot and everything runs great. Althouhg using the default vnc viewer from ubuntu stinks, I just use remmina and set the colrs to 256, great performance andit seems to be working. I did not test with the 185 drivers on 10.04 so I can't comment on that, but past experience with 9.10 indicates that it does not work.
Jose

KiJune Yoon (kijune) wrote :

I've spent 3 days to solve this problem. And finally I found this link.
Changing disable_xdamage value works fine. thanks.
I think this option would be default value.or many people have to spend their time searching for the solution.

Valentin Rocher (bishiboosh) wrote :

As the fix has been released in the nvidia drivers, couldn' they be backported for Jaunty/Karmic/Lucid ?

Changed in nvidia-drivers-ubuntu:
status: In Progress → Fix Released
Changed in lucid-backports:
status: New → Confirmed
VPablo (villumar) wrote :

It needs to be backported xserver 1.7.0 on Karmic and Jaunty too as mentioned Aaron on #278. I don't think this could be done on previous distros.

I have this issue with both remote desktop server and client running Ubuntu 10.4, server uses ATI/AMD FGLRX graphics driver; either disabling desktop-effects or setting noxdamage to true in gconf-editor are verified workarounds, but it would be great to have a fix.

Changed in xorg-server (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
swatspyder (andrewdefilippis) wrote :

Not working for me. 10.04 AMD64 with NVIDIA Drivers. Connection from Android OS to Ubuntu via VNC. Had to disable Visual Effects to be able to receive screen refreshes.

Troy Ready (troyready) wrote :

swatspyder: For Lucid, It requires the drivers from the right PPA -- see comment 280.

swatspyder (andrewdefilippis) wrote :

Thank you Troy.

Steve Stalcup (vorian) wrote :

This should be a Stable Release Update and not a Backport.

Please see https://wiki.ubuntu.com/StableReleaseUpdates for information on how to request an SRU

Changed in lucid-backports:
status: Confirmed → Invalid

I do not have any idea what you are talking about.
I reported a bug.
I hope this does not mean you are marking the whole bug invalid, and
therefore the bug is quietly ignored.

Kris

On Thu, August 5, 2010 2:13 pm, Steve Stalcup wrote:
> This should be a Stable Release Update and not a Backport.
>
> Please see https://wiki.ubuntu.com/StableReleaseUpdates for information
> on how to request an SRU
>
> ** Changed in: lucid-backports
> Status: Confirmed => Invalid
>
> --
> Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI
> fglrx driver using X.org
> https://bugs.launchpad.net/bugs/353126
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
>

--
Kriston Rehberg
http://kriston.net/

Changed in xorg-server:
importance: Unknown → High
status: Confirmed → Fix Released
Changed in vino:
importance: Unknown → Wishlist
status: Incomplete → Fix Released
KruyKaze (kruykaze) wrote :

I am still experiencing this bug on Maverick 64bit

Josh (majik) wrote :

I don't understand how the most user friendly Linux distribution in the world can have such a fundamental problem for *four years*.

I think it's more like 2 years the problem is that it was working before and
then it broke.What I don't understand is that I know it's not uncommon to
use compiz and vnc at the same time.

On Thu, Oct 21, 2010 at 9:46 PM, Josh <email address hidden> wrote:

> I don't understand how the most user friendly Linux distribution in the
> world can have such a fundamental problem for *four years*.
>
> --
> Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI
> fglrx driver using X.org
> https://bugs.launchpad.net/bugs/353126
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in AMD fglrx video driver: Confirmed
> Status in Lucid Backports: Invalid
> Status in NVIDIA Drivers Ubuntu: Fix Released
> Status in GNOME Remote Desktop: Fix Released
> Status in X.Org X server: Fix Released
> Status in “vino” package in Ubuntu: Fix Released
> Status in “xorg-server” package in Ubuntu: Fix Released
> Status in “vino” package in Fedora: Unknown
>
> Bug description:
> Binary package hint: compiz
>
> When using the nvidia-restricted or some ATI drivers and compiz desktop
> effects the vnc server will not refresh the screen. This is being caused by
> the xserver not getting "damaged" by the nvidia-restricted drivers (see
> https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/353126/comments/245for details). Linked bugs confirm this is not an issue on intel chipsets or
> nv driver.
>
> Steps to reproduce:
> Enable desktop-effects (default) with nvidia-restricted, virtualBox's
> display or some ATI driver like RV610
> Enable remote desktop
> Connect with VNC
>
> Results:
> You see a screen snapshot of your desktop but if you click a menu item
> there are no updates to the screen.
> Notes:
> If you close and restart the vnc session, you get an updated snapshot but
> still no refreshes.
>
> Workarounds:
> Use the -noxdamage argument with vncviewer. This is really inefficient and
> bandwidth hungry since the whole screen refreshes.
> Kill compiz and use a different wm (metacity).
>
> [Tested with nvidia] Run compiz with the --use-root-window option, eg:
> compiz --replace --use-root-window &
>
> This bug has been confirmed by many others with linked reports. Might be an
> issue with xorg since there is a report of ATI drivers with similar issues
> in https://bugs.launchpad.net/bugs/328559 .
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/fglrx/+bug/353126/+subscribe
>

Rocko (rockorequin) wrote :

The open-source ATI driver doesn't have this problem; it's only a problem with the proprietary ATI driver, so it's a problem that the Ubuntu developers cannot solve (and the same goes for the X developers).

It might therefore be worth raising the bug directly with AMD if you are experiencing it. It only took nvidia a few days to release a fixed driver when I logged the bug on their forums.

KruyKaze (kruykaze) wrote :

My apologies, I found out i was not using the "current" NVIDIA driver.It is
working fine now :)

On Thu, Oct 21, 2010 at 10:42 PM, Rocko <email address hidden> wrote:

> The open-source ATI driver doesn't have this problem; it's only a
> problem with the proprietary ATI driver, so it's a problem that the
> Ubuntu developers cannot solve (and the same goes for the X developers).
>
> It might therefore be worth raising the bug directly with AMD if you are
> experiencing it. It only took nvidia a few days to release a fixed
> driver when I logged the bug on their forums.
>
> --
> Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI
> fglrx driver using X.org
> https://bugs.launchpad.net/bugs/353126
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in AMD fglrx video driver: Confirmed
> Status in Lucid Backports: Invalid
> Status in NVIDIA Drivers Ubuntu: Fix Released
> Status in GNOME Remote Desktop: Fix Released
> Status in X.Org X server: Fix Released
> Status in “vino” package in Ubuntu: Fix Released
> Status in “xorg-server” package in Ubuntu: Fix Released
> Status in “vino” package in Fedora: Unknown
>
> Bug description:
> Binary package hint: compiz
>
> When using the nvidia-restricted or some ATI drivers and compiz desktop
> effects the vnc server will not refresh the screen. This is being caused by
> the xserver not getting "damaged" by the nvidia-restricted drivers (see
> https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/353126/comments/245for details). Linked bugs confirm this is not an issue on intel chipsets or
> nv driver.
>
> Steps to reproduce:
> Enable desktop-effects (default) with nvidia-restricted, virtualBox's
> display or some ATI driver like RV610
> Enable remote desktop
> Connect with VNC
>
> Results:
> You see a screen snapshot of your desktop but if you click a menu item
> there are no updates to the screen.
> Notes:
> If you close and restart the vnc session, you get an updated snapshot but
> still no refreshes.
>
> Workarounds:
> Use the -noxdamage argument with vncviewer. This is really inefficient and
> bandwidth hungry since the whole screen refreshes.
> Kill compiz and use a different wm (metacity).
>
> [Tested with nvidia] Run compiz with the --use-root-window option, eg:
> compiz --replace --use-root-window &
>
> This bug has been confirmed by many others with linked reports. Might be an
> issue with xorg since there is a report of ATI drivers with similar issues
> in https://bugs.launchpad.net/bugs/328559 .
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/fglrx/+bug/353126/+subscribe
>

Changed in xorg-server:
importance: High → Unknown
Changed in xorg-server:
importance: Unknown → High
Matt Marnell (mattmarnell) wrote :

I can confirm this is still an issue with Ubuntu 10.10 x64 and ATI/AMD Proprietary FGLRX graphics drivers installed.

Linux brutus 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:44 UTC 2011 x86_64 GNU/Linux

With Visual Effects enabled, I get no client-side visual refresh from VNC (using ubuntu's built-in vino server) although commands are being processed. With Visual Effects set to None, it seems to work fine.

rambamram (rami-negev) wrote :

I can confirm that I'm also having this issue on 10.10 x32 with nVidia drivers.

Was having this issue with 10.04 as well.

yes with Visual effects disabled you can get Client side info but with visual effects enabled it does not automatically disable when someone connects.

If you setup a vncserver :1 and higher the issue does not present itself...it only affects the main Desktop vncserver :0

in earlier versions there was a built in visual effects auto disable when VNC connected to the main desktop...but not since 9.14.

Kim Botherway (dj-dvant) wrote :

This is still a problem on Ubuntu 11.04:

fglrx 2:8.840-0ubuntu4
compiz 1:0.9.4+bzr20110415-0ubuntu2
vino 2.32.1-0ubuntu2
xorg 1:7.6+4ubuntu3

Josh (majik) wrote :

I am having the problem with ATI video card on 11.04.

I don't understand why this VNC server is still shipping with Ubuntu with this problem after several major releases.

This is still a problem on Ubuntu 10.10 (maverick):

kernel 2.6.25-29-generic
gnome 2.32.0
fglrx 2:8.780-0ubuntu2
compiz 1:0.8.6-0ubuntu9.2
vino 2.32.0-0ubuntu1.2
xorg 1:7.5+6ubuntu3

Bryce Nesbitt (bryce2) wrote :

Confirmed: 10.04
Removing NVida proprietary drivers, and suddenly all the windows and menus that were invisible on the remote show up.
On the local machine they were always visible.

Josh (majik) wrote :

That's because removing the driver eliminates the source of the problem along with the acceleration required to use Desktop Effects.

You might want to read the bug report before posting a comment.

Greg Michalec (greg-primate) wrote :

Unfortunately, I'm still seeing this issue in Oneric Beta 1.
Steps to reproduce:
1) log in to guest session
2) Enable Desktop Sharing
3) Open Remote Desktop Viewer
4) Open VNC connection to localhost:5900

You'll see the initial screen, and the mouse will move around, but no screen updates are made. If you repeat the steps abovem , but starting the guest session in 'Ubuntu 2D' mode, it will work as expected.

Obviously there is something incompatible between the VNC server and desktop compositing, but since Vino, Vinaigre, and Compiz are now all part of the default Ubuntu experience, it seems that the current situation will cause nothing but frustration for new users. Even if there is no programmatic solution, can't there be some sort of indication of why this won't work, or a best way to work around - i.e. maybe a notification in the Desktop Sharing preferences tool warning that sharing will not work unless you restart to a 2d session (if this is indeed the best/easiest solution).

Bryce Harrington (bryce) wrote :

This bug still exists, but we are tracking it at bug #772873; this report is a dupe of that one. I would set this as a dupe, but because this one has so many dupes on it, launchpad chokes.

Anyway, subscribe to bug #772873 if you want to follow it.

The short story is, it seems to be a bug in the fglrx driver, we're going to escalate it to AMD. Assuming it gets fixed we'll try to include the updated driver in the x-updates PPA. See bug #772873 for workarounds and more information.

Changed in fglrx:
status: Confirmed → Invalid
Evan Broder (broder) wrote :

I'm closing the maverick-backports task on this bug due to Ubuntu 10.10 (Maverick Meerkat) no longer being supported.

This bug is being closed by a bot. If you feel the change was made in error, please feel free to re-open the bug. However, backports requests for Ubuntu 10.10 (Maverick Meerkat) are no longer being accepted.

Changed in maverick-backports:
status: New → Won't Fix
Josh (majik) wrote :

I have discovered a useful workaround:

Splashtop.

It is a much more functional remote desktop solution than VNC or Vino. It has sound. You can play 3D games over it and even Second Life works beautifully.

And it's available in the Ubuntu Software Center for free.

This really should be the default remote desktop. It blows Microsoft's Remote Desktop away.

If you need a desktop client it's under "other products" on the Splashtop App download page.

MestreLion (mestrelion) wrote :

@Josh: being gratis does not mean it is free. Ubuntu, like Debian, values software freedom, so a proprietary software can ever be the default one.

Displaying first 40 and last 40 comments. View all 327 comments or add a comment.