Ubuntu

huge fonts

Reported by Fernando Miguel on 2009-02-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

After the update I got affected by the symptoms mentioned in https://wiki.ubuntu.com/JauntyJackalope/TechnicalOverview

$ xrandr --verbose
Screen 0: minimum 320 x 240, current 1280 x 800, maximum 1280 x 800
default connected 1280x800+0+0 (0x143) normal (normal) 0mm x 0mm
 Identifier: 0x142
 Timestamp: 29657
 Subpixel: unknown
 Clones:
 CRTC: 0
 CRTCs: 0
  1280x800 (0x143) 51.2MHz *current
        h: width 1280 start 0 end 0 total 1280 skew 0 clock 40.0KHz
        v: height 800 start 0 end 0 total 800 clock 50.0Hz
  1024x768 (0x144) 40.1MHz
        h: width 1024 start 0 end 0 total 1024 skew 0 clock 39.2KHz
        v: height 768 start 0 end 0 total 768 clock 51.0Hz
  960x540 (0x145) 27.0MHz
        h: width 960 start 0 end 0 total 960 skew 0 clock 28.1KHz
        v: height 540 start 0 end 0 total 540 clock 52.0Hz
  840x525 (0x146) 23.4MHz
        h: width 840 start 0 end 0 total 840 skew 0 clock 27.8KHz
        v: height 525 start 0 end 0 total 525 clock 53.0Hz
  800x600 (0x147) 25.9MHz
        h: width 800 start 0 end 0 total 800 skew 0 clock 32.4KHz
        v: height 600 start 0 end 0 total 600 clock 54.0Hz
  800x512 (0x148) 22.5MHz
        h: width 800 start 0 end 0 total 800 skew 0 clock 28.2KHz
        v: height 512 start 0 end 0 total 512 clock 55.0Hz
  720x450 (0x149) 18.1MHz
        h: width 720 start 0 end 0 total 720 skew 0 clock 25.2KHz
        v: height 450 start 0 end 0 total 450 clock 56.0Hz
  700x525 (0x14a) 20.9MHz
        h: width 700 start 0 end 0 total 700 skew 0 clock 29.9KHz
        v: height 525 start 0 end 0 total 525 clock 57.0Hz
  680x384 (0x14b) 15.1MHz
        h: width 680 start 0 end 0 total 680 skew 0 clock 22.3KHz
        v: height 384 start 0 end 0 total 384 clock 58.0Hz
  680x384 (0x14c) 15.4MHz
        h: width 680 start 0 end 0 total 680 skew 0 clock 22.7KHz
        v: height 384 start 0 end 0 total 384 clock 59.0Hz
  640x512 (0x14d) 19.7MHz
        h: width 640 start 0 end 0 total 640 skew 0 clock 30.7KHz
        v: height 512 start 0 end 0 total 512 clock 60.0Hz
  640x480 (0x14e) 18.7MHz
        h: width 640 start 0 end 0 total 640 skew 0 clock 29.3KHz
        v: height 480 start 0 end 0 total 480 clock 61.0Hz
  640x480 (0x14f) 19.0MHz
        h: width 640 start 0 end 0 total 640 skew 0 clock 29.8KHz
        v: height 480 start 0 end 0 total 480 clock 62.0Hz
  576x432 (0x150) 15.7MHz
        h: width 576 start 0 end 0 total 576 skew 0 clock 27.2KHz
        v: height 432 start 0 end 0 total 432 clock 63.0Hz
  512x384 (0x151) 12.6MHz
        h: width 512 start 0 end 0 total 512 skew 0 clock 24.6KHz
        v: height 384 start 0 end 0 total 384 clock 64.0Hz
  400x300 (0x152) 7.8MHz
        h: width 400 start 0 end 0 total 400 skew 0 clock 19.5KHz
        v: height 300 start 0 end 0 total 300 clock 65.0Hz
  320x240 (0x153) 5.1MHz
        h: width 320 start 0 end 0 total 320 skew 0 clock 15.8KHz
        v: height 240 start 0 end 0 total 240 clock 66.0Hz
$ get-edid | parse-edid
bash: get-edid: command not found
bash: parse-edid: command not found
$ xdpyinfo | grep dots
  resolution: 112x112 dots per inch

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: xorg 1:7.4~5ubuntu12
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcVersion: Linux version 2.6.28-6-generic (buildd@crested) (gcc version 4.3.3 (Ubuntu 4.3.3-3ubuntu1) ) #17-Ubuntu SMP Fri Jan 30 15:35:08 UTC 2009

SourcePackage: xorg
Uname: Linux 2.6.28-6-generic x86_64

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 03)
     Subsystem: ASUSTeK Computer Inc. Device [1043:8261]
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8400M G [10de:0428] (rev a1) (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Device [1043:8265]

Richard Seguin (sectech) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. As this issue has been already identified within the release notes as being a problem this particular report is fairly redundant. I encourage you to search launchpad for the main report for this issue and follow that, this report would end up getting marked as a duplicate of that one anyway.

Thanks,

Richard Seguin

Changed in xorg:
status: New → Won't Fix

Richard please allow me to disagree.

The wiki page states that any system fails to use a proper size for the fonts, should be reported to allow it to be fix(by means of a quirk, I would guess) so that users of the stable release will not face the same issue as I did.
I've provided all the debug information I thought was required. If any other log is needed please let me know. Thanks.

 status new

--
Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

Changed in xorg:
status: Won't Fix → New
Bryce Harrington (bryce) on 2009-02-13
Changed in xorg:
importance: Undecided → Medium
status: New → Triaged
Bryce Harrington (bryce) on 2009-03-06
description: updated
Alexander Dahl (lespocky) wrote :

Same problem here with daily snapshot installer CD for Kubuntu jaunty from 2009-03-21: really (!!) huge font sizes in kdm and kde itself, round about four lines for the whole screen!

I use an AMD/ATI onboard graphics 3200 HD and a Samsung SyncMaster 2333HD monitor. It works fine with another monitor so I assume it's the monitor reporting wrong information. Monitor is connected via analog VGA cable (no other available).

I'll attach the Xorg.0.log and the output of `xrandr --verbose` and hope this will be fixed until release. :-)

Alexander Dahl (lespocky) wrote :
Alexander Sack (asac) wrote :

please consider to test "ubuntu" dailies (not kubuntu) ... we switched to "pixel" sized fonts by default in gnome now so they should be better on high dpi screens.

Some apps have regressions from it, but the general gnome desktop and most gtk apps should be fine if they dont do their own font handling. see bug 345189 which tracks the regressions.

Let us know.

Tormod Volden (tormodvolden) wrote :

LeSpocky, please file a separate bug for your specific monitor so that we can fix that issue.

BUGabundo, I think the DPI is correctly detected from your monitor, so it is just the issue of "excessively large fonts" in bug 345189. Note the nuance, if we say "huge font" we mean huge, like several centimeters :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers