Ubuntu

xvfb missing dependency on xserver-core-core

Reported by ais77 on 2008-11-06
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xvfb

Xvfb installed from official repo on Hardy server gives multiple errors on startup.
Description: Ubuntu 8.04.1
Release: 8.04
First 3 lines are unexplanable to me, the most of others are related to fonts (why don't they install during package installation if package requres them?) and the very lst one - looks very strange:
----------------
:~$ Xvfb :0
expected keysym, got XF86KbdLightOnOff: line 70 of pc
expected keysym, got XF86KbdBrightnessDown: line 71 of pc
expected keysym, got XF86KbdBrightnessUp: line 72 of pc
Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
Could not init font path element /usr/share/fonts/X11/100dpi/:unscaled, removing from list!
Could not init font path element /usr/share/fonts/X11/Type1, removing from list!
Could not init font path element /usr/share/fonts/X11/100dpi, removing from list!
Could not init font path element /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType, removing from list!
[config/hal] couldn't initialise context: (null) ((null))
----------------
Those errors appear every time any application connects to Xvfb service.

After Xvfb shutdown also every time appears another error:
----------------
FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.
----------------
SUMMARY:
It seems that xvfb package assumes to be installed on desktop (X-server enabled) Ubuntu version only.
Question to mantainers - are all needed packages and paths doublecheked to be relevant for server version too?

ais77 (greenais) on 2008-11-06
description: updated
ais77 (greenais) on 2008-11-06
description: updated
Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi greenais,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Changed in xorg-server:
status: New → Incomplete
ais77 (greenais) wrote :

Situation gets even worse - after clean reinstall Ubuntu server 8.10 and Xvfb from actual repos I've got Xvfb process hanged with 95% CPU load and no success with killing it:

ais77@sev77u:~$ top
  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
10190 root 20 0 22748 18m 15m R 94.4 3.7 63:56.40 Xvfb
...

ais77@sev77u:~$ ps -C Xvfb
  PID TTY TIME CMD
10190 ? 00:03:12 Xvfb
ais77@sev77u:~$ sudo killall Xvfb
ais77@sev77u:~$ ps -C Xvfb
  PID TTY TIME CMD
10190 ? 00:03:24 Xvfb
ais77@sev77u:~$ sudo killall Xvfb
ais77@sev77u:~$ sudo killall Xvfb
ais77@sev77u:~$ ps -C Xvfb
  PID TTY TIME CMD
10190 ? 00:06:17 Xvfb
ais77@sev77u:~$ sudo killall -v -w Xvfb
Killed Xvfb(10190) with signal 15

and killall hangs sinding SIGTERM too...
Any idea how to kill it?

On clean installed (as mentioned) system there is no /var/log/Xorg.0.log, neither /var/log/Xorg.0.log files at all.
ais77@sev77u:~$ ls /var/log
apparmor debug installer mail.warn unattended-upgrades
apt dist-upgrade kern.log messages user.log
aptitude dmesg landscape news vsftpd.log
auth.log dmesg.0 lastlog pycentral.log wtmp
boot dmesg.1.gz lpr.log samba
btmp dpkg.log mail.err syslog
ConsoleKit faillog mail.info syslog.0
daemon.log fsck mail.log udev

ais77@sev77u:~$ ls /etc/X11
fonts xkb Xresources Xsession Xsession.d Xsession.options Xwrapper.config
lspci -vvnn output is attached.

Xvfb was started by
/usr/bin/X11/Xvfb :10.10 -screen 10 800x600x16 -ac -br -kb -c -fbdir /var/tmp
/ &

ais77 (greenais) on 2008-11-26
Changed in xorg-server:
status: Incomplete → Confirmed
ais77 (greenais) wrote :

Are there any mantainer activities to solve this bug? How to check?

xvfb doesn't work on Intrepid Server still.
I can guess that there not so many changes in package are needed, but I don't know wich ones to do it myself..
Please update status.

Changed in xorg-server:
assignee: nobody → bryceharrington
ais77 (greenais) wrote :

Responce is needed

Bryce Harrington (bryce) on 2009-01-15
Changed in xorg-server:
assignee: bryceharrington → nobody
Bryce Harrington (bryce) wrote :

You need to do some further work on this bug report before it can be investigated. Detail the exact steps you follow for reproducing the problem. You've not included some form of run log (typically Xorg.0.log but perhaps xvfb uses something different), which is always required before we will begin looking at a bug.

Further, we generally ask that people focus one bug report per distinct issue, however you've mentioned several different things and it's unclear which specific one you want to be investigated. In your original report, most of the warnings you list are basically harmless and usually always appear. The one about hal not being initialized sounds unusual; that one isn't an X problem, but could potentially cause problems in getting X to work if hal isn't running.

Changed in xorg-server:
status: Confirmed → Incomplete
Stefan Baramov (s-baramov) wrote :

Hello
I am experiencing exactly the same problem. I have a tomcat6 (comes with Ubuntu Server) with Hudson (http://hudson.dev.java.net) running continuous build of a Eclipse based product. After every build the Xvfb process goes to 99% CPU usage. The only work around I can find is to kill Xvfb on regular bases.

To reproduce the problem follow these steps:

1. Setup a Ubuntu 8.10 sever with open JDK 6 and Tomcat6. These are standard installation options of Ubuntu Server.

2. Install gtk packages:
> dpkg -l | grep gtk
ii libgtk2.0-0 2.14.4-0ubuntu1 The GTK+ graphical user interface library
ii libgtk2.0-bin 2.14.4-0ubuntu1 The programs for the GTK+ graphical user int
ii libgtk2.0-common 2.14.4-0ubuntu1 Common files for the GTK+ graphical user int

3. Install xvfb package
> dpkg -l | grep xvfb
ii xvfb 2:1.5.2-2ubuntu3 Virtual Framebuffer 'fake' X server

4. Run the Xvfb server like this :
> Xvfb :99 -screen 0 1024x768x24 -fbdir /var/run

5. Set display
> export DISPLAY=localhost:99.0

6. Run the Notepad.jar demo from the OpenJdk demo pacakge (openjdk-6-demo package):
> java -jar /usr/lib/jvm/java-6-openjdk/demo/jfc/Notepad/Notepad.jar

7 Kill the Notepad.jar process

At this point the Xvfb goes to 99% CPU usage. It stops working normally. It does not produce Xorg.0.log log file as one will expect from a xserver. So very difficult to say what is going on.

Thanks
Stefan

ais77 (greenais) wrote :

Bug update
[*** copy-paste from previous posts - presonally for Bryce Harrington ***]

Binary package hint: xvfb

Xvfb installed from official repo on Hardy server gives multiple errors on startup
[*** THIS IS the main issue to work on - notice for Bryce Harrington ***].

Description: Ubuntu 8.04.1 (server)
Release: 8.04

EXACT steps to reproduce the issue:
[*** notice for Bryce Harrington - how to install and run xvfb on Intrepid server ***]

1. Install Ubuntu 8.04.1 (server)
2. Update and upgrade system
~$ apt-get update
~$ apt-get upgrade
3. Install xvfb
~$ apt-get install xvfb
4. run xvfb (as either one of follows)
~$ Xvfb :0
or
/usr/bin/X11/Xvfb :10.10 -screen 10 800x600x16 -ac -br -kb -c -fbdir /var/tmp/ &
5. run ANY application wich uses (X) xvfb, i.e.:
~$ wine notepad

Outpun in stdout:

[*** First 3 lines are unexplanable to me, the most of others are related to fonts (why don't they install during package installation if package requres them?) and the very lst one - looks very strange:***]

----------------
:~$ Xvfb :0
expected keysym, got XF86KbdLightOnOff: line 70 of pc
expected keysym, got XF86KbdBrightnessDown: line 71 of pc
expected keysym, got XF86KbdBrightnessUp: line 72 of pc
Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
Could not init font path element /usr/share/fonts/X11/100dpi/:unscaled, removing from list!
Could not init font path element /usr/share/fonts/X11/Type1, removing from list!
Could not init font path element /usr/share/fonts/X11/100dpi, removing from list!
Could not init font path element /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType, removing from list!
[config/hal] couldn't initialise context: (null) ((null))
----------------

Those errors appear every time any application connects to Xvfb service.
After Xvfb shutdown also every time appears another error:

----------------
FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.
----------------

SUMMARY:
It seems that xvfb package assumes to be installed on desktop (X-server enabled) Ubuntu version only.
Question to mantainers - are all needed packages and paths doublecheked to be relevant for server version too?

LOG FILES:
[*** Highlight notice for Bryce Harrington ***]

On clean installed (as mentioned) system there is no /var/log/Xorg.0.log, neither /var/log/Xorg.0.log files at all.
Output of confirmation commands is listed below:

~$ ls /var/log
apparmor debug installer mail.warn unattended-upgrades
apt dist-upgrade kern.log messages user.log
aptitude dmesg landscape news vsftpd.log
auth.log dmesg.0 lastlog pycentral.log wtmp
boot dmesg.1.gz lpr.log samba
btmp dpkg.log mail.err syslog
ConsoleKit faillog mail.info syslog.0
daemon.log fsck mail.log udev

~$ ls /etc/X11
fonts xkb Xresources Xsession Xsession.d Xsession.options Xwrapper.config

Requested lspci -vvnn output was also attached in previuos post.

Nothing else was requsted.

SUMMARY 2:
Bryce, have you ever looked at my reply (2008-11-17) on your request?

Changed in xorg-server:
status: Incomplete → Confirmed

I just ran into this. Same problems as everyone else. Started with a fresh install and started working towards the headless testing of Swing apps using Xvfb.

When firing up the GUI unit test, Xvfb starts spinning at 100% CPU indefinitely. Java process hangs.

I compared the /etc/X11 dirs from my working Gutsy install and noticed that xinit and xdb where missing on Intrepid.

Because I've been at this for so damn long I just did an "aptitude install xorg" and installed the whole damn X11 stack. Bouncing Xvfb and retrying the Java process shows that this has fixed the problem. I can't be sure which part of the X11 was missing.

bugmenot (bugmenot) wrote :

*** WORKAROUND ***

install libgl1-mesa-dri

xvfb gets itself into a fuss that it can't find the dri extension and will just CPU spin until killed off. Installing libgl1-mesa-dri will fix this particular issue... xvfb should probably be made dependent on dri or the default config changed.

velo (velo-br) wrote :

I tried the suggested workaround, but still no success......

Anything else people recommend to fix/workaround this problem?

VELO

Bryce Harrington (bryce) on 2009-08-13
tags: added: hardy
Matthias Klose (doko) wrote :

this seems to be fixed in 1.6 (karmic)

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

wrong report ...

Changed in xorg-server (Ubuntu):
status: Fix Released → Confirmed
Adam Nelson (adam-varud) wrote :

Here is the current reproducibility for Karmic (9.10) on a fresh install from a clean Canonical installation:

 1. Install Canonical's 64-bit stock AMI ami-ab15f6c2 from http://alestic.com/
 2. Run sudo apt-get update && sudo apt-get upgrade
 3. Install Xvfb: sudo apt-get install xvfb
 4. Install workaround to get rid of one of the errors, "(EE) AIGLX error: dlopen of /usr/lib/dri/swrast_dri.so failed (/usr/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory)": sudo apt-get install libgl1-mesa-dri
 5. Run: sudo Xvfb :42 -screen 0 640x480x24

----- Messages from Xvfb -----------
[dix] Could not init font path element /usr/share/fonts/X11/misc, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/100dpi/:unscaled, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/75dpi/:unscaled, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/Type1, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/100dpi, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/75dpi, removing from list!
sh: /usr/bin/xkbcomp: not found
(EE) Error compiling keymap (server-42)
(EE) XKB: Couldn't compile keymap
[config/dbus] couldn't take over org.x.config: org.freedesktop.DBus.Error.AccessDenied (Connection ":1.74" is not allowed to own the service "org.x.config.display42" due to security policies in the configuration file)
(EE) config/hal: couldn't initialise context: unknown error (null)

Expected results:

 1. Fonts used by default by Xvfb should be installed by apt-get install xvfb
 2. Other errors which may be caused by AppArmor? shouldn't be happening on a fresh system.

Adam Nelson (adam-varud) wrote :

Run: sudo apt-get install x11-xkb-utils

To get rid of these errors:

sh: /usr/bin/xkbcomp: not found
(EE) Error compiling keymap (server-42)
(EE) XKB: Couldn't compile keymap

Adam Nelson (adam-varud) wrote :

In addition these install the fonts used by xvfb:

sudo apt-get install xfonts-100dpi xfonts-75dpi xfonts-scalable xfonts-cyrillic

and will get rid of these errors:

[dix] Could not init font path element /usr/share/fonts/X11/misc, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/100dpi/:unscaled, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/75dpi/:unscaled, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/Type1, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/100dpi, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/75dpi, removing from list!

Adam Nelson (adam-varud) wrote :

And this solves the error "(EE) config/hal: couldn't initialise context: unknown error (null)":

sudo apt-get install xserver-xorg-core

I know this is a big package, but I think it should be a dependency of xvfb in order to make it consistently work if the underlying problem can't be found.

summary: - xvfb on server gives multiple errors
+ xvfb missing dependency on xserver-core-core
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi ais77,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 294454

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 294454 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/294454

Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg-server (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments