Ubuntu

System bell crashes X in ProcBell

Reported by DannyKing on 2008-09-16
8
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

All of a sudden, after working fine all day (and in fact, all month) my install of Hardy has an odd bug concerning what I think must be the system bell:

Whenever I press tab in a terminal (I have tried in gnome-terminal and xterm) my X server restarts! It also restarts if I press delete and there is no text left to delete in the terminal. The only thing that happens in both those situations is the beep, so I disabled the bell in /etc/inputrc and that has stopped the crashing.

I don't know what suddenly caused this issue, but it was working perfectly and then suddenly started to have this problem. A bug fix would be great because this is pretty serious but if someone could offer a short term fix I would appreciate it too.

Thanks

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x7e) [0x80c780e]
1: [0xb7fb2420]
2: /usr/bin/X(ProcBell+0x13c) [0x808386c]
3: /usr/bin/X [0x815076e]
4: /usr/bin/X(Dispatch+0x2cf) [0x808d8df]
5: /usr/bin/X(main+0x48b) [0x807471b]
6: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7d3f450]
7: /usr/bin/X(FontFileCompleteXLFD+0x201) [0x8073a91]

Fatal server error:
Caught signal 11. Server aborting

lukyluke (luca-tagliacozzo) wrote :

Same behaviour, please read the detailed description here: http://ubuntuforums.org/showthread.php?p=5879943#post5879943

I think it is an issue between the Xserver and the wacom X server module.

Find the log of the crash attached

lukyluke (luca-tagliacozzo) wrote :

Just a comment.
I reinstalled kubuntu amd64 with the same repositories and hardware and now everything is working, no bell bugs.
It looks like a bug related to the 32 bit version, can you please DannyKing confirm you are using a 32 bit installation?

DannyKing (dannyking) wrote :

Yes, I confirm that I am running Hardy 32 bit.

Bryce Harrington (bryce) on 2008-12-05
description: updated
Bryce Harrington (bryce) wrote :

Please collect a full backtrace on this crash. See http://wiki.ubuntu.com/X/Backtracing for directions.

Changed in xorg:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg-server:
status: Incomplete → Invalid

As I werote in my case the bug went away by switching to the 64 bit
installation,
I am not able to test it with the current 32 bit version for time reasons,
sorry for that.

Regards
Luca

On Fri, Jan 9, 2009 at 4:00 PM, Bryce Harrington
<email address hidden>wrote:

>
> We're closing this bug since it is has been some time with no response from
> the original reporter. However, if the issue still exists please feel free
> to reopen with the requested information. Also, if you could, please test
> against the latest development version of Ubuntu, since this confirms the
> bug is one we may be able to pass upstream for help.
>
>
> ** Changed in: xorg-server (Ubuntu)
> Status: Incomplete => Invalid
>
> --
> System bell crashes X in ProcBell
> https://bugs.launchpad.net/bugs/270790
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I have to reopen this bug, because I can reproduce it. Ubuntu Intrepid, xserver-xorg 1:7.4~5ubuntu3, xserver-xorg-input-wacom 1:0.8.1.6-1ubuntu2.

The backtrace is the same. xset -b doesn't help.

Changed in xorg-server:
status: Invalid → New
Bryce Harrington (bryce) wrote :

If you want to reopen it, we still must have a backtrace. See http://wiki.ubuntu.com/X/Backtracing for directions.

Changed in xorg-server:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments