Wrong resolution for DVI connected Monitor on startup [X3100 GMA]

Bug #221297 reported by nclm on 2008-04-24
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Invalid
High
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I have a Thinkpad T61 with an Intel X3100 GMA. I also have the advanced mini dockingstation with a DVI connector. The Problem is that the intel graphics driver seems to prioritize the "wrong" way. VGA comes first, then LVDS and then TMDS-1. So when I boot up with the laptop docked in and the external monitor connected to TMDS-1 I'll get only the resolution of the internal monitor (WXGA) instead of SXGA+.

Everytime this happens I must execute "xrandr --output TMDS-1 --auto --output LVDS --off".

Strange to say VGA comes first so when I connect my Monitor via VGA instead of DVI everything applies as expected.

nclm (nclm) wrote :

Intel driver version is 2.2.1-1ubuntu12 on hardy

This xorg problem is wide-spread - it affects many different video types.

I started with a nVidia gForce2 MX440; but could never get the resolution above 800X400. I pulled out the card and went with the onboard Vesa - same problem. Fortunately I had an "old" xorg.conf with all of the settings defined. I plugged it in and success 1024X768

I won't go through all of the tips and tricks I tried, including a failed attempt at installing the gutsy version of xorg - BUT the conclusion is that xorg.conf is NOT being created correctly and is missing most of the settings.

Another PC using gutsy.beta.5 was OK - this problem happened with this week's gutsy.RC - a BIG Uh-Oh! Maybe it's just affecting LCD screens?

Sorry - it's late - that should have said "Hardy.Beta.5" and "this week's Hardy.RC" - and it's the Kubuntu version.

Bryce Harrington (bryce) wrote :

Please attach your /var/log/Xorg.0.log showing the failure, and the /etc/X11/xorg.conf you found made it work.

Changed in xserver-xorg-video-intel:
status: New → Incomplete
nclm (nclm) wrote :
nclm (nclm) wrote :

The xorg.conf is an initial version of 8.04. No changes from me.

I think in Xorg.0.log you can the TMDS-1 comes last:

(II) intel(0): Output VGA disconnected
(II) intel(0): Output LVDS connected
(II) intel(0): Output TMDS-1 connected
(II) intel(0): Output LVDS using initial mode 1280x800
(II) intel(0): Output TMDS-1 using initial mode 1152x864

Bryce Harrington (bryce) on 2008-05-01
Changed in xserver-xorg-video-intel:
importance: Undecided → Medium
status: Incomplete → Triaged
kabuchin (karbunkle) wrote :

I have a ViewSonic 2035wm monitor, an nVidia 8800GTS video card. On a fresh ubuntu 8.04 install, x doesn't detect my monitor. The only thing I was able to do is select a flat panel 1280x1024 and use 1024x768 resoluion.
However, i switched the DVI cable for a analog VGA cable, restarted and Ubuntu booted up in native 1680x1050 resolution.

Forwarding a Ubuntu bug report...
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/221297

"I have a Thinkpad T61 with an Intel X3100 GMA. I also have the advanced mini dockingstation with a DVI connector. The Problem is that the intel graphics driver seems to prioritize the "wrong" way. VGA comes first, then LVDS and then TMDS-1. So when I boot up with the laptop docked in and the external monitor connected to TMDS-1 I'll get only the resolution of the internal monitor (WXGA) instead of SXGA+.

Everytime this happens I must execute "xrandr --output TMDS-1 --auto --output LVDS --off".

Strange to say VGA comes first so when I connect my Monitor via VGA instead of DVI everything applies as expected.

I think in Xorg.0.log you can the TMDS-1 comes last:

(II) intel(0): Output VGA disconnected
(II) intel(0): Output LVDS connected
(II) intel(0): Output TMDS-1 connected
(II) intel(0): Output LVDS using initial mode 1280x800
(II) intel(0): Output TMDS-1 using initial mode 1152x864"

Xorg.0.log: http://launchpadlibrarian.net/13926564/Xorg.0.log
xorg.conf: http://launchpadlibrarian.net/13926614/xorg.conf

Bryce Harrington (bryce) wrote :

Hi nclm,

I've forwarded this bug upstream to X.org: http://bugs.freedesktop.org/show_bug.cgi?id=16704

Please go ahead and subscribe to that bug report in case upstream needs further information or has something for you to test.

Changed in xserver-xorg-video-intel:
importance: Undecided → Unknown
status: New → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed

This should be a server issue.

Bryce Harrington (bryce) wrote :

Upstream says it's a server issue, so refiling accordingly.

sonderlich (sonderlich) wrote :

I experience the same as kabuchin. In my case, I have an onboard intel X3100 graphics chipset, with a Pci-E DVI adapter card (in a thinkcentre A57 desktop). When I connect it to a TFT, I get a maximum resolution of 1280x800, connected with an analog VGA cable, I can use the native resolution of 1920x1200. I am using ubuntu hardy with no modification to xorg.conf ('out of the box', modulo updates). When connected via dvi, the TFT gets recognized correctly, as ddcprobe reveals.

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi nclm,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 221297

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 221297 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/221297

Changed in xorg-server (Ubuntu):
status: Triaged → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) on 2010-07-10
tags: added: hardy
Changed in xserver-xorg-video-intel:
importance: Unknown → High
Changed in xserver-xorg-video-intel:
importance: High → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → High

nclm, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg-server REPLACE-WITH-BUG-NUMBER

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: removed: needs-retested-on-lucid-by-june
Changed in xorg-server (Ubuntu):
importance: Medium → Low

This wants a more nuanced design discussion.

Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.