Cursor bleeds on the platform with Mali armsoc driver

Bug #1920096 reported by ethan.hsieh
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Status tracked in Focal
Focal
Critical
Unassigned
xorg-server (Ubuntu)
High
Unassigned

Bug Description

[Impact]

The cursor bleeds because of the bug in xorg which does not refresh the sprite background. (LP: #1911479)
The issue happens to Xilinx zcu102/104/106 boards (arm64, mali gpu).

[Test Case]

Check if cursor is still bleeding with the patched xorg-server

[ Regression potential ]

The new function, miDCSaveUnderCursor2, is only used by Xilinx armsoc driver.
It won't impact other platforms.

---
Xilinx is trying to upstream the patch. It's still under review.
https://lists.x.org/archives/xorg-devel/2021-March/058672.html

Revision history for this message
ethan.hsieh (ethan.hsieh) wrote :

debdiff for hirsute

Revision history for this message
ethan.hsieh (ethan.hsieh) wrote :

debdiff for focal

description: updated
Revision history for this message
ethan.hsieh (ethan.hsieh) wrote :

The issue is fixed by the attached patch in comment#1 and #2.
Please help to review and integrate it to hirsute and focal.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "xorg-server_1.20.10-3ubuntu4.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in oem-priority:
importance: Undecided → High
importance: High → Critical
description: updated
Mathew Hodson (mhodson)
Changed in xorg-server (Ubuntu):
importance: Undecided → High
tags: added: hirsute
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

it would be best to use the latest version of the patch from the list, with the explanation added

Revision history for this message
ethan.hsieh (ethan.hsieh) wrote :

debdiff for hirsute

Revision history for this message
ethan.hsieh (ethan.hsieh) wrote :

debdiff for focal

Rex Tsai (chihchun)
tags: added: oem-priority
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

did you try that it builds?

Revision history for this message
ethan.hsieh (ethan.hsieh) wrote :

@Timo

I got the attached patch from [1] and found it has duplicate content.

---
[1] https://launchpad.net/ubuntu/+source/xorg-server/2:1.20.10-3ubuntu6

Revision history for this message
ethan.hsieh (ethan.hsieh) wrote :

I built the package in my local machine without problems.

The issue in [1] is caused by the duplicate content in the attached patch (comment#9).

In file included from ../../../../mi/misprite.c:48:
../../../../mi/mipointer.h:132:23: warning: redundant redeclaration of ‘miDCSaveUnderCursor2’ [-Wredundant-decls]
  132 | extern _X_EXPORT void miDCSaveUnderCursor2(ScreenPtr pScreen);
      | ^~~~~~~~~~~~~~~~~~~~
../../../../mi/mipointer.h:130:23: note: previous declaration of ‘miDCSaveUnderCursor2’ was here
  130 | extern _X_EXPORT void miDCSaveUnderCursor2(ScreenPtr pScreen);
      | ^~~~~~~~~~~~~~~~~~~~

../../../../mi/misprite.c:977:1: error: redefinition of ‘miDCSaveUnderCursor2’
  977 | miDCSaveUnderCursor2(ScreenPtr pScreen)
      | ^~~~~~~~~~~~~~~~~~~~
../../../../mi/misprite.c:960:1: note: previous definition of ‘miDCSaveUnderCursor2’ was here
  960 | miDCSaveUnderCursor2(ScreenPtr pScreen)

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

ok, something weird happened, will fix :)

Rex Tsai (chihchun)
tags: added: xilinx
Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue was fixed in hirsute I believe but it referenced the wrong launchpad bug so didn't get closed, right?

Changed in xorg-server (Ubuntu):
status: New → Fix Released
Revision history for this message
Rex Tsai (chihchun) wrote :

I believe Timo and Ethan are working on SRU the changes back to focal for an OEM project.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

yeah it referenced the private bug, and I didn't notice it

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

we'll backport the hirsute version to focal

Revision history for this message
John Agosta (jagosta) wrote :

@Timo, any ETA for when this would land into Focal? thanks.

Rex Tsai (chihchun)
Changed in oem-priority:
assignee: nobody → ethan.hsieh (ethan.hsieh)
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

it's in focal-proposed now

tags: added: originate-from-1911479
Revision history for this message
John Agosta (jagosta) wrote :

Timo, Do you have an ETA when this would be released to focal-update?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers