OpenGL not detected (Intel Ivy Bridge + Nvidia GeForce GT 635M)

Bug #1875113 reported by Juan Pedraza on 2020-04-26
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

The screen presents screen tearing in the browser, on the desktop as well and when installing Steam it says that it does not detect Opengl or any video card

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.4.0-26.30-generic 5.4.30
Uname: Linux 5.4.0-26-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Es un directorio: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 390.132 Fri Nov 1 00:40:14 PDT 2019
 GCC version:
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
BootLog: Error: [Errno 13] Permiso denegado: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sat Apr 25 20:01:32 2020
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. 3rd Gen Core processor Graphics Controller [1043:100d]
 NVIDIA Corporation GF108M [GeForce GT 635M] [10de:0de3] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. GF108M [GeForce GT 635M] [1043:100d]
InstallationDate: Installed on 2020-04-24 (1 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
MachineType: ASUSTeK COMPUTER INC. K46CM
ProcEnviron:
 LANGUAGE=es_CO:es
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-26-generic root=UUID=2d00d17e-c566-412e-bdfd-529af92571e2 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/17/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K46CM.317
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K46CM
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK46CM.317:bd05/17/2013:svnASUSTeKCOMPUTERINC.:pnK46CM:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnK46CM:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: K
dmi.product.name: K46CM
dmi.product.sku: ASUS-NotebookSKU
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
nvidia-settings:
 ERROR: Unable to load info from any available system

 ERROR: Unable to load info from any available system
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Juan Pedraza (juan-pedraza) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the log has

Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

What video card is enabled on your system?

Daniel van Vugt (vanvugt) wrote :

Hmm, Nvidia recommends driver version 390 for your GeForce GT 635M and that's what you have...

affects: xorg (Ubuntu) → xorg-server (Ubuntu)
tags: added: nvidia
summary: - Opengl no detected
+ OpenGL not detected (Intel Ivy Bridge + Nvidia GeForce GT 635M)
Juan Pedraza (juan-pedraza) wrote :

Yes, I have the Nvidia Geforce GT 635M card, too (it is supposed), I have the proprietary drivers for the card, since I did the installation of Ubuntu 20.04 from scratch and in the installation I assigned the option of third-party and proprietary software, for On the other hand, in the "more controllers" option, the option marked with the proprietary driver appears, but when installing applications such as steam or Anydesk, I get initially that does not support OpenGL

Daniel van Vugt (vanvugt) wrote :

This might be some kind of misconfiguration of the proprietary Nvidia driver. Please try:

 1. Uninstall the Nvidia driver and reboot.

 2. Reinstall the Nvidia driver and reboot.

If that doesn't fix the problem then maybe you don't really need the proprietary driver so just do:

 1. Uninstall the Nvidia driver and reboot.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Incomplete
Changed in xorg-server (Ubuntu):
status: New → Incomplete
Juan Pedraza (juan-pedraza) wrote :

I already did it, now I get other errors:

1. Now it says that Nvidia NV-CONTROL X extension does not detect it

Gtk-CRITICAL **: 23: 12: 30.049: IA__gtk_widget_set_tooltip_markup: assertion 'GTK_IS_WIDGET (widget)' failed

Gtk-CRITICAL **: 23: 12: 30.062: IA__gtk_signal_connect_full: assertion 'GTK_IS_OBJECT (object)' failed

Daniel van Vugt (vanvugt) wrote :

Nvidia controls are not expected to work if the proprietary Nvidia driver is not installed.

I suggest just uninstalling the Nvidia driver and leaving it that way. If something doesn't work after that then please open a new bug to cover the new problem.

Juan Pedraza (juan-pedraza) wrote :

By uninstalling the Nvidia driver, the OS will still use the card with the free drivers, or will the video card be left unused on my computer?

Daniel van Vugt (vanvugt) wrote :

Yes the free driver (called "nouveau") should work well on your system, I think.

Juan Pedraza (juan-pedraza) wrote :

ok, got it

Launchpad Janitor (janitor) wrote :

[Expired for nvidia-graphics-drivers-390 (Ubuntu) because there has been no activity for 60 days.]

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for xorg-server (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg-server (Ubuntu):
status: Incomplete → Expired
Jhosman Lizarazo (jhosman) wrote :

I'm too affected, please review.

Thanks

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Expired → Opinion
Changed in xorg-server (Ubuntu):
status: Expired → Opinion
Daniel van Vugt (vanvugt) wrote :

Please open your own new bug by running:

  ubuntu-bug gnome-shell

This bug should stay closed.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Opinion → Invalid
Changed in xorg-server (Ubuntu):
status: Opinion → Invalid
Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Invalid → Won't Fix
Changed in xorg-server (Ubuntu):
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers