Displaylink is extremely slow in Xorg sessions

Bug #1875015 reported by Krisztian Poos
302
This bug affects 57 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
New
Unknown
OEM Priority Project
New
Undecided
Unassigned
X.Org X server
Fix Released
Unknown
xf86-video-amd
Fix Released
Unknown
xorg-server (Ubuntu)
Fix Released
Medium
Unassigned
Focal
Fix Released
Medium
Dave Walker
Hirsute
Won't Fix
Medium
Dave Walker
Impish
Fix Released
Medium
Unassigned
Jammy
Fix Released
Medium
Unassigned
xserver-xorg-video-amdgpu (Ubuntu)
Fix Released
Medium
Łukasz Spintzyk
Jammy
New
Medium
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
In Progress
Medium
Łukasz Spintzyk
Jammy
New
Medium
Unassigned

Bug Description

Using ubuntu 20.04 on displaylink docking with external monitor is totally slow, unusable. The GUI responds very slow, if you click, the command of the click goes on after about 3 seconds... if you type, all the letters are with the same lag, so it is totally unusable.

Was using displaylink without any problem on 19.10 until yesterday, when I upgraded to 20.04.
It is terrific.

If i plug out the usb for the displaylink docking station, than the speed is back, and the system is ok, if I connect it to the docking station again, everything extremely slow again.

Please investigate this asap, as it is unusable on displaylink docking stations.

tags: added: 20.04 displaylink docking station ubuntu
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1875015/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
Allan (allan-cairns) wrote :

My problem is not as severe as OP but DisplayLinkManager is usually my highest cpu burner swinging between 20% and 100%. Idling it takes around 18%

tags: added: focal
Revision history for this message
Mario Sánchez Prada (mariospr) wrote :

Same problem here, with a DisplayLink dock station and a Thinkpad P1 (1st gen) with the NVIDIA (Quadro P2000) card disabled, running only on the iGPU that comes with my Xeon E-2176M CPU.

It's so unusable that I basically had to move back to using an NVIDIA-only mode and plug the screen directly over the laptop's HDMI port, which makes now the dock station a "glorified pots hub" :-).

This said, I believe this is in general a known issue of the DisplayLink drivers for Linux, and not necessarily related to Ubuntu or the Linux kernel. Reporting anyway in case I'm wrong and there's a chance to make this work properly, which would be awesome for many reasons (e.g. I could go back to the iGPU-only mode).

Hope this helps, and thanks!

Revision history for this message
Krisztian Poos (rocky-poos) wrote :

New Displaylink driver is out now:
https://support.displaylink.com/knowledgebase/articles/1944022-how-to-install-displaylink-software-on-ubuntu-20-0

However on my Thinkpad T480 and Lenovo USb3 Ultra Dock it is still not perfect, still I have 1sec lag.

But I think, this is now displayLink driver related, not an ubuntu related issue, so this butg can be closed? .

Revision history for this message
Caitifty (caitifty) wrote :

I can confirm the OPs dismal experience on a brand new dell xp13 with a fresh install of 20.04 and the latest (May 5) displaylink driver 5.3.1. But I agree with Krisztian that this is a displaylink issue not an ubuntu issue..

Revision history for this message
Tobias Römer (troem) wrote :

I can confirm this issue on Toshiba notebook as well: fresh upgrade to 20.04. Before on 19.10 it was working fine. Now it is very very slow.

Revision history for this message
TomeK (tkanik) wrote :

Same as above guys, I can confirm this issue on Lenovo X1 Carbon gen 7 notebook. Problem appear after upgrade from 19.10 to 20.04 LTS. Using ubuntu 20.04 on DisplayLink docking with an external monitor is totally unusable. The GUI responds so slow that if you click, the command of the click goes on after about 4-5 seconds. If you type, all the letters are with the same lag, so it is totally unusable. If I plug out the USB for the DisplayLink docking station, then the speed is back, and the system is ok if I connect it to the docking station again, everything extremely slow again.

Revision history for this message
Jerome (jsimons8) wrote :

Same here, I can confirm this issue on a Lenovo Yoga 15IKB. I also upgraded from 19.10 to 20.04 LTS and had extremely snappy displaylink support which now ground to a halt. Hopefully, this gets fixed soon? I am happy to help in any way I can.

Revision history for this message
Mike Bartlet (bartlet7827) wrote :

Upgraded from ubuntu 18.04 to 20.04 today and was happy that DisplayLink finally started to work. Well, that is until I realised how totally unusable it was! Exactly the same experience as the other posters. I'm using an Acer Aspire V5 with a DisplayLink D3100 device and dual monitors.

Then I noticed something very interesting. If I also plugged in a monitor to the VGA output, everything works perfectly. As soon as I unplug the VGA monitor, it is unusable again. While not ideal, this is a reasonable work-around for me until the bug is fixed.

The down-side of this workaround for me is that the VGA output is plugged into a VGA input of one of my monitors. So although ubuntu thinks I have 3 monitors, there are only two. This means if I launch an app and it goes to the VGA output, I can't see it. It takes a bit of fiddling around to drag it to the DisplayLink output.

Looking forward to this bug being fixed.

Revision history for this message
Leonardo Carvalho (leonardocarvalho) wrote :

Improving Mike's above feedback, I've realized that connecting the external monitor directly to the laptop HDMI port really make things run normally, but when I turned off the OS extend desktop to external monitor function(HDMI), I can keep the Docktation connected with 2 monitors on it without problems...
My environment has 3 monitors,

2 on Dock station and 1 on laptop's HDMI port...

For now, I can work without any problems ....

Mike, thanks for the tip!!

Revision history for this message
Stefan Fleischmann (sfleischmann) wrote :

Looks like this upstream bug report https://github.com/DisplayLink/evdi/issues/181

Seems to be triggered by disabling the laptop display. Two possible workarounds:

a) keep laptop display enabled

b) disable compositor (in my case with Xfce, settings -> window manager tweaks -> compositor -> untick enable box

Instead of posting more here please make sure to bother DisplayLink so that they fix this and release another update https://support.displaylink.com/, and/or provide more info on the GitHub issue linked above.

Revision history for this message
Tobias Weisserth (tobias-weisserth) wrote :

I am seeing the same impact on a Lenovo T460S running Ubuntu 18.04LTS with latest kernel and patches. The problem started after a reboot today (06/23/2020) and updates applied earlier the same day.

Revision history for this message
Michael Anstis (manstis) wrote :

If I connect my Thinkpad P50 running 18.04LTS with latest patches to an external monitor it runs incredibly slow. I have to disconnect from the monitor and use the laptop screen. Then things run OK.

Revision history for this message
Chris Castle (onyxrook) wrote :

Displaylink put a sticky on their forums. In it, there is a download link for a patched xserver-xorg-core which resolves the problem.

https://www.displaylink.org/forum/showthread.php?t=67148

Revision history for this message
Aleksander Miera (amiera) wrote :

Assigning to xserver.
Upstream bug report is here: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1028

affects: ubuntu → xorg-server (Ubuntu)
Revision history for this message
Stefan (sproell) wrote :

DisplayLink offers a patch for the XServer: https://www.displaylink.org/forum/showthread.php?t=67148

Applying the patch on my Dell XPS running Ubuntu 20.04.1 seems to fix the problem.

Revision history for this message
Aaron Cardinal (uup115) wrote :

Patch has little to no effect on my laptop. It's especially noticeable when playing video.

Dell Inspiron 13 5368 2-in-1 Laptop
Processor: Intel(R) Core(TM) i3-6100U CPU @ 2.30GHz
Memory: 12125MB (4913MB used)
Operating System: Ubuntu 20.04.1 LTS
Kernel: Linux 5.4.0-48-generic (x86_64)
Version: #52-Ubuntu SMP Thu Sep 10 10:58:49 UTC 2020
C Library: GNU C Library / (Ubuntu GLIBC 2.31-0ubuntu9.1) 2.31
Date/Time: Sun 04 Oct 2020 12:24:04 PM EDT

Revision history for this message
Daniel Weber (daniw42) wrote :

https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1875015/comments/15 still not fixed it perfectly but it is somehow usable again. there is still a noticable lag on my lenovo x1 yoga 5th with two external monitors connected

Revision history for this message
EAB (adair-boder) wrote :

Thinkpad P14s running 20.04 with Ultra Dock and three monitors connected (DP+DP+HDMI). The system is non-usable without using the Nvidia GPU. Non-usable because of constant slow-downs, especially with anything visually "intensive" going on ... like web-pages with embedded video etc ...

Revision history for this message
Michael Devine (circumjovial) wrote :

Same problem here, ThinkPad T490 with 20.04 with "ThinkPad Hybrid USB-C with USB-A Dock" model DUD9011D1, with DisplayLink 5.3.1 drivers. No discrete GPU, just the Intel UHD graphics "Device: Mesa Intel(R) UHD Graphics (CML GT2) (0x9b41)"

It seems display buffers are updated roughly once per second.

Revision history for this message
Arvind (aiy3ngar) wrote :

Additionally, I noticed this issue on Linuxmint 20 (Ulayana) release installed on a Lenovo T580 Thinkpad. The displays attached via USB3.0 (dell D3100) totally become stuttery and unusable. The Xserver fix provided by DisplayLink makes it useable (https://www.displaylink.com/downloads/file?d=310) (without and with laptop lid closed) but there are still a lot of stutters/lag overall.

Revision history for this message
Alexander Eble (alexanderdavide) wrote :

I got it working flawlessly by switching to Wayland.

From the DisplayLink installation instructions page (https://support.displaylink.com/knowledgebase/articles/684649): "Current version supports Wayland and it is recommended to use it."

Revision history for this message
peddanet (peddanet) wrote :

Is there still no solution in sight? I have tried all above workarounds (patch, and latest displaylink version and vice versa) but it did not work at all.

xrandr gives me many disconnected devices, I did not find them anywhere in the filesystem.

```
$ xrandr --query |grep connected
eDP-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 381mm x 214mm
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DVI-I-4-4 disconnected (normal left inverted right x axis y axis)
DVI-I-3-3 disconnected (normal left inverted right x axis y axis)
DVI-I-2-2 connected 1920x1080+3840+0 (normal left inverted right x axis y axis) 510mm x 287mm
DVI-I-1-1 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 521mm x 293mm

Revision history for this message
Jeff Wright (javajeff13) wrote :

I am suffering from this problem as well (2020 Dell XPS 13", Ubuntu LTS 20.04), even after applying the fix at https://www.displaylink.org/forum/showthread.php?t=67148. HOWEVER - I have found that if I mirror my displays (laptop built-in + external HP2511X vis DVI), the lag disappears. This is true even when connected via an external USB 3.0 hub, so at least I can use my external mouse/KB at the same time as enjoying the larger desktop.

Revision history for this message
svenmeier (sven-meiers) wrote :

On my system this problem shows up when I enable fractional-scaling (which I have to, to be able to use different scaling for my notebook's 3k display and my external monitor).

As soon as I close my notebook's lid or disable fractional-scaling, performance on the external monitor is back to normal.

Revision history for this message
Carl Englund (englundc) wrote :

Seems some people here are using the DisplayLink driver offered by the company for USB3-based DL-devices. I ran into this bug using the udl driver, since I'm using a DL-device based on one of the older USB2 DisplayLink chipsets. Confirmed the problem in Mint 20.1 and Ubuntu 20.04.2. In Ubuntu, I also tried Wayland but couldn't get DL working there at all.

Some people here have stated that it helped running one of the screens with VGA or HDMI. Didn't help me though.

Revision history for this message
Binerf (binerf) wrote :

Since I've migrated to Linux Mint 20.1 MATE (from Xubuntu), no problem for me anymore.

Revision history for this message
ilker (ilkerk) wrote :

I have this issue on 21.04 Thinkpad P1 when I use DP on the dock and turn the laptop monitor off.

The workaround for me was adding
LIBGL_DRI3_DISABLE=true
to the /etc/environment and reboot.

I have nvidia card and read this workaround for an HDMI issue somewhere on the Nvidia forums, But it seems like it also solved my problem.

Revision history for this message
Rogelio Andrade Mancisidor (rogelioamancisidor) wrote :

I also had this problem on ubuntu 20.10 X1 carbon 9 gen. and adding LIBGL_DRI3_DISABLE=true to the /etc/environment solved it.

Revision history for this message
Łukasz Spintzyk (lspintzy) wrote :

This is now fixed for intel gpu based machines.
XServer issue: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1183
Merge request that has fixed that on Xorg Xserver 1.20 branch (server-1.20-branch):
https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/686
Please incorporate that fix to Ubuntu 1.20

To sum up fix is solving extreamly slow refresh rate(1FPS) when laptop lid is closed or DisplayLink display is the only one. This fixes laptops with intel cpu.
For amd,nvidia gpus fix is not ready yet.

Revision history for this message
Dave Walker (davewalker) wrote :

Upstream patch debdiff for hirsute

Revision history for this message
Dave Walker (davewalker) wrote :

Upstream patch debdiff for focal

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "xorg-server_1.20.11-1ubuntu2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Note we're still missing a fix for impish. It's marked as Fix Committed because it's committed upstream and coming in release 1.20.12 but that tag doesn't exist yet.

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Committed
tags: added: fixed-in-1.20.12 fixed-upstream
Changed in xorg-server (Ubuntu Focal):
assignee: nobody → Dave Walker (davewalker)
Changed in xorg-server (Ubuntu Hirsute):
assignee: nobody → Dave Walker (davewalker)
Changed in xorg-server (Ubuntu Focal):
status: New → In Progress
Changed in xorg-server (Ubuntu Hirsute):
status: New → In Progress
Revision history for this message
Łukasz Spintzyk (lspintzy) wrote :

What about focal and hirsute, will it be merged in?

Mathew Hodson (mhodson)
Changed in xorg-server (Ubuntu Focal):
importance: Undecided → Medium
Changed in xorg-server (Ubuntu Hirsute):
importance: Undecided → Medium
Changed in xorg-server (Ubuntu Impish):
importance: Undecided → Medium
tags: removed: 20.04 displaylink docking station ubuntu
Revision history for this message
tim O (z0rk) wrote :

This issue should be resolved with 1.20.12 on Focal? Do the expected release date will be? Thank you

Revision history for this message
Alexander Karlstad (alexander.karlstad) wrote :

I see that impish got 1.20.13 of xserver-xorg-core recently. Is it fixed there?

Revision history for this message
Łukasz Spintzyk (lspintzy) wrote :

It should be for intel gpu based machines. For nvidia and amd we need to wait until community will upstream corresponding part to nouveau and amdgpu xserver DDX drivers.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

If you're sure changes are required in "nouveau and amdgpu xserver DDX drivers" then those are different packages that should be added as new tasks at the top of the page:

  xserver-xorg-video-nouveau
  xserver-xorg-video-amdgpu

Changed in xorg-server (Ubuntu Impish):
status: Fix Committed → Fix Released
Revision history for this message
Bin Li (binli) wrote :

I tried 2:1.20.13-1ubuntu1 xorg and with 470.63.01 nvidia driver on my ThinkPad, this issue is still exist.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Checking again, the fix for Xorg issue #1028 is definitely in 1.20.12 so it sounds like something else is at play. Maybe try with open source drivers?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Actually Łukasz Spintzyk is the author of the fix and in comment #39 even he is only discussing open source drivers. Not sure if Nvidia-470 is expected to work.

no longer affects: nvidia-graphics-drivers-470 (Ubuntu Focal)
no longer affects: nvidia-graphics-drivers-470 (Ubuntu Hirsute)
no longer affects: nvidia-graphics-drivers-470 (Ubuntu Impish)
no longer affects: xserver-xorg-video-amdgpu (Ubuntu Focal)
no longer affects: xserver-xorg-video-amdgpu (Ubuntu Hirsute)
no longer affects: xserver-xorg-video-amdgpu (Ubuntu Impish)
no longer affects: xserver-xorg-video-nouveau (Ubuntu Focal)
no longer affects: xserver-xorg-video-nouveau (Ubuntu Hirsute)
no longer affects: xserver-xorg-video-nouveau (Ubuntu Impish)
Changed in xserver-xorg-video-nouveau (Ubuntu):
assignee: nobody → Łukasz Spintzyk (lspintzy)
Changed in xserver-xorg-video-amdgpu (Ubuntu):
assignee: nobody → Łukasz Spintzyk (lspintzy)
status: New → In Progress
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → In Progress
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-470 (Ubuntu):
status: New → Confirmed
Rex Tsai (chihchun)
tags: added: oem-priority
Revision history for this message
AaronMa (mapengyu) wrote (last edit ):

Hi,

The bug status of focal is in progress, when will the version 1.20.12 be released in focal?
It blocks many OEM projects.

Revision history for this message
Luca Capra (luca-capra) wrote :

Hi, I am on 21.10 with intel driver and latest displaylink from their website. Everything used to work decently until a couple of day ago when I started seeing the external monitor very slow. I was on 21.04 and after an update it has started being slow.

1. It is slower when more things change on the screen, only the mouse works slow a full screen rendering is unusably slow.
2. on the login screen the screen works very well, as I was used to.
3. Audio work fine, rendering is very slow

About my pc

1. Linux vin 5.13.0-20-generic #20-Ubuntu SMP Fri Oct 15 14:21:35 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
2. Driver from display link displaylink-driver-5.4.1-55.174
3. Tried X11 and Wayland from GDM with Gnome

I tried to troubleshoot as described here https://wiki.archlinux.org/title/DisplayLink and setting LIBGL_DRI3_DISABLE=true as said here but it does not change

Any hint is appreciated!
Thank you

Revision history for this message
Adam Niedling (krychek) wrote :

Bumped into this bug after upgrading to 21.10. Laptop with nVidia 2080, DisplayPort to external screen.
Adding LIBGL_DRI3_DISABLE=true to /etc/environment fixed my issue.

tags: added: displaylink evdi
Revision history for this message
Cody (qwertycody) wrote :

After doing some deeper reading I've come across this bug via the DisplayLink GitHub Repo.

As a developer, I recognize that this isn't really the responsiblity of the Canonical Ltd. to hunt down issues that don't relate back to the Core OS - to an extent - so it's not really THEIR fault that an unexpected side-effect was introduced in XServer.

That being said, DisplayLink and their "external graphics card" platform powers an overwhelming majority of Home and Office Docking Stations, Conference Rooms, Backpack Adapters, etc.

Ultimately frustrated end-users who don't care to dig deep into what the true issue is (including software developers) will give up and just blame Ubuntu and revert to the excuse "Linux is unstable and not a daily operating system"

I personally think this is a bad look for Canonical and Ubuntu and will cause a loss in market share due to reduced confidence in the stability of the platform.

Basically what I'm saying is - things like this that are glaringly obvious to end-users from the frontend perspective absolutely need to be prioritized and I hope that someone sees this and attempts to get this bug ultimately closed out.

This bug has been open since 2020-04-25.

I am writing this comment as of 2021-12-01.

The bug located over at XServer looks to be closed as of 2020-5-29 - though it's unclear to me if it's completely merged into main.

The two teams need to come together and figure this out because like I said previously - this is an extremely bad look from an end-user perspective and just adds to the invalid argument used for years that people use to complain about Linux instability.

My Comment on DisplayLink GitHub:
- https://github.com/DisplayLink/evdi/issues/61#issuecomment-983603462
- I am on a FRESH install of Ubuntu 20.04 as of October 6th 2021 that I updated many times before actually jumping into using it.
- Reference - I started a new job that day and needed to jump into using Linux full time for the type of Software Development work I'd be doing - naturally I've used DisplayLink adapters flawlessly for years (on Windows) so it came as a shock to me that something so glaringly obvious is a problem in a major distribution like Ubuntu.

XServer Bug Tracker (Closed):
- https://gitlab.freedesktop.org/xorg/xserver/-/issues/1028

Revision history for this message
Luca Capra (luca-capra) wrote :

Nice write up, I am back to my evdi device from a week and is working flawless now. Thanks

Mathew Hodson (mhodson)
tags: added: patch-accepted-upstream
removed: fixed-upstream
Revision history for this message
aaron (aaronsuns) wrote :

Still no fix or workaround? Having a fresh ubuntu 20.04 installed.
nvidia 470.86
xserver-xorg-core 2:1.20.13-1ubuntu1~20.04.2
5.11.0-43-generic

HP zbook, G5.

External monitor, Xorg high cpu load, external monitor random slow.

Revision history for this message
Bas Prins (bas-prins3) wrote :

Hi aaron, after building up my hate again towards microsoft for two months (bought a new fancy laptop, upgraded to windows11, and my screens connected via display link went dark from time to time, no fix, really freaking annoying), I thought %&#$ this, I'll try ubuntu one more time.

Installed 20.04, downloaded the drivers for displaylink. Went through all the misery listed above.

Installed 21.10, downloaded the beta drivers from display link. Bam. Works like a charm.

So if you are able to upgrade to 21.10, it might be the fix for you too

Revision history for this message
Bas Prins (bas-prins3) wrote :

Scratch that.... After a reboot it's the same story all over again. 1FPS. Read so many posts on this topic. Will this ever get solved or is displaylink for ubuntu (/linux) just not on the agenda? (iow is this the end for me with ubuntu?)

Revision history for this message
aaron (aaronsuns) wrote :

Thanks Bas, this bug really make the system unusable. Very annoying. Any workaround would be appreciate.

I guess this issue is talking about similar thing.
https://github.com/DisplayLink/evdi/issues/181

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

xorg-server 1.20.13 is in focal/impish/jammy now

Changed in xorg-server (Ubuntu Focal):
status: In Progress → Fix Released
Changed in xorg-server (Ubuntu Hirsute):
status: In Progress → Won't Fix
summary: - Ubuntu 20.04 and Displaylink is extremely slow
+ Displaylink is extremely slow
Revision history for this message
Bas Prins (bas-prins3) wrote : Re: Displaylink is extremely slow

Just to share with those who didn't knew. I just leared that you can use wayland instead of xorg with ubuntu 21.10. I've installed the latest stable display link drivers, and I am running my 2 screens via displaylink without any problems now.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

The 5.5 beta driver:

  https://www.synaptics.com/products/displaylink-graphics/downloads/ubuntu

has also solved a serious issue in Wayland sessions for me...

  https://gitlab.gnome.org/GNOME/mutter/-/issues/2005

Revision history for this message
Luca Capra (luca-capra) wrote :

I just updated my ubuntu 21.10 with normal apt software updates and the issues is here again. It used to work well since beginning of December 2021

Linux 5.13.0-35-generic #40-Ubuntu SMP Mon Mar 7 08:03:10 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

no longer affects: nvidia-graphics-drivers-470 (Ubuntu)
summary: - Displaylink is extremely slow
+ Displaylink is extremely slow in Xorg sessions
Revision history for this message
Andrii Ovchinnikov (goldruno) wrote (last edit ):

Displaylink is extremely slow
ubuntu 22.04
DisplayLink driver version Release: 5.5
acer nitro 5 an515-45
GeForce RTX 3080 Mobile
https://i.imgur.com/hXU0Euv.png
On the laptop screen, the system does not slow down.
Terrible brakes on external monitors. Moreover, if 1 external monitor, then the brakes are not as strong as if you connect two external ones.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Andrii, if you experience different performance on the laptop screen to external monitors then you might have bug 1970291 instead.

Changed in xf86-video-amd:
status: Unknown → Fix Released
Changed in nouveau:
status: Unknown → New
Changed in xorg-server:
status: Unknown → Fix Released
Mathew Hodson (mhodson)
Changed in xserver-xorg-video-amdgpu (Ubuntu):
importance: Undecided → Medium
Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

The amdgpu driver fix is committed upstream but not yet tagged, so probably will be in version 22.0.1 or later?

Changed in xserver-xorg-video-amdgpu (Ubuntu):
status: In Progress → Fix Committed
jeremyszu (os369510)
tags: added: originate-from-1979015 stella
Revision history for this message
jeremyszu (os369510) wrote :

I can confirmed the commits from https://gitlab.freedesktop.org/xorg/driver/xf86-video-amdgpu/-/merge_requests/75/commits fix my issue on I+A machine using Jammy and KKK daily build.

Test PPA is https://launchpad.net/~os369510/+archive/ubuntu/lp1875015

For Focal, it seems the extra patches are needed.

Revision history for this message
jeremyszu (os369510) wrote :
Revision history for this message
jeremyszu (os369510) wrote :
Revision history for this message
jeremyszu (os369510) wrote :
Revision history for this message
jeremyszu (os369510) wrote :
Revision history for this message
jeremyszu (os369510) wrote :

comment#63-66 for xserver-xorg-video-amdgpu on Jammy.

For debian and KKK, do we plan those to be landed through stable updates?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-amdgpu - 22.0.0-2

---------------
xserver-xorg-video-amdgpu (22.0.0-2) unstable; urgency=medium

  * Added patches from git to fix slow refresh rate with Displaylink
    output. (LP: #1875015)

 -- Timo Aaltonen <email address hidden> Thu, 07 Jul 2022 11:29:03 +0300

Changed in xserver-xorg-video-amdgpu (Ubuntu):
status: Fix Committed → Fix Released
Mathew Hodson (mhodson)
Changed in xorg-server (Ubuntu Jammy):
importance: Undecided → Medium
status: New → Fix Released
Changed in xserver-xorg-video-amdgpu (Ubuntu Jammy):
importance: Undecided → Medium
Changed in xserver-xorg-video-nouveau (Ubuntu Jammy):
importance: Undecided → Medium
Revision history for this message
jeremyszu (os369510) wrote (last edit ):

In Focal Stock Ubuntu, I confirmed if user installs "cryptsetup-initramfs" on I+A platform with choosing display mode to "External Only", the issue presents.

tags: added: jellyfish-edge-staging
Revision history for this message
jeremyszu (os369510) wrote :

More precisely, it seems related to

FRAMEBUFFER=y in "conf-hooks.d/cryptsetup".

When I marked it as 'n', then issue is gone.

Need to figure it out what's it exactly causes.

Revision history for this message
jeremyszu (os369510) wrote :

The xserver-xorg-video-amdgpu patches #63~#66 don't need in focal because only Stock Jammy default installation will be affect.

The same symptom can be reproduced in both Focal and Jammy with applying "FRAMEBUFFER=y" and the xserver-xorg-video-amdgpu patchset don't help.

Revision history for this message
josh d (jd531) wrote (last edit ):

Hi, I can confirm this for lenovo z16 laptop as well (kubuntu jammy). This seems not yet fixed in jammy? Glad it seems to be being worked on. Pardon my ignorance to the ubuntu release cadence but if anyone could clear that part up for me it would be greatly appreciated. I can't seem to find much info online (not sure if public?).

Revision history for this message
jeremyszu (os369510) wrote :

Hi Josh,

In my experience on this issue, there are at least two ways to reproduce this issue.
1. fresh install.
2. enable "FRAMEBUFFER=y" in initramfs.

As lenovo z16 is an AMD platform, would you please try to upgrade all packages to latest and try the package from the ppa of comment#62?

BTW, FWIK, the Jammy is default to Wayland for AMD platform.
I didn't see this issue on Wayland platform unless you switched to Xorg manually.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Yes, please use Wayland if you can. It's usually the login option labelled "Ubuntu".

I've been testing and fixing DisplayLink for Wayland in Mutter for much of this year so I would expect it to be a better experience than Xorg by now.

Revision history for this message
josh d (jd531) wrote (last edit ):

Hi Jeremyszu,
That ppa fixed my issue! I'm using kubuntu which seems to use xorg by default... I might need to get used to gnome! Is this going to prevent other upgrades? I am not super familiar with how different ppas for same packages would work. I imagine a later version will be marked as an update and override those updates.

Daniel,
Unfortunately I tried installing the kubuntu wayland packages and the experience was far worse on the dock. So I switched back to x as I'm a pretty big kde fan (I saw some reports that KDE wayland was a bit half baked as of yet across the web, I'm not really in the know). I might switch to gnome to try it out as it has been some years. When I do that I'll definitely try wayland again.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

When I say "Wayland in Mutter" I do mean GNOME. That's what we are involved in the development of, and recommend as the primary Ubuntu environment.

Revision history for this message
jeremyszu (os369510) wrote :

Installed a package from a PPA won't break the package upgrade.

As Timo uploads the package to Unstable.
If everything goes smoothly, the next version of xserver-xorg-video-amdgpu will contain the patches and that version will overwrite mine from the PPA.

In short, an "apt upgrade" will overwrite it and point to current version from ubuntu-archive.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.