[nvidia] Ubuntu 20.04 beta: Blank/black screen after login on an Nvidia-only desktop (GeForce GTX 1060)

Bug #1870779 reported by Michael on 2020-04-04
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-440 (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

I have the reproducible effect with Ubuntu 20.04 beta that I'm able to login right after installation, but after a few reboots a black screen is displayed after login.
I'm able to switch to a tty and tried to collect information with ubuntu-bug, but I am not sure if that help. I'm happy to provide further information if needed.
I reinstalled Ubuntu 20.04 a couple of times, the behaviour is always the same. 19.10 works without any problem.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
Uname: Linux 5.4.0-21-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.09.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:09:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.suspend: suspend hibernate resume
.proc.driver.nvidia.suspend_depth: default modeset uvm
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 440.64 Fri Feb 21 01:17:26 UTC 2020
 GCC version: gcc version 9.3.0 (Ubuntu 9.3.0-8ubuntu1)
ApportVersion: 2.20.11-0ubuntu22
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
Date: Sat Apr 4 14:05:01 2020
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
DkmsStatus:
 nvidia, 440.64, 5.4.0-21-generic, x86_64: installed
 virtualbox, 6.1.4, 5.4.0-21-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell GP106 [GeForce GTX 1060 6GB] [1028:11d7]
InstallationDate: Installed on 2020-04-03 (0 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200402)
MachineType: Dell Inc. Inspiron 5675
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-21-generic root=UUID=3210a7fb-4a4d-4b22-ba85-60282726ebc3 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
Title: Xorg crash
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/14/2018
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.3.7
dmi.board.name: 0477DV
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 1.3.7
dmi.modalias: dmi:bvnDellInc.:bvr1.3.7:bd03/14/2018:svnDellInc.:pnInspiron5675:pvr1.3.7:rvnDellInc.:rn0477DV:rvrA00:cvnDellInc.:ct3:cvr1.3.7:
dmi.product.family: Inspiron
dmi.product.name: Inspiron 5675
dmi.product.sku: 07EE
dmi.product.version: 1.3.7
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.100-4
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.2-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Michael (mrzxvp5j-ubuntu) wrote :
description: updated
affects: ubuntu → xorg (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you get a 'journalctl -b 0' log after triggering the issue and add it to the bug?

Changed in xorg (Ubuntu):
status: New → Incomplete

Thank you for taking the time to report this bug and helping to make Ubuntu better. It sounds like some part of the system has crashed. To help us find the cause of the crash please follow these steps:

1. Look in /var/crash for crash files and if found run:
    ubuntu-bug YOURFILE.crash
Then tell us the ID of the newly-created bug.

2. If step 1 failed then look at https://errors.ubuntu.com/user/ID where ID is the content of file /var/lib/whoopsie/whoopsie-id on the machine. Do you find any links to recent problems on that page? If so then please send the links to us.

3. If step 2 also failed then apply the workaround from bug 994921, reboot, reproduce the crash, and retry step 1.

Please take care to avoid attaching .crash files to bugs as we are unable to process them as file attachments. It would also be a security risk for yourself.

tags: added: nvidia
summary: - Ubuntu 20.04 beta: Blank/black screen after login
+ [nvidia] Ubuntu 20.04 beta: Blank/black screen after login
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
tags: added: black-screen
Changed in nvidia-graphics-drivers-440 (Ubuntu):
status: New → Incomplete
Michael (mrzxvp5j-ubuntu) wrote :

Hi Daniel,
thanks for your support.

1) The /var/crash directory is empty.
2) The last whoopsie problem was reported on March 27th and is most likely from the Ubuntu 19.10 system on the same machine.
3) The /etc/apport/crashdb.conf for focal fossa does not include the "problem_types" statement. So there's nothing I can comment out.

Any other things I can do? I have some spare time these days, so I'm willing to do, whatever it takes.

Regards
Michael

Daniel van Vugt (vanvugt) wrote :

Maybe repeat the problem a few times and then attach here all your most recent Xorg log files from:

  ~/.local/share/xorg/

Michael (mrzxvp5j-ubuntu) wrote :

I'm sorry, there is not xorg directory under .local/share. It doesn't exist in Ubuntu 19.10 either!

tags: added: hybrid
tags: removed: hybrid
summary: - [nvidia] Ubuntu 20.04 beta: Blank/black screen after login
+ [nvidia] Ubuntu 20.04 beta: Blank/black screen after login on an Nvidia-
+ only desktop (GeForce GTX 1060)
Changed in nvidia-graphics-drivers-440 (Ubuntu):
status: Incomplete → New
Changed in xorg-server (Ubuntu):
status: Incomplete → New
Michael (mrzxvp5j-ubuntu) wrote :

I've got some new findings here. I tried to use the HDMI cable instead of Display Port. With HDMI I was able to login and see the desktop. I was able to reboot several times and it worked well.
Then I switched the scaling to 200% (I'm an old man ;-)) and everything looked good. However after the next reboot the screen is black again.
I reproduced this behaviour with the second HDMI port. So it seems that this is a scaling problem. I will do some further testing there.

Michael (mrzxvp5j-ubuntu) wrote :

I did some additional testing. If I set the scale in .config/monitors.xml back to 1, I am able to login again. So the problem is caused by the scaling. If I set the scaling is set to 200% everything works well until the next reboot.
It tried the nvidia driver 435 and had the same effect.
I switched to the Nouveau driver and now the system does not boot anymore. I do not even reach the login screen.

Michael (mrzxvp5j-ubuntu) wrote :

Now, I switched back to Nvidia 440, scale 100% and I'm able to use the system again. (Of course, I can hardly read anything, because it is so small)

Michael (mrzxvp5j-ubuntu) wrote :
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1870758, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-440 (Ubuntu):
status: New → Confirmed
Changed in xorg-server (Ubuntu):
status: New → Confirmed

I have a similar big, with this same video card, when starting in Ubuntu 20.04, it is no more than the login screen, how do I report?

Abou (fipoucat) wrote :

I have a similar problem on an HP desktop, with the number affected, this requires a very urgent fix.

EVGENY (nikevist) wrote :

I have the same problem with fractional display scaling. After I change my default drivers to Nvidia and I try to use fractional scaling my system is crushing and I get black screen.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers