[nvidia] Slowness and sometimes the computer freezes

Bug #1840626 reported by Rabillon on 2019-08-19

This bug report will be marked for expiration in 33 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Since maybe two months, my computer deosn't work correctly. There is slowness and sometime the computer freeze.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 4.15.0-58.64-generic 4.15.18
Uname: Linux 4.15.0-58-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.04.00.0: Error: [Errno 21] est un dossier: '/proc/driver/nvidia/gpus/0000:04:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 390.116 Sun Jan 27 07:21:36 PST 2019
 GCC version: gcc version 7.4.0 (Ubuntu 7.4.0-1ubuntu1~18.04.1)
.tmp.unity_support_test.0:

ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Mon Aug 19 00:42:31 2019
DistUpgraded: 2019-02-23 11:53:16,014 DEBUG icon theme changed, re-reading
DistroCodename: bionic
DistroVariant: ubuntu
DkmsStatus: nvidia, 390.116, 4.15.0-58-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation HD Graphics 5500 [8086:1616] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] HD Graphics 5500 [1025:0974]
   Subsystem: Acer Incorporated [ALI] GK208BM [GeForce 920M] [1025:0974]
InstallationDate: Installed on 2019-02-21 (178 days ago)
InstallationMedia: Ubuntu 16.04.5 LTS "Xenial Xerus" - Release amd64 (20180731)
MachineType: Acer Aspire E5-772G
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-58-generic root=UUID=377aa352-9018-46e8-bfee-2799a1be51e6 ro persistent quiet splash vt.handoff=1
SourcePackage: xorg
UpgradeStatus: Upgraded to bionic on 2019-02-23 (176 days ago)
dmi.bios.date: 07/28/2015
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V1.09
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Aspire E5-772G
dmi.board.vendor: Acer
dmi.board.version: V1.09
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.09
dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.09:bd07/28/2015:svnAcer:pnAspireE5-772G:pvrV1.09:rvnAcer:rnAspireE5-772G:rvrV1.09:cvnAcer:ct10:cvrV1.09:
dmi.product.family: BDW
dmi.product.name: Aspire E5-772G
dmi.product.version: V1.09
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
version.libdrm2: libdrm2 2.4.97-1ubuntu1~18.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.0.8-0ubuntu0~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 19.0.8-0ubuntu0~18.04.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Mon Aug 19 00:38:49 2019
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.6-1ubuntu4.3

Rabillon (t-rabillon) wrote :
Daniel van Vugt (vanvugt) wrote :

I wonder if the slowness is related to this from your Xorg log:

[ 137.718] randr: falling back to unsynchronized pixmap sharing

tags: added: nvidia
summary: - Description
+ Slowness and sometimes the computer freezes
summary: - Slowness and sometimes the computer freezes
+ [nvidia] Slowness and sometimes the computer freezes
tags: added: hybrid
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

Can you disable the discrete (Nvidia) GPU in your BIOS for a while and try that? That will help us to identify if the Nvidia driver is related to the problem.

Also, next time any slowness occurs please run in a Terminal window:

  journalctl -b0 > journal.txt

and then attach the file 'journal.txt' to this bug.

tags: added: performance
Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Incomplete
Changed in xorg-server (Ubuntu):
status: New → Incomplete
Rabillon (t-rabillon) wrote :

I can't disable the discrete Nvidia GPU in my BIOS. I don't have menu to swich off this GPU on the BIOS.
I will run your command in a Term next time,
Thanks.

Rabillon (t-rabillon) wrote :

Hi,
After some test, I try this and now my system seems to be more stable :
<pre><font color="#8AE234"><b>xxxxxx@XXXXXXX</b></font>:<font color="#729FCF"><b>~</b></font>$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:1c.4/0000:04:00.0 ==
modalias : pci:v000010DEd00001299sv00001025sd00000974bc03sc02i00
vendor : NVIDIA Corporation
model : GK208BM [GeForce 920M]
driver : nvidia-driver-410 - third-party free
driver : nvidia-driver-415 - third-party free recommended
driver : nvidia-driver-390 - third-party free
driver : xserver-xorg-video-nouveau - distro free builtin

<font color="#8AE234"><b>xxxxxx@XXXXXXX</b></font>:<font color="#729FCF"><b>~</b></font>$ sudo apt install nvidia-driver-415
</pre>
If I have another problem I will try on Terminal your command:
journalctl -b0 > journal.txt

Thanks

To post a comment you must log in.