Comment 0 for bug 1823516

Nvidia-418 installed but GLX is using LLVMpipe/Mesa in Wayland sessions.

I am using kernel parameter nvidia-drm.modeset=1, which is required to get the "Ubuntu on Wayland" option. But after logging in I see:

$ glxinfo | grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 8.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.0.1
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 19.0.1
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 19.0.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: nvidia-driver-418 418.56-0ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-8.9-generic 5.0.1
Uname: Linux 5.0.0-8-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu25
Architecture: amd64
Date: Sun Apr 7 17:26:07 2019
InstallationDate: Installed on 2018-12-04 (124 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20181203)
SourcePackage: nvidia-graphics-drivers-418
UpgradeStatus: No upgrade log present (probably fresh install)