Nvidia driver installed but X apps are using software rendering (LLVMpipe) in Wayland sessions

Bug #1823516 reported by Daniel van Vugt
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Fix Committed
Low
Unassigned
xwayland (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Nvidia driver installed but X apps are using software rendering (LLVMpipe) in Wayland sessions.

I am using kernel parameter nvidia-drm.modeset=1, which is required to get the "Ubuntu on Wayland" option. But after logging in I see:

$ glxinfo | grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 8.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.0.1
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 19.0.1
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 19.0.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

$ es2_info | grep ^GL
GL_VERSION: OpenGL ES 3.0 Mesa 19.0.1
GL_RENDERER: llvmpipe (LLVM 8.0, 256 bits)

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: nvidia-driver-418 418.56-0ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-8.9-generic 5.0.1
Uname: Linux 5.0.0-8-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu25
Architecture: amd64
Date: Sun Apr 7 17:26:07 2019
InstallationDate: Installed on 2018-12-04 (124 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20181203)
SourcePackage: nvidia-graphics-drivers-418
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Daniel van Vugt (vanvugt) wrote :
summary: - Nvidia-418 installed but GLX is using LLVMpipe/Mesa in Wayland sessions
+ Nvidia-418 installed but GLX and EGL are using LLVMpipe/Mesa in Wayland
+ sessions
description: updated
description: updated
summary: - Nvidia-418 installed but GLX and EGL are using LLVMpipe/Mesa in Wayland
+ Nvidia-418 installed but apps are using LLVMpipe/Mesa in Wayland
sessions
description: updated
tags: added: nvidia-drm.modeset
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: Nvidia-418 installed but apps are using LLVMpipe/Mesa in Wayland sessions

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-418 (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Added a xorg-server task, because I recall that needed rebuilding with EGLStreams support enabled in Xwayland. Maybe that's the only problem here?

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Rebuilding xorg-server with --enable-xwayland-eglstream didn't help (!?)

Revision history for this message
Nico Jakob (nicoj10) wrote :

Is there anything one can do to help resolving this issue?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Apparently the feature doesn't exist in Xwayland yet. Someone mentioned that it's a known issue and the upstream developers will be looking at completing it this year.

summary: - Nvidia-418 installed but apps are using LLVMpipe/Mesa in Wayland
+ Nvidia driver installed but apps are using LLVMpipe/Mesa in Wayland
sessions
Changed in mesa (Ubuntu):
status: Confirmed → Invalid
Changed in mutter (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-graphics-drivers-418 (Ubuntu):
status: Confirmed → Invalid
summary: - Nvidia driver installed but apps are using LLVMpipe/Mesa in Wayland
- sessions
+ Nvidia driver installed but X apps are using software rendering
+ (LLVMpipe/Mesa) in Wayland sessions
Changed in xorg-server (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
tags: added: performance
summary: Nvidia driver installed but X apps are using software rendering
- (LLVMpipe/Mesa) in Wayland sessions
+ (LLVMpipe) in Wayland sessions
description: updated
tags: added: nvidia
Revision history for this message
Nico Jakob (nicoj10) wrote :

Is there any update on this?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Someone probably needs to find a relevant upstream Xorg bug link to see where/if it is being discussed there.

This is not the place where Xorg developers discuss such things.

Revision history for this message
Bryan Quigley (bryanquigley) wrote :

Couldn't find a bug, but it's described as a known issue here: https://blogs.gnome.org/uraeus/2019/04/03/preparing-for-fedora-workstation-30/

Given the description above it seems to be waiting on a new nvidia driver - still an issue on 430.14.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in mesa (Ubuntu):
status: Invalid → Triaged
importance: Undecided → Medium
Changed in xorg-server (Ubuntu):
importance: High → Medium
no longer affects: mutter (Ubuntu)
no longer affects: nvidia-graphics-drivers-418 (Ubuntu)
tags: removed: disco
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

The bug is still present in 21.04 but a new fix has been proposed in: https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/587

tags: added: hirsute
no longer affects: mesa (Ubuntu)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Fix landed in Xorg 1.21: https://cgit.freedesktop.org/xorg/xserver/commit/?id=38e875904b039ec1889e7c81eb1d577a4f69b26d&utm_source=anzwix

But it's not yet in the separate Xwayland branch *and* it supposedly requires Nvidia driver 470. So we're probably waiting for Ubuntu 21.10.

Changed in xorg-server (Ubuntu):
status: Triaged → Fix Committed
tags: added: fixed-in-1.21 fixed-upstream
Changed in xwayland (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in xwayland (Ubuntu):
status: Triaged → Fix Committed
tags: added: fixed-in-xwayland-21.1.2
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Fix released in xwayland 21.1.1.901 (which is a release candidate for the aforementioned 21.1.2)

Changed in xwayland (Ubuntu):
status: Fix Committed → Fix Released
tags: removed: hirsute
tags: added: nvidia-wayland
removed: nvidia-drm.modeset
Revision history for this message
Daniel van Vugt (vanvugt) wrote (last edit ):

Looks like xorg-server will get the fix in "21" instead of "1.21". Although that's probably not really important to anyone here because Ubuntu switched to using the separate 'xwayland' package in impish which already has the fix.

It might be relevant to focal HWE in future though. Maybe Ubuntu 20.04.5?

Changed in xorg-server (Ubuntu):
importance: Medium → Low
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers