Xwayland crashed with SIGABRT in wl_proxy_destroy() from wl_callback_destroy() from xwl_present_sync_callback() from ffi_call_unix64()

Bug #1821385 reported by El jinete sin cabeza on 2019-03-22
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Unknown
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

https://errors.ubuntu.com/problem/008c7bd0fdc996890cce5f67e5f0214f280aefd8

---

I do not know what happened.

ProblemType: Crash
DistroRelease: Ubuntu 19.04
Package: xwayland 2:1.20.4-1ubuntu2
Uname: Linux 5.0.2-050002-generic x86_64
ApportVersion: 2.20.10-0ubuntu23
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Mar 16 10:31:56 2019
DistUpgraded: 2018-12-02 16:59:40,473 DEBUG inhibit gnome-session idle
DistroCodename: disco
DistroVariant: ubuntu
DkmsStatus:
 rtl8812au, 4.3.8.12175.20140902+dfsg, 4.19.30-041930-generic, x86_64: installed
 rtl8812au, 4.3.8.12175.20140902+dfsg, 5.0.0-7-generic, x86_64: installed
 rtl8812au, 4.3.8.12175.20140902+dfsg, 5.0.0-8-generic, x86_64: installed
 rtl8812au, 4.3.8.12175.20140902+dfsg, 5.0.3-050003-generic, x86_64: installed
ExecutablePath: /usr/bin/Xwayland
ExecutableTimestamp: 1552033916
GraphicsCard:
 Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company UHD Graphics 620 [103c:8486]
InstallationDate: Installed on 2018-12-02 (109 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
MachineType: HP HP Pavilion x360 Convertible 14-cd0xxx
ProcCmdline: /usr/bin/Xwayland :0 -rootless -terminate -accessx -core -listen 4 -listen 5 -displayfd 6
ProcCwd: /home/caravena
ProcEnviron:
 LANGUAGE=es_CL:es
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_CL.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-5.0.3-050003-generic root=UUID=28bdadba-133c-4f5b-a5c9-b06993ea7ce2 ro rootflags=subvol=@ quiet splash vt.handoff=1
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 wl_proxy_destroy () from /usr/lib/x86_64-linux-gnu/libwayland-client.so.0
 ?? ()
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libwayland-client.so.0
UpgradeStatus: Upgraded to disco on 2018-12-02 (109 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 11/08/2018
dmi.bios.vendor: Insyde
dmi.bios.version: F.32
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 8486
dmi.board.vendor: HP
dmi.board.version: 72.23
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 31
dmi.chassis.vendor: HP
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.32:bd11/08/2018:svnHP:pnHPPavilionx360Convertible14-cd0xxx:pvrType1ProductConfigId:rvnHP:rn8486:rvr72.23:cvnHP:ct31:cvrChassisVersion:
dmi.product.family: 103C_5335KV HP Pavilion
dmi.product.name: HP Pavilion x360 Convertible 14-cd0xxx
dmi.product.sku: 3PX63LA#ABM
dmi.product.version: Type1ProductConfigId
dmi.sys.vendor: HP
separator:

version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.97-1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.0.0-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 19.0.0-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.20.4-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20180925-2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

El jinete sin cabeza (ejsc) wrote :
tags: added: wayland-session

StacktraceTop:
 wl_proxy_destroy (proxy=0x97000001cf) at ../src/wayland-client.c:523
 wl_callback_destroy (wl_callback=<optimized out>) at /usr/include/wayland-client-protocol.h:1154
 xwl_present_sync_callback (data=0x55654040fd10, callback=<optimized out>, time=<optimized out>) at ../../../../../hw/xwayland/xwayland-present.c:284
 ffi_call_unix64 () at ../src/x86/unix64.S:76
 ffi_call (cif=cif@entry=0x7fff9e3d8f50, fn=<optimized out>, rvalue=<optimized out>, rvalue@entry=0x0, avalue=avalue@entry=0x7fff9e3d9020) at ../src/x86/ffi64.c:525

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
description: updated
description: updated
no longer affects: xorg-server
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
summary: - Xwayland crashed with SIGABRT in wl_proxy_destroy()
+ Xwayland crashed with SIGABRT in wl_proxy_destroy() from
+ wl_callback_destroy() from xwl_present_sync_callback() from
+ ffi_call_unix64()
Changed in xorg-server:
status: Unknown → New
Changed in xorg-server:
status: New → Fix Released
Changed in xorg-server:
status: Fix Released → Unknown
Changed in xorg-server:
status: Unknown → Fix Released
Changed in xorg-server (Ubuntu):
status: Confirmed → Triaged
tags: added: eoan
El jinete sin cabeza (ejsc) wrote :

The shock was brutal, all my applications were closed. And then GDM appears.

Sebastien Bacher (seb128) wrote :

The issue was fixed upstream in https://gitlab.freedesktop.org/xorg/xserver/commit/2e18eec6

note that it's only a problem in wayland session and there are only 11 reports on e.u.c

Changed in xorg-server (Ubuntu):
status: Triaged → Fix Committed
El jinete sin cabeza (ejsc) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.