Lubuntu 19.04 qa-test; suspend then wake & keyboard & mouse movement, but not mouse-buttons

Bug #1818777 reported by Chris Guiver on 2019-03-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Update (see comment #5)
another QA-Test on same dc7700

This time i firstly confirmed issue was still there - YEP suspend & no mouse buttons.

Then i turned on another machine sharing KVM switch (more power is my theory for this) and the issue disappeared. It was tried again a few times with other machine on, and no issues with mouse buttons on wake.. I'm going to change this to INCOMPLETE as I'm suspicious it's hardware related; lack of power from my old boxes (old psu's) to my KVM switch

I'm marking this as INCOMPLETE - if I change my mind (another qa-test) I can always put it back to NEW

---
Notes: The box I tested this on has shared keyboard/mouse/video
I tried to re-produce on two other boxes (same thumb-drive so same daily 19.04 image)
I always check-media on first box tested after media is written (x201 I think today)

Also note: lynorian (lubuntu-devel) also said
<lynorian> guiverc: I think I filed something about this in a vm a few weeks ago
What I found doesn't apply in my opinion.

I consider this issue [really] MINOR or wishlist at most; in fact I still wonder if it's a hardware issue related to my KVM switch (not getting enough power or something like that)
----

Lubuntu 19.04 QA-TEST on hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

// info from QA-TEST comments
..
firefox paused; suspended machine (using menu)

ISSUE: on wake (used keyboard to wake system) the mouse couldn't click on anything, but keyboard functions worked perfectly (ctrl+alt+t to open term etc). i'll reboot & reload, re-try

reboot & retried.. same issue (on reboot; after reboot I ctrl+alt+T to open term & ran `htop` so I had some changing data on screen to confirm more than just mouse was moving on screen, then suspended..

on wake [2nd boot], notification boxes appeared... mouse moves correctly, keyboard keys appear all good (can switch to tty & back) but no mouse buttons work

ran `xev` & is see all keyboard, and mouse movements, but no buttons appear in window on pressing (unless I accidentally cause mouse to move)

Of note: I've experienced this behavior BEFORE & not reported, as the reboot & re-try has always worked flawlessly.

Rebooted again & re-tested it a third time (menu->suspend, used mouse to click yes [normally I hit enter]) & counted to 20
Woke machine (using power-button instead of keyboard) & keyboard perfect, mouse movement perfect, alas no mouse-button function on screen or menu, nor appearing in `xev` .. mouse wheel is recognized in `xev`.

// this is typed into another box - no mouse function on ubuntu-bug machine since suspend

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: xorg 1:7.7+19ubuntu9
ProcVersionSignature: Ubuntu 4.19.0-13.14-generic 4.19.20
Uname: Linux 4.19.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu21
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperVersion: 1.402
CompositorRunning: None
CurrentDesktop: LXQt
Date: Wed Mar 6 04:22:12 2019
DistUpgraded: Fresh install
DistroCodename: disco
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 NVIDIA Corporation G86 [Quadro NVS 290] [10de:042f] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation G86 [Quadro NVS 290] [10de:0492]
LiveMediaBuild: Lubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190305)
MachineType: Hewlett-Packard HP Compaq dc7700 Small Form Factor
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd quiet splash ---
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/30/2006
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786E1 v01.05
dmi.board.name: 0A54h
dmi.board.vendor: Hewlett-Packard
dmi.chassis.type: 4
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786E1v01.05:bd08/30/2006:svnHewlett-Packard:pnHPCompaqdc7700SmallFormFactor:pvr:rvnHewlett-Packard:rn0A54h:rvr:cvnHewlett-Packard:ct4:cvr:
dmi.product.family: 103C_53307F
dmi.product.name: HP Compaq dc7700 Small Form Factor
dmi.product.sku: ET090AV
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.97-1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.3.4-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.3-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.1.99+git20190207-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Chris Guiver (guiverc) wrote :
description: updated
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Chris Guiver (guiverc) wrote :

I did another QA-test on a different box (most of this is copied from qa-test comments)
& suspended/awoke multiple times, without issue.
This second box has two mice, one thru KVM switch & one direct - both worked flawlessly (after each awake-from-suspend)

---
dell [optiplex] 755 (c2d-e6850, 5gb, amd/ati radeon rv516/x1300/x1550)

This test is only run to explore (test for) https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1818777
this uses same display/keyboard, but has it's own [2nd] mouse I want to see if it works (one mouse going thru kvm switch, one does not)
booted, opened term, `xev` then suspended, wrote/typed up to here..

woke using power switch; now I see screensaver?? (i didn't see that on last box!)
keyboard & mouse work perfectly (both mice work)

suspend again.. waited, awoke again no issues (NO screensaver this time, but did I wake the same way - not sure)

suspend again - waited, awoke again (greeted with screensaver on wake using power-button) with keyboard & mouse (both) working perfectly

suspend again - waited, awoke again (power button & screensaver), keyboard & mouse perfect

suspend again - waited, awoke again (power button, different screensaver), keyboard & mouse perfect.

I cannot reproduce the aforementioned bug-report.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1818777

tags: added: iso-testing
Chris Guiver (guiverc) wrote :

Another box - NO ISSUES again with mouse buttons after WAKE..
QA-test comment follows :-
---
hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)
i'm really only testing for https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1818777 ie. suspend & wake tests.
this box has its own screens & no shared mouse or keyboard !
// i'm not re-arranging screens; open terminal in one & htop running

suspend, waited, hit ESC & I see screensaver running on each display, touch key & mouse & keyboard perfect

suspend, waited, hit ESC again & briefly see htop on top (left) display before screensavers are visible, touch SHIFT & both mouse & keyboard work perfectly.

suspend, waited .. wake this time with power button, NO SCREEN SAVER & instant wake.. both keyboard & mouse work perfectly

suspend, waited .. wake again with power button, very-very-briefly see htop before screensaver visible.. so it's not power-keyboard that dictates whether screensaver shows.. but again keyboard & mouse are working perfectly...

Chris Guiver (guiverc) on 2019-03-06
description: updated
Chris Guiver (guiverc) wrote :

another QA-Test on same dc7700

This time i firstly confirmed issue was still there - YEP suspend & no mouse buttons

Then i turned on another machine sharing KVM switch (more power is my theory for this)
and the issue disappeared. It was tried again a few times with other machine on, and
no issues with mouse buttons on wake.. I'm going to change this it INVALID as I'm suspicious
it's hardware related; lack of power from my old boxes to my KVM switch (old PSU's?)

QA-test comments follow
---

hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)
i'm boot this again looking only for https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1818777

suspended, waited, woke with power-button & buttons on mouse didn't work :(keyboard & mouse movement all fine, just buttons fail).

I turned on d755 (shares kvm switch so more power to the kvm if that's cause as I'm suspicious it is)

I suspended again (as mouse didn't work, `sudo systemctl suspend` , then had to fight to get screen active again (i forget how my setup works)

when it awoke & I got screen showing - i had mouse buttons again -- so my hardware & power-related (ie. two machines providing power to kvm switch & it works??? maybe??)

suspend again (using mouse & menu, then enter) and screen shifts to d755

power switch to wake up; get screen showing & mouse-buttons work !!!

suspend again (this time with `sudo systemctl suspend`) & waited (type here), wake with power buttons, get screen display & mouse buttons & movement & keyboard all good...

suspend again; mouse on menu & selecting yep, wait, wake (get screen to display) & no issues at all !

with other machine on (more power to KVM switch) it looks fine, I suspect my kvm switch has a lot to do with this issue (these boxes that share keyboard/mouse are not used much; mostly testing or if i want something not on my main displays)

description: updated
Changed in xorg-server (Ubuntu):
status: New → Incomplete
description: updated
description: updated
Chris Guiver (guiverc) wrote :

for original report (live qa-test system on dc7700); I forgot to upload this file...

Chris Guiver (guiverc) on 2019-03-13
Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers