[amdgpu] ubuntu 18.04.2 daily is janky with chromium on fishgl.com?

Bug #1814607 reported by Dan Kegel on 2019-02-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

I've been testing as follows:
- install chromium (or chrome, or chrome beta)
- open http://fishgl.com
- crank up number of fish to 325 (or as high as it'll go and sustain 60 fps)
- after fish are happily swimming, watch them swim for 60 seconds, and count number of times the screen freezes

This was fine (i.e. zero hangs) on 18.04.1 + https://ubuntuforums.org/showthread.php?t=2400400
but not fine on 18.04.2 (i.e. always hangs briefly within 60 seconds)

The last four times I ran this, I got 4, 2, 8, 3 hangs in 60 seconds. Each hang usually lasted
for less than a second. Some lasted for a second and a half (maybe that was two hangs
back to back). Running xclock -update 1 seems to show that the hang extends to other apps,
i.e. when the fish hang, xclock also seems to hang. Running firefox in parallel, or a second
chromium window, seems to avoid the hang.

tail -f /var/log/syslog didn't show any new output during hangs.
(There are a lot of gnome-shell stack dumps in /var/log/syslog, fwiw.)

I'll try to test on a non-Hades system.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 4.18.0-14.15~18.04.1-generic 4.18.20
Uname: Linux 4.18.0-14-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Mon Feb 4 16:50:27 2019
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:694e] (rev c0) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation Device [8086:2073]
InstallationDate: Installed on 2019-02-04 (0 days ago)
InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Beta amd64 (20190204)
MachineType: Intel Corporation NUC8i7HNK
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.18.0-14-generic root=UUID=861436ab-4967-41b5-99bc-64b8726682a5 ro quiet splash vt.handoff=1
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/01/2018
dmi.bios.vendor: Intel Corp.
dmi.bios.version: HNKBLi70.86A.0049.2018.0801.1601
dmi.board.name: NUC8i7HNB
dmi.board.vendor: Intel Corporation
dmi.board.version: J68197-502
dmi.chassis.type: 3
dmi.chassis.vendor: Intel Corporation
dmi.chassis.version: 2.0
dmi.modalias: dmi:bvnIntelCorp.:bvrHNKBLi70.86A.0049.2018.0801.1601:bd08/01/2018:svnIntelCorporation:pnNUC8i7HNK:pvrJ71486-502:rvnIntelCorporation:rnNUC8i7HNB:rvrJ68197-502:cvnIntelCorporation:ct3:cvr2.0:
dmi.product.family: Intel NUC
dmi.product.name: NUC8i7HNK
dmi.product.version: J71486-502
dmi.sys.vendor: Intel Corporation
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.95-1~18.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.2.2-0ubuntu1~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.2.2-0ubuntu1~18.04.1
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Dan Kegel (dank) wrote :
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
tags: added: regression-update
tags: added: amdgpu
summary: - ubuntu 18.04.2 daily is janky with chromium on fishgl.com?
+ [amdgpu] ubuntu 18.04.2 daily is janky with chromium on fishgl.com?
Daniel van Vugt (vanvugt) wrote :

My first guess is that this might be an amdgpu-specific problem. So yes please do try a non-Hades system. I'm running 18.04.2 and can't reproduce any problem using Intel graphics.

Please also run:

  dmesg -w

and watch to see if any particular kernel messages correlate with the hangs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers