Ubuntu 18.04 falls back to LLVMpipe (CPU render) with Intel graphics (i9-9900k => UHD-630)

Bug #1802353 reported by Crati on 2018-11-08
This bug report is a duplicate of:  Bug #1789924: Missing Intel GPU pci-id's. Edit Remove
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

A fresh Xubuntu 18.04.1 install (from an ISO), on a machine with only the Intel integrated graphics (i9-9900k => UHD-630). The graphic drivers module seems to be properly loaded, but X rendering seems to fallback to LLVMpipe.
This was the case immediately after the install. The performance of the SW rendering improved significantly after the first update with the latest packages.

$ glxinfo | grep "OpenGL"
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

dmesg output:
[ 4.725296] [drm] Replacing VGA console driver
[ 4.731702] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 4.731704] [drm] Driver supports precise vblank timestamp query.
[ 4.733885] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[ 4.734288] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_01.bin (v1.1)
[ 5.003709] [drm] failed to retrieve link info, disabling eDP
[ 5.004608] [drm] Initialized i915 1.6.0 20171023 for 0000:00:02.0 on minor 0
[ 5.005628] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
[ 5.005799] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input5
[ 5.174759] fbcon: inteldrmfb (fb0) is primary device
[ 5.209969] Console: switching to colour frame buffer device 320x90
[ 5.229823] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device

I tried using the latest stable mesa from ubuntu-x-swat/updates but it did not help (I ppa-purge'd it before generating the bug report)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libegl1 1.0.0-2ubuntu2.2
ProcVersionSignature: Ubuntu 4.15.0-38.41-generic 4.15.18
Uname: Linux 4.15.0-38-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Nov 8 17:52:03 2018
InstallationDate: Installed on 2018-11-06 (2 days ago)
InstallationMedia: Xubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
SourcePackage: libglvnd
UpgradeStatus: No upgrade log present (probably fresh install)

Crati (cratiport) wrote :
description: updated
description: updated
Crati (cratiport) on 2018-11-08
description: updated
Timo Aaltonen (tjaalton) wrote :

please run 'apport-collect 1802353'

it's likely that some component is missing your GPU pci-id, but looks like it's not the kernel since drm loads.

affects: libglvnd (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → Incomplete
summary: Ubuntu 18.04 falls back to LLVMpipe (CPU render) with Intel graphics
+ (i9-9900k => UHD-630)

ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: XFCE
DistUpgraded: Fresh install
DistroCodename: bionic
DistroRelease: Ubuntu 18.04
DistroVariant: ubuntu
DkmsStatus: virtualbox, 5.2.10, 4.15.0-38-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation Device [8086:3e98] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8694]
InstallationDate: Installed on 2018-11-06 (2 days ago)
InstallationMedia: Xubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 002: ID 04b3:3025 IBM Corp. NetVista Full Width Keyboard
 Bus 001 Device 003: ID 17ef:6045 Lenovo
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System manufacturer System Product Name
Package: xorg-server (not installed)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-38-generic root=UUID=73b446f0-5e3a-4b2f-8fe6-b6b64e8f1e37 ro drm.debug=0xe plymouth:debug
ProcVersionSignature: Ubuntu 4.15.0-38.41-generic 4.15.18
Renderer: Software
Tags: bionic ubuntu
Uname: Linux 4.15.0-38-generic x86_64
UnreportableReason: This report is about a package that is not installed.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo video
_MarkForUpload: False
dmi.bios.date: 09/21/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0411
dmi.board.asset.tag: Default string
dmi.board.name: PRIME Z370-P II
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0411:bd09/21/2018:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnPRIMEZ370-PII:rvrRevX.0x:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.91-2
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~18.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Fri Nov 9 09:57:48 2018
xserver.configfile: default
xserver.errors:
 modeset(0): glamor initialization failed
 AIGLX: reverting to software rendering
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.6-1ubuntu4.2
xserver.video_driver: modeset

tags: added: apport-collected ubuntu

apport information

crati2 (crati2) wrote : DpkgLog.txt

apport information

crati2 (crati2) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

crati2 (crati2) wrote : UdevDb.txt

apport information

crati2 (crati2) wrote : XorgLog.txt

apport information

apport information

crati2 (crati2) wrote : Xrandr.txt

apport information

crati2 (crati2) wrote : xdpyinfo.txt

apport information

apport information

apport information

crati2 (crati2) wrote :

Thanks Timo, note that I installed xdiagnose, and set it to print "extra graphics debug messages"

Timo Aaltonen (tjaalton) wrote :

thanks, this is a dupe of 1789924, mesa doesn't have 3e98 yet in a stable release

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers