Desktop live cd boots corrupted screen in Virtualbox on Bionic

Bug #1796822 reported by Will Cooke on 2018-10-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Dimitri John Ledkov
Cosmic
High
Dimitri John Ledkov
xorg-server (Ubuntu)
High
Timo Aaltonen

Bug Description

On a Bionic host running the standard archive version of Virtualbox and the daily ISO of Cosmic, the live session starts with a corrupted graphical display, as can be seen here:

https://imgur.com/a/rkTId4S

(also attached)

Switching VTs to 2 and back to 1 clears the display and things work again.

Will Cooke (willcooke) wrote :
Will Cooke (willcooke) wrote :

Logs from the live session show that xorg started before the vbox video driver was ready
dmesg attached

Will Cooke (willcooke) wrote :

xorg log

Will Cooke (willcooke) wrote :

From IRC:

<willcooke> xorg log: https://paste.ubuntu.com/p/kgYWct2QP2/
<willcooke> dmesg: https://paste.ubuntu.com/p/fbXBC64yHz/
<willcooke> [ 14.762240] vboxvideo: module is from the staging directory, the quality is unknown, you have been warned.
<willcooke> [ 14.762271] vboxvideo: module verification failed: signature and/or required key missing - tainting kernel
<willcooke> [ 14.774141] [drm] VRAM 01800000
<willcooke> [ 14.789234] [TTM] Zone kernel: Available graphics memory: 743060 kiB
<willcooke> [ 14.789235] [TTM] Initializing pool allocator
<willcooke> [ 14.789238] [TTM] Initializing DMA pool allocator
<willcooke> [ 14.860361] fbcon: vboxdrmfb (fb0) is primary device
<willcooke> [ 14.860441] Console: switching to colour frame buffer device 100x37
<willcooke> [ 14.860446] vboxvideo 0000:00:02.0: fb0: vboxdrmfb frame buffer device
<willcooke> [ 14.860458] [drm] Initialized vboxvideo 1.0.0 20130823 for 0000:00:02.0 on minor 0
<willcooke> vs
<willcooke> [ 14.592]
<willcooke> X.Org X Server 1.20.1

Changed in xorg-server (Ubuntu):
status: New → Confirmed
importance: Undecided → High
importance: High → Critical
tags: added: rls-cc-incoming
Timo Aaltonen (tjaalton) wrote :

After installation vboxvideo is loaded much earlier (no rootfs to unpack) and getting userspace up and running takes a few seconds, so once X is started the native driver is ready and everything works as it should.

On the live-session though, the xserver realizes a new device has arrived and loads modesetting on it (with VESA already loaded) and we get this mess. While this is a bug in the X stack, getting it fixed properly before release is unlikely, because it's a fringe case no-one else is seeing.

Timo Aaltonen (tjaalton) wrote :

adding vboxvideo to initrd seems to load it at 1.2s instead of 6.6s on my instance, giving it plenty of time for X to not cause issues

Will Cooke (willcooke) wrote :

What is the fringe case here?

The desktop team have tested on a variety of different hardware and we can reproduce this issue every time. I think this is a significant issue for desktop users and will affect anyone trying to run Cosmic in Virtualbox on Ubuntu.

We know from the Ubuntu Report data that a significant percentage of users run in Virtualbox, so we need this to work.

Will Cooke (willcooke) on 2018-10-09
Changed in xorg-server (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) wrote :

it's a fringe case for devs who use other distributions

Iain Lane (laney) on 2018-10-09
tags: removed: rls-cc-incoming
Changed in initramfs-tools (Ubuntu Cosmic):
importance: Undecided → High
status: New → Fix Committed
assignee: nobody → Dimitri John Ledkov (xnox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.131ubuntu14

---------------
initramfs-tools (0.131ubuntu14) cosmic; urgency=medium

  * hooks/framebuffer: manual_add_modules vboxvideo to support graphical
    boot in VirtualBox. LP: #1796822

 -- Dimitri John Ledkov <email address hidden> Wed, 10 Oct 2018 11:06:00 +0100

Changed in initramfs-tools (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Will Cooke (willcooke) wrote :

Confirming that todays pending ISO boots correctly on Vbox.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1796822

tags: added: iso-testing
Jeremy Bicha (jbicha) wrote :

I can still reproduce this bug with the Ubuntu cosmic 20181014 iso on VirtualBox (my host is also running cosmic and I use the distro-packaged VirtualBox). The workaround mentioned in the bug description works well.

Jeremy Bicha (jbicha) wrote :

Never mind. I think I somehow managed to boot an older iso. I zsynced just before so I don't know how that happened. I can't reproduce this bug any more.

Jeremy Bicha (jbicha) wrote :

I have a similar case. Let me know if you want me to file a new bug and where to file it.

Test Case
=========
Install Ubuntu 18.10 in VirtualBox. Restart
Log in. Open Settings > Details > Users. Unlock then turn on Automatic Login.
Restart.

I get the similar corrupted display. My screen resolution is locked to 1024x768.

The workaround for the corruption is to switch to a virtual terminal and back, but I still end up have screen drawing issues.

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :

Personally I can't reproduce that, so please check if the fix for bug #1794280 also works here.

Sebastien Bacher (seb128) wrote :

Untargetting the xorg part from cosmic since the initramfs was enough to workaround the problem there

no longer affects: xorg-server (Ubuntu Cosmic)
Changed in xorg-server (Ubuntu):
importance: Critical → High
Daniel van Vugt (vanvugt) wrote :

FYI, similar skewed stride bugs on:

radeon: bug 1799103
Huawei rack servers: bug 1780076

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers