Cosmic Desktop fails to boot in vbox: Xorg assert failure: Xorg: ../../../../dix/privates.c:384: dixRegisterPrivateKey: Assertion `!global_keys[type].created' failed.

Bug #1792932 reported by Jean-Baptiste Lallement on 2018-09-17
102
This bug affects 23 people
Affects Status Importance Assigned to Milestone
X.Org X server
Unknown
Unknown
xorg-server (Ubuntu)
Status tracked in Cosmic
Nominated for Bionic by Daniel van Vugt
Nominated for Xenial by Daniel van Vugt
Cosmic
High
Timo Aaltonen

Bug Description

https://errors.ubuntu.com/problem/4ffab1fb339140b2c39fa0d096293706399e7280
https://errors.ubuntu.com/problem/d18c1a21ca8ed1bb6cca06ddb5350187bed44f80

---

Test Case:
Boot Ubuntu Cosmic Desktop 20180916 on Virtual Box

Actual Result
Black screen or dropped to the login screen if the user skips ubiquity-dm

Workaround:
Add nomodeset on the kernel command line or from the boot menu, press F6 then select nomodeset

Possibly a duplicate of bug 1432137

ProblemType: Crash
DistroRelease: Ubuntu 18.10
Package: xserver-xorg-core 2:1.20.1-1ubuntu2
ProcVersionSignature: Ubuntu 4.18.0-7.8-generic 4.18.5
Uname: Linux 4.18.0-7-generic x86_64
ApportVersion: 2.20.10-0ubuntu9
Architecture: amd64
AssertionMessage: Xorg: ../../../../dix/privates.c:384: dixRegisterPrivateKey: Assertion `!global_keys[type].created' failed.
CasperVersion: 1.395
CompositorRunning: None
Date: Mon Sep 17 12:42:24 2018
DistUpgraded: Fresh install
DistroCodename: cosmic
DistroVariant: ubuntu
ExecutablePath: /usr/lib/xorg/Xorg
ExtraDebuggingInterest: Yes
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
LiveMediaBuild: Ubuntu 18.10 "Cosmic Cuttlefish" - Alpha amd64 (20180916)
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcCmdline: /usr/lib/xorg/Xorg vt1 -displayfd 3 -auth /run/user/999/gdm/Xauthority -background none -noreset -keeptty -verbose 3
ProcEnviron:

ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd --- keyboard-configuration/layoutcode=fr keyboard-configuration/variantcode=oss
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
 __GI_abort () at abort.c:79
 __assert_fail_base (fmt=0x7f60fa1e3858 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=0x563dbf96db7d "!global_keys[type].created", file=0x563dbf96db38 "../../../../dix/privates.c", line=384, function=<optimized out>) at assert.c:92
 __GI___assert_fail (assertion=0x563dbf96db7d "!global_keys[type].created", file=0x563dbf96db38 "../../../../dix/privates.c", line=384, function=0x563dbf96dde0 "dixRegisterPrivateKey") at assert.c:101
 dixRegisterPrivateKey ()
Title: Xorg assert failure: Xorg: ../../../../dix/privates.c:384: dixRegisterPrivateKey: Assertion `!global_keys[type].created' failed.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.family: Virtual Machine
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.94-1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.1.5-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.1.5-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.20.1-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1build1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1build1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-3

Jean-Baptiste Lallement (jibel) wrote :
information type: Private → Public
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
tags: added: rms-cc-incoming
tags: added: rls-cc-incoming
removed: rms-cc-incoming
Timo Aaltonen (tjaalton) wrote :

could be a mesa bug which is fixed in 18.1.7/18.2.0-rc5+, please test the latter from

ppa:canonical-x/x-staging

which has 18.2.0

Timo Aaltonen (tjaalton) on 2018-09-18
Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1432137, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

summary: - Xorg assert failure: Xorg: ../../../../dix/privates.c:384:
- dixRegisterPrivateKey: Assertion `!global_keys[type].created' failed.
+ Cosmic Desktop fails to boot in vbox: Xorg assert failure: Xorg:
+ ../../../../dix/privates.c:384: dixRegisterPrivateKey: Assertion
+ `!global_keys[type].created' failed.
description: updated
Changed in xorg-server (Ubuntu):
importance: Undecided → High
assignee: nobody → Timo Aaltonen (tjaalton)
tags: added: rls-cc-tracking
removed: rls-cc-incoming
Jean-Baptiste Lallement (jibel) wrote :

ubiquity-dm then the session start with mesa from the canonical-x/x-staging PPA.

Changed in xorg-server (Ubuntu Cosmic):
status: Incomplete → Triaged
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1792932

tags: added: iso-testing
Iain Lane (laney) wrote :

that mesa is now on the latest ISOs, and apparently doesn't fix it after all

Timo Aaltonen (tjaalton) wrote :

right, not this case which is a bit weird one

Booting up the live image desktop does this:
- vboxvideo.ko is not initialized when X starts
- X unloads modesetting and configures the vesa driver instead
- vboxvideo.ko is initialized later and xserver loads modesetting again
- DRI is initialized and at this point the server goes boom

Then the installer will load gdm and it works normally, because vboxvideo.ko is loaded. On the installed system the initrd probably has vboxvideo in it so it's loaded earlier, but I haven't confirmed this.

In any case, the xserver probably shouldn't crash like it does, I'll try filing it upstream.

Timo Aaltonen (tjaalton) wrote :

was filed upstream already, linked here

Judging by the duplicates it looks like this isn't specific to virtualbox. It's been happening for a few years.

summary: - Cosmic Desktop fails to boot in vbox: Xorg assert failure: Xorg:
- ../../../../dix/privates.c:384: dixRegisterPrivateKey: Assertion
- `!global_keys[type].created' failed.
+ Xorg assert failure: Xorg: ../../../../dix/privates.c:384:
+ dixRegisterPrivateKey: Assertion `!global_keys[type].created' failed.
description: updated
tags: added: bionic xenial
description: updated
description: updated
summary: - Xorg assert failure: Xorg: ../../../../dix/privates.c:384:
- dixRegisterPrivateKey: Assertion `!global_keys[type].created' failed.
+ Cosmic Desktop fails to boot in vbox: Xorg assert failure: Xorg:
+ ../../../../dix/privates.c:384: dixRegisterPrivateKey: Assertion
+ `!global_keys[type].created' failed.
Sebastien Bacher (seb128) wrote :

the bug should be fixed with that upload (currently in proposed), https://launchpad.net/ubuntu/+source/xorg-server/2:1.20.1-3ubuntu2

Changed in xorg-server (Ubuntu Cosmic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.20.1-3ubuntu2

---------------
xorg-server (2:1.20.1-3ubuntu2) cosmic; urgency=medium

  * dont-init-glamor-on-llvmpipe.diff: Glamor shouldn't be used on
    llvmpipe, as it might end up crashing the server on a racy bootup.
    (LP: #1792932)

 -- Timo Aaltonen <email address hidden> Tue, 02 Oct 2018 21:40:03 +0300

Changed in xorg-server (Ubuntu Cosmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.