sudo apt-get install xserver-xorg-video-intel

Bug #1787581 reported by Brij raj Singh on 2018-08-17

This bug report will be marked for expiration in 29 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

While attempting to install display drivers.

My laptop's battery gets drained too early because of power setting & don't have hibernate option.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3.1
ProcVersionSignature: Ubuntu 4.15.0-32.35~16.04.1-generic 4.15.18
Uname: Linux 4.15.0-32-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
BootLog:

CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Aug 17 16:33:57 2018
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Haswell-ULT Integrated Graphics Controller [103c:2212]
   Subsystem: Hewlett-Packard Company GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] [103c:2212]
InstallationDate: Installed on 2018-07-23 (24 days ago)
InstallationMedia: Ubuntu 16.04.4 LTS "Xenial Xerus" - Release amd64 (20180228)
MachineType: Hewlett-Packard 15-r014tx
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-32-generic root=UUID=1ce01056-3b54-40dc-8a89-fa42de6dc8ab ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/18/2014
dmi.bios.vendor: Insyde
dmi.bios.version: F.36
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 2212
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 86.49
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.36:bd12/18/2014:svnHewlett-Packard:pn15-r014tx:pvr0985110000450E10001000000:rvnHewlett-Packard:rn2212:rvr86.49:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV G=N L=CON B=HP S=PAV
dmi.product.name: 15-r014tx
dmi.product.version: 0985110000450E10001000000
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.12.3+16.04.20180221-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.91-2~16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~16.04.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~16.04.1
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Fri Aug 17 10:07:22 2018
xserver.configfile: default
xserver.errors:
 /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 NOUVEAU(G0): [XvMC] Failed to initialize extension.
 /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.6-1ubuntu4~16.04.1
xserver.video_driver: modeset

Brij raj Singh (brijrajsingh27) wrote :
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

Ubuntu already fully supports Intel GPUs using the built-in "modesetting" driver. So you don't need to install xserver-xorg-video-intel and it probably would not help power usage if you did.

What is the main problem you're trying to solve? If it's the power usage then the Nvidia GPU is more likely the main problem. To reduce the power usage there you can:

 * Maybe disable the secondary GPU in your BIOS; or
 * Install a more power-efficient driver by looking in:
     Settings > Software & Updates > Additional drivers

Is power usage the main problem?

Changed in xorg-server (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers