slideshow screensaver makes X to crash in pixman_composite_rect_general

Bug #175321 reported by Marco Lazzaroni
6
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Invalid
Medium
Unassigned

Bug Description

Binary package hint: gnome-screensaver

/usr/lib/gnome-screensaver/gnome-screensaver/slideshow makes X to crash.
I have ubuntu Hardy installed, in Italian.
I tried debugging it compiling it (gnome-screensaver_2.20.0 found here) and running it with no arguments; location is correctly set to 'home/marco/Immagini' (my correct pictures folder).
But then when I step in to gtk_main(), X crashes...

Revision history for this message
Pedro Villavicencio (pedro) wrote :

thanks for your report, please include the files listed at https://wiki.ubuntu.com/X/Debugging , especially the ones at the section "What To Include in Bug Reports/X crash, lockup, freeze, exit, or doesn't start/shutdown" also ask to the questions listed there, thanks.

Changed in gnome-screensaver:
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
Marco Lazzaroni (marcolazzaroni) wrote :

I must say I'm running Ubuntu Hardy in Virtual Box 1.5.2.

Output of
lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef]

Revision history for this message
Marco Lazzaroni (marcolazzaroni) wrote :
Revision history for this message
Marco Lazzaroni (marcolazzaroni) wrote :
Revision history for this message
Marco Lazzaroni (marcolazzaroni) wrote :

I think that this attachment is very important, it ends up with the following:

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x7e) [0x80c744e]
1: [0xffffe420]
2: /usr/lib/libpixman-1.so.0(pixman_composite_rect_general+0x45c) [0xb7e638ec]
3: /usr/lib/libpixman-1.so.0 [0xb7e79736]
4: /usr/lib/libpixman-1.so.0(pixman_image_composite+0x598) [0xb7e78a88]
5: /usr/lib/xorg/modules//libfb.so(fbComposite+0x1ad) [0xb794a90d]
6: /usr/bin/X [0x81727f3]
7: /usr/bin/X(CompositePicture+0x150) [0x81599e0]
8: /usr/bin/X [0x815f9bf]
9: /usr/bin/X [0x815c875]
10: /usr/bin/X [0x814feee]
11: /usr/bin/X(Dispatch+0x2cf) [0x808d93f]
12: /usr/bin/X(main+0x48b) [0x80747ab]
13: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7c9b450]
14: /usr/bin/X(FontFileCompleteXLFD+0x20d) [0x8073b21]

Fatal server error:
Caught signal 11. Server aborting

Revision history for this message
Marco Lazzaroni (marcolazzaroni) wrote :
Revision history for this message
Marco Lazzaroni (marcolazzaroni) wrote :

the backtrace at the end of /var/log/Xorg.0.log.old is always the same.
Another thing: I installed from source glib 2.14.4, using the package found here: ftp://ftp.gtk.org/pub/glib/2.14/glib-2.14.4.tar.bz2
If you need further information, please let me know.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

Re-assigning to xorg, thanks you.

Changed in gnome-screensaver:
status: Incomplete → New
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Can you reproduce this at will? I'm trying to make it crash running a real session with vesa driver, but so far haven't been able to. The slideshow window is just blank.

Changed in xorg-server:
status: New → Incomplete
Revision history for this message
Andreas (andreas-kotowicz) wrote : Re: [Bug 175321] Re: slideshow screensaver makes X to crash in pixman_composite_rect_general

On 1/2/08, Timo Aaltonen <email address hidden> wrote:
> Can you reproduce this at will? I'm trying to make it crash running a
> real session with vesa driver, but so far haven't been able to. The
> slideshow window is just blank.

no, I can't. I guess the bug I'm seeing at my place is different and
has nothing to do with pixman:

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x7e) [0x80c743e]
1: [0xffffe420]
2: /usr/lib/xorg/modules//libxaa.so [0xb78ae899]
3: /usr/bin/X [0x8172853]
4: /usr/bin/X(CompositePicture+0x150) [0x8159a30]
5: /usr/bin/X [0x815fa0f]
6: /usr/bin/X [0x815c8c5]
7: /usr/bin/X [0x814ff3e]
8: /usr/bin/X(Dispatch+0x2cf) [0x808d8ff]
9: /usr/bin/X(main+0x48b) [0x807476b]
10: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7c90450]
11: /usr/bin/X(FontFileCompleteXLFD+0x205) [0x8073ae1]

Revision history for this message
Marco Lazzaroni (marcolazzaroni) wrote :

Timo, the problem shows up every time I run slideshow. Hope I can give you some more information.
Cheers,
 Marco

Revision history for this message
Connor Imes (ckimes) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release?

If the problem still occurs, can you add the attachments from https://wiki.ubuntu.com/X/Debugging again, then we finish the triage on the bug.

Thanks in advance.

Revision history for this message
Connor Imes (ckimes) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Specifically, please let us know if the bug still exists, and if so, please re-attach the information that was requested in Comment 1 using Intrepid (or at least Hardy).

Thanks again!

Changed in xorg-server:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers