Xwayland crashed with SIGABRT in OsAbort() from AbortServer() from FatalError() from InitOutput()

Bug #1751508 reported by Robson William on 2018-02-24
52
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

Xorg crashed with VS Code.

ProblemType: Crash
DistroRelease: Ubuntu 18.04
Package: xwayland 2:1.19.6-1ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
Uname: Linux 4.15.0-10-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CrashCounter: 1
CurrentDesktop: GNOME-Greeter:GNOME
Date: Sat Feb 24 18:28:10 2018
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xwayland
GraphicsCard:
 Intel Corporation HD Graphics 5500 [8086:1616] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo HD Graphics 5500 [17aa:3820]
InstallationDate: Installed on 2018-02-24 (0 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180222)
MachineType: LENOVO 80NE
ProcCmdline: /usr/bin/Xwayland :1024 -rootless -terminate -core -listen 4 -listen 5 -displayfd 6
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-10-generic.efi.signed root=UUID=0beb58c8-0bf5-4e01-95dd-ae78f4ce0dea ro quiet splash vt.handoff=1
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 OsAbort ()
 ?? ()
 FatalError ()
 InitOutput ()
 ?? ()
Title: Xwayland crashed with SIGABRT in OsAbort()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 09/09/2015
dmi.bios.vendor: Lenovo
dmi.bios.version: BDCN61WW
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Lenovo Yoga 500-14IBD
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40688 WIN
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo Yoga 500-14IBD
dmi.modalias: dmi:bvnLenovo:bvrBDCN61WW:bd09/09/2015:svnLENOVO:pn80NE:pvrLenovoYoga500-14IBD:rvnLENOVO:rnLenovoYoga500-14IBD:rvrSDK0J40688WIN:cvnLENOVO:ct10:cvrLenovoYoga500-14IBD:
dmi.product.family: IDEAPAD
dmi.product.name: 80NE
dmi.product.version: Lenovo Yoga 500-14IBD
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.90-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.3.3-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 17.3.3-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

Robson William (robson.dba) wrote :

StacktraceTop:
 OsAbort () at ../../../../os/utils.c:1361
 AbortServer () at ../../../../os/log.c:877
 FatalError (f=f@entry=0x55a1df546857 "Couldn't add screen\n") at ../../../../os/log.c:1015
 InitOutput (screen_info=screen_info@entry=0x55a1df7d50a0 <screenInfo>, argc=argc@entry=11, argv=argv@entry=0x7ffdecc2ee08) at ../../../../../hw/xwayland/xwayland.c:926
 dix_main (argc=11, argv=0x7ffdecc2ee08, envp=<optimized out>) at ../../../../dix/main.c:197

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
information type: Private → Public
Alex Murray (alexmurray) wrote :

I am also seeing this on a similar system - Lenovo Thinkpad X260 - and for me this occurs when I boot with the laptop docked with two external monitors connected. If I boot without it docked then it boots fine - but when docked Xwayland seems to always crash on startup.

summary: - Xwayland crashed with SIGABRT in OsAbort()
+ Xwayland crashed with SIGABRT in OsAbort() from AbortServer() from
+ FatalError() from InitOutput()
To post a comment you must log in.