Xwayland crashed with SIGABRT in OsAbort() from AbortServer() from FatalError() from xwl_log_handler() from wl_log() ["wl_registry@2: error 0: invalid global wl_output (20)\n"]

Bug #1745799 reported by Mario Limonciello
150
This bug affects 13 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

Crashes when plugging in Dell WD15

ProblemType: Crash
DistroRelease: Ubuntu 18.04
Package: xwayland 2:1.19.5-0ubuntu2
Uname: Linux 4.15.0-rc8+ x86_64
ApportVersion: 2.20.8-0ubuntu6
Architecture: amd64
CompositorRunning: None
CrashCounter: 1
CurrentDesktop: ubuntu:GNOME
Date: Sat Jan 27 22:12:41 2018
DistUpgraded: 2018-01-26 09:36:11,455 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
DistroCodename: bionic
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xwayland
ExtraDebuggingInterest: No
GraphicsCard:
 Intel Corporation Device [8086:591e] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:077a]
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 0bda:5690 Realtek Semiconductor Corp.
 Bus 001 Device 003: ID 138a:0091 Validity Sensors, Inc.
 Bus 001 Device 002: ID 8087:0a2b Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. XPS 13 9365
ProcCmdline: /usr/bin/Xwayland :0 -rootless -terminate -core -listen 4 -listen 5 -displayfd 6
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-rc8+ root=UUID=fe08dba8-d746-4a04-82c9-cac962e9321c ro quiet splash wmi.debug_dump_wdg=1 vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 OsAbort ()
 ?? ()
 FatalError ()
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libwayland-client.so.0
Title: Xwayland crashed with SIGABRT in OsAbort()
UpgradeStatus: Upgraded to bionic on 2018-01-26 (1 days ago)
UserGroups: adm cdrom dip docker lpadmin plugdev sambashare sudo
dmi.bios.date: 12/05/2017
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.0.21
dmi.board.name: 0DVT6M
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 31
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.0.21:bd12/05/2017:svnDellInc.:pnXPS139365:pvr:rvnDellInc.:rn0DVT6M:rvrA00:cvnDellInc.:ct31:cvr:
dmi.product.family: XPS
dmi.product.name: XPS 13 9365
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.13.1+18.04.20171116-0ubuntu1
version.libdrm2: libdrm2 2.4.89-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.4-0ubuntu2
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.4-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

Revision history for this message
Mario Limonciello (superm1) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 OsAbort () at ../../../../os/utils.c:1361
 AbortServer () at ../../../../os/log.c:877
 FatalError (f=f@entry=0x55df4a60cfa6 "%s") at ../../../../os/log.c:1015
 xwl_log_handler (format=<optimized out>, args=<optimized out>) at ../../../../../hw/xwayland/xwayland.c:885
 wl_log (fmt=<optimized out>) at ../src/wayland-util.c:406

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
tags: added: artful
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: Xwayland crashed with SIGABRT in OsAbort()

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
summary: - Xwayland crashed with SIGABRT in OsAbort()
+ OsAbort() from AbortServer() from FatalError() from xwl_log_handler()
+ from wl_log() ["wl_registry@2: error 0: invalid global wl_output
+ (20)\n"]
tags: added: cosmic
summary: - OsAbort() from AbortServer() from FatalError() from xwl_log_handler()
- from wl_log() ["wl_registry@2: error 0: invalid global wl_output
- (20)\n"]
+ Xwayland crashed with SIGABRT in OsAbort() from AbortServer() from
+ FatalError() from xwl_log_handler() from wl_log() ["wl_registry@2: error
+ 0: invalid global wl_output (20)\n"]
Revision history for this message
Gert van de Kraats (gkraats) wrote :

I created bug #1795760, which describes a Xwayland-abort and got the status duplicate of 1745799.

Below is a part of the symbolic trace of the abort.

 #7 0x004b6296 in xwl_log_handler (format=0xb7dc71ea "%s@%u: error %d: %s\n", args=0xbf9c7994 "\027uܷ\255\001") at ../../../../../hw/xwayland/xwayland.c:1137
         msg = "wl_surface@429: error 2: Failed to create a texture for surface 429: Failed to create texture 2d due to size/format constraints\n", '\000' <repeats 127 times>
 #8 0xb7dc5fef in wl_log (fmt=0xb7dc71ea "%s@%u: error %d: %s\n") at ../src/wayland-util.c:404

Problem can be solved by using slicing at shm_buffer_attach() at src/wayland/meta-wayland-buffer.c, if size of texture is too large for graphics card.

I attach a bug-fix to this bug, which is tested during a long time.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "error9_patch.txt" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Gert,

I agree bug 1795760 is different. It has been unmarked as a duplicate so maybe use that instead?

tags: removed: cosmic
tags: removed: artful
tags: added: eoan
tags: added: bugpattern-needed
tags: added: focal
tags: added: hirsute
To post a comment you must log in.