Comment 0 for bug 1707691

/usr/include/xorg/dixfont.h includes X11/fonts/fontutil.h.

fontutil.h is contained in libxfont1-dev package not libxfont-dev package (version 2.0.1).

I am trying to build xorgxrdp and it fails because fontutil.h is missing.

In Ubuntu, libxfont1-dev package is required however libxfont1-dev and libxfont-dev cannot be installed together. This is the problem.

I looked at Debian, too. /usr/include/xorg/dixfont.h in Debian does NOT include X11/fonts/fontutil.h.

This is the right state.

Package info: Ubuntu 16.04

$ dpkg -la | grep -e xserver-xorg-dev -e libxfont-dev
ii libxfont-dev 1:2.0.1-3~ubuntu16.04.1 amd64 X11 font rasterisation library (development headers)
ii xserver-xorg-dev 2:1.18.4-0ubuntu0.3 amd64 Xorg X server - development files

brian