Please drop debian/patches/disable-rotation-transform-gpuscreens.patch of xorg-server

Bug #1706287 reported by Shih-Yuan Lee on 2017-07-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Timo Aaltonen
Xenial
Undecided
Unassigned

Bug Description

[Impact]
Display rotation does not work when the NVIDIA driver is used. This is caused by a distro patch to xserver which disables it, because the NVIDIA driver had issues in the past.

NVIDIA Graphics driver 375.66 has supported the rotation since Ubuntu 16.04.

[Test case]
Install nvidia blob, try to rotate with xrandr or the display capplet.

[Regression potential]
No other distro shipped with such a patch, so there should be minimal risk of regressing anything.

tags: added: originate-from-1693131
Timo Aaltonen (tjaalton) wrote :

this is fixed since zesty

Changed in xorg-server (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → Fix Released
tags: added: originate-from-1691715
Timo Aaltonen (tjaalton) on 2017-07-25
description: updated
Timo Aaltonen (tjaalton) wrote :

a new version is now in -proposed, please test and change the tag to verification-done-xenial if it works

tags: added: verification-needed-xenial
Changed in xorg-server (Ubuntu Xenial):
status: New → Fix Committed
Shih-Yuan Lee (fourdollars) wrote :

I have verified the xorg packages in xenial-proposed on some laptop with NVIDIA Graphics and it does fix the problem.

tags: added: verification-done-xenial
removed: verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers