Xorg assert failure: Xorg: ../../glamor/glamor_fbo.c:189: glamor_pixmap_ensure_fb: Assertion `fbo->tex != 0' failed.

Bug #1627852 reported by autra on 2016-09-26
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

[Steps]
I don't know, automatic bug report. I have the displaylink linux drivers installed, btw. I was testing it when this crash appears, so it may be related.

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: xserver-xorg-core 2:1.18.4-1ubuntu6
ProcVersionSignature: Ubuntu 4.8.0-16.17-generic 4.8.0-rc7
Uname: Linux 4.8.0-16-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
AssertionMessage: Xorg: ../../glamor/glamor_fbo.c:189: glamor_pixmap_ensure_fb: Assertion `fbo->tex != 0' failed.
BootLog:
 WARNING: Failed to connect to lvmetad. Falling back to device scanning.
 /dev/mapper/ubuntu--vg-root: clean, 3210374/15122432 files, 46188509/60467200 blocks
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
Date: Mon Sep 26 22:50:29 2016
DistUpgraded: 2016-09-26 18:59:06,915 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
DistroCodename: yakkety
DistroVariant: ubuntu
ExecutablePath: /usr/lib/xorg/Xorg
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell 3rd Gen Core processor Graphics Controller [1028:058b]
InstallationDate: Installed on 2015-02-16 (588 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
MachineType: Dell Inc. Dell System XPS L322X
ProcCmdline: /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.8.0-16-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 __assert_fail_base (fmt=<optimized out>, assertion=assertion@entry=0x7f6df1a0a305 "fbo->tex != 0", file=file@entry=0x7f6df1a0a2eb "../../glamor/glamor_fbo.c", line=line@entry=189, function=function@entry=0x7f6df1a0a440 "glamor_pixmap_ensure_fb") at assert.c:92
 __GI___assert_fail (assertion=0x7f6df1a0a305 "fbo->tex != 0", file=0x7f6df1a0a2eb "../../glamor/glamor_fbo.c", line=189, function=0x7f6df1a0a440 "glamor_pixmap_ensure_fb") at assert.c:101
 ?? () from /usr/lib/xorg/modules/libglamoregl.so
 ?? () from /usr/lib/xorg/modules/libglamoregl.so
 glamor_set_pixmap_texture () from /usr/lib/xorg/modules/libglamoregl.so
Title: Xorg assert failure: Xorg: ../../glamor/glamor_fbo.c:189: glamor_pixmap_ensure_fb: Assertion `fbo->tex != 0' failed.
UpgradeStatus: Upgraded to yakkety on 2016-09-26 (0 days ago)
UserGroups: dialout
dmi.bios.date: 05/15/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0PJHXN
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd05/15/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn0PJHXN:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L322X
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.13.0+16.10.20160818.2-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.70-1
version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.3-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.3-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160706-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-2

autra (autra) wrote :

StacktraceTop:
 __assert_fail_base (fmt=<optimized out>, assertion=assertion@entry=0x7f6df1a0a305 "fbo->tex != 0", file=file@entry=0x7f6df1a0a2eb "../../glamor/glamor_fbo.c", line=line@entry=189, function=function@entry=0x7f6df1a0a440 <__PRETTY_FUNCTION__.44820> "glamor_pixmap_ensure_fb") at assert.c:92
 __GI___assert_fail (assertion=0x7f6df1a0a305 "fbo->tex != 0", file=0x7f6df1a0a2eb "../../glamor/glamor_fbo.c", line=189, function=0x7f6df1a0a440 <__PRETTY_FUNCTION__.44820> "glamor_pixmap_ensure_fb") at assert.c:101
 glamor_pixmap_ensure_fb () from /tmp/apport_sandbox_Y7KoUh/usr/lib/xorg/modules/libglamoregl.so
 glamor_create_fbo_from_tex () from /tmp/apport_sandbox_Y7KoUh/usr/lib/xorg/modules/libglamoregl.so
 glamor_set_pixmap_texture () from /tmp/apport_sandbox_Y7KoUh/usr/lib/xorg/modules/libglamoregl.so

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
To post a comment you must log in.