Xorg crashes with modeset driver on kernel 4.8-rc3 with SIGABRT in OsAbort()

Bug #1615540 reported by Rocko on 2016-08-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

With kernel 4.8-rc3, lightdm no longer starts if the modesetting driver is in use, because X crashes (I get the 'X is running in low-graphics mode' message). The modesetting driver works ok though with kernels 4.4, 4.6, and 4.7.

Using the intel driver it boots up fine (well, almost - the laptop screen turns off during login, so I have to type in my password blind, but then the laptop screen turns on and the desktop fires up).

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: xserver-xorg-core 2:1.18.4-1ubuntu4
Uname: Linux 4.8.0-040800rc3-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
BootLog:

CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
Date: Mon Aug 22 16:41:32 2016
DistUpgraded: 2016-07-25 02:38:44,004 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
DistroCodename: yakkety
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/xorg/Xorg
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation HD Graphics 530 [8086:191b] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Dell HD Graphics 530 [1028:06e4]
InstallationDate: Installed on 2016-07-04 (48 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
MachineType: Dell Inc. XPS 15 9550
ProcCmdline: /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-4.6.4-040604-generic root=UUID=8de7ebec-48db-48b6-9eb9-fafdee4eb7d6 ro rootflags=subvol=@ quiet splash nogpumanager vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 OsAbort ()
 ?? ()
 FatalError ()
 ?? ()
 __libc_start_main (main=0x55af52986210, argc=11, argv=0x7ffd2722f988, init=<optimised out>, fini=<optimised out>, rtld_fini=<optimised out>, stack_end=0x7ffd2722f978) at ../csu/libc-start.c:291
Title: Xorg crashed with SIGABRT in OsAbort()
UpgradeStatus: Upgraded to yakkety on 2016-07-24 (28 days ago)
UserGroups:

dmi.bios.date: 04/07/2016
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 01.02.00
dmi.board.name: 0N7TVV
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr01.02.00:bd04/07/2016:svnDellInc.:pnXPS159550:pvr:rvnDellInc.:rn0N7TVV:rvrA01:cvnDellInc.:ct9:cvr:
dmi.product.name: XPS 15 9550
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.13.0+16.10.20160818.2-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.70-1
version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.1-3ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.1-3ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-1ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160706-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Rocko (rockorequin) wrote :
Rocko (rockorequin) wrote :

Here's the Xorg.0.log from when it crashes. The initial error is "(EE) modeset(0): failed to set mode: Invalid argument".

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1543192, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
Rocko (rockorequin) wrote :

I don't think this is a duplicate of https://bugs.launchpad.net/bugs/1543192. Although it triggers a crash at the same point, the underlying cause of this bug is an incompatibility between the modesetting driver and kernel 3.8-rc3. (Unless the underlying bug is in the kernel and it triggers the other bug.)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Rocko (rockorequin) wrote :

I don't see this any more in 4.8-0 final.

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers