Alt-backtick regression

Bug #1566878 reported by Barry Warsaw on 2016-04-06
36
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Timo Aaltonen

Bug Description

dist-upgrading to xorg-server (source package) 2:1.18.3-1ubuntu1 (binary packages xserver-common, xserver-xorg-core, xvfb) introduces a regression for Alt-backtick switching between windows of the same application. Before the upgrade, Alt-backtick works by showing you the switcher and letting you cycle between multiple windows of the same application. After the upgrade, Alt-backtick does nothing.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-17.33-generic 4.4.6
Uname: Linux 4.4.0-17-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 361.42 Tue Mar 22 18:10:58 PDT 2016
 GCC version: gcc version 5.3.1 20160405 (Ubuntu 5.3.1-13ubuntu4)
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Apr 6 09:52:54 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.4.0-16-generic, x86_64: installed
 bbswitch, 0.8, 4.4.0-17-generic, x86_64: installed
 nvidia-361, 361.42, 4.4.0-16-generic, x86_64: installed
 nvidia-361, 361.42, 4.4.0-17-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 NVIDIA Corporation GK104 [GeForce GTX 760] [10de:1187] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd GK104 [GeForce GTX 760] [1458:360b]
InstallationDate: Installed on 2016-01-22 (75 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160117)
MachineType: Gigabyte Technology Co., Ltd. Z170X-UD5
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-17-generic root=UUID=d03718f1-9983-4b07-a942-1b42fe8352ec ro
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/24/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F2
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z170X-UD5-CF
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF2:bd07/24/2015:svnGigabyteTechnologyCo.,Ltd.:pnZ170X-UD5:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnZ170X-UD5-CF:rvrx.x:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: Z170X-UD5
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.12.2+16.04.20160331-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.1.2-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.1.2-1ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.6.1-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Wed Apr 6 09:09:25 2016
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.3-1ubuntu1

Barry Warsaw (barry) wrote :
Barry Warsaw (barry) wrote :

I narrowed this down by doing a bisect dist-upgrade with disk snapshots. I.e. take a snapshot, manually upgrade a few packages, reboot, test, rinse, repeat. The only packages left are the three binary packages mentioned in the bug report. With the snapshot before upgrading those packages, Alt-backtick works. I've verified that after upgrading just these three, the regression occurs.

Barry Warsaw (barry) wrote :

I'll note that Alt-TAB still works.

Timo Aaltonen (tjaalton) on 2016-04-06
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → High
status: New → Triaged
Timo Aaltonen (tjaalton) wrote :

hrm, looks like I can reproduce this, which kinda is great

Martin Pitt (pitti) wrote :

Since yesterday's dist-upgrade I'm getting

[ 4305.170] (EE) Error compiling keymap (server-A24141C1DFD907420EB8836C380C7C1C62283A5E)
[ 4305.170] (EE) XKB: Couldn't compile keymap

errors in Xorg.0.log. Also, in qemu guests the keys are now totally garbled, particularly the cursor keys, Home, etc. QEMU itself didn't change in three weeks, and neither did the guest (verified on trusty with evdev on a VT). As that started at exactly the same time, I suppose it's not a coincidence but has the same root cause.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.18.3-1ubuntu2

---------------
xorg-server (2:1.18.3-1ubuntu2) xenial; urgency=medium

  * Disable 190_cache-xkbcomp_output_for_fast_start_up.patch for now,
    compiling the keymap fails in current xenial for some reason.
    (LP: #1566878)

 -- Timo Aaltonen <email address hidden> Thu, 07 Apr 2016 12:10:12 +0300

Changed in xorg-server (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers