Some text (in buttons, dropdown menus) renders incorrectly

Bug #1555960 reported by Furkan on 2016-03-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Upstream bug report here, with the relevant patch for the fix: https://bugs.freedesktop.org/show_bug.cgi?id=94246

After the upgrade to Xorg 1.18, some text (especially in buttons or dropdown menus) appears bold/blurry - see attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xserver-xorg 1:7.7+13ubuntu3
Uname: Linux 4.5.0-040500rc7-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Mar 11 02:10:47 2016
DistUpgraded: 2016-01-04 15:54:21,482 DEBUG enabling apt cron job
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus: virtualbox, 5.0.16, 4.5.0-040500rc7-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Bonaire XTX [Radeon R7 260X/360] [1002:6658] (prog-if 00 [VGA controller])
   Subsystem: VISIONTEK Bonaire XTX [Radeon R7 260X/360] [1545:7260]
InstallationDate: Installed on 2014-06-06 (643 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Gigabyte Technology Co., Ltd. GA-970A-D3
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.5.0-040500rc7-generic root=UUID=d254b01f-2bf2-4b57-acdc-c796786f4c4c ro
SourcePackage: xorg
UpgradeStatus: Upgraded to xenial on 2016-01-04 (66 days ago)
dmi.bios.date: 09/03/2013
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F12
dmi.board.name: GA-970A-D3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF12:bd09/03/2013:svnGigabyteTechnologyCo.,Ltd.:pnGA-970A-D3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-970A-D3:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-970A-D3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.12.2+16.04.20160209-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.1.2-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.1.2-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.18.1-1ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.6.1-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160218-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Fri Mar 11 01:15:58 2016
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:
 evdev: Microsoft Microsoft® 2.4GHz Transceiver v9.0: Unable to open evdev device "/dev/input/event4".
 PreInit returned 2 for "Microsoft Microsoft® 2.4GHz Transceiver v9.0"
 evdev: Microsoft Microsoft® 2.4GHz Transceiver v9.0: Unable to open evdev device "/dev/input/event4".
 PreInit returned 2 for "Microsoft Microsoft® 2.4GHz Transceiver v9.0"
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.18.1-1ubuntu3
xserver.video_driver: radeon

Furkan (falaca) wrote :
Timo Aaltonen (tjaalton) on 2016-03-11
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.18.1-1ubuntu4

---------------
xorg-server (2:1.18.1-1ubuntu4) xenial; urgency=medium

  * glamor: Fix font rendering issue. (LP: #1555960)

 -- Timo Aaltonen <email address hidden> Fri, 11 Mar 2016 09:36:40 +0200

Changed in xorg-server (Ubuntu):
status: New → Fix Released
To post a comment you must log in.