Xorg crashed with SIGABRT in OsAbort() from AbortServer() from FatalError("no screens found") from dix_main()

Bug #1543192 reported by Daniel Holbach on 2016-02-08
This bug affects 78 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)

Bug Description



No idea what happened.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: xserver-xorg-core 2:1.17.3-2ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-2.16-generic 4.4.0
Uname: Linux 4.4.0-2-generic x86_64

ApportVersion: 2.19.4-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
Date: Mon Feb 8 17:07:23 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
ExecutablePath: /usr/lib/xorg/Xorg
ExtraDebuggingInterest: Yes
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo 2nd Generation Core Processor Family Integrated Graphics Controller [17aa:21da]
InstallationDate: Installed on 2015-04-30 (283 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
MachineType: LENOVO 429149G
ProcCmdline: /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-2-generic root=UUID=457973fc-512e-4b6a-b65b-85f15fa85b7b ro console=tty1 console=ttyS0 panic=-1
Signal: 6
SourcePackage: xorg-server
 OsAbort ()
 ?? ()
 FatalError ()
 ?? ()
 __libc_start_main (main=0x557f8180ff00, argc=11, argv=0x7fffc9e34fd8, init=<optimised out>, fini=<optimised out>, rtld_fini=<optimised out>, stack_end=0x7fffc9e34fc8) at libc-start.c:289
SystemImageInfo: Error: command ['system-image-cli', '-i'] failed with exit code 2:
Title: Xorg crashed with SIGABRT in OsAbort()
UpgradeStatus: No upgrade log present (probably fresh install)

dmi.bios.date: 05/18/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET46WW (1.16 )
dmi.board.asset.tag: Not Available
dmi.board.name: 429149G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET46WW(1.16):bd05/18/2011:svnLENOVO:pn429149G:pvrThinkPadX220:rvnLENOVO:rn429149G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 429149G
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.66-2
version.libgl1-mesa-dri: libgl1-mesa-dri 11.1.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.1.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.17.3-2ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.6.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160127-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1
xserver.bootTime: Mon Feb 8 17:08:14 2016
xserver.configfile: default
xserver.errors: systemd-logind: failed to get session: PID 9847 does not belong to any known session
xserver.logfile: /var/log/Xorg.0.log
 product id 728
 vendor LGD
xserver.version: 2:1.17.3-2ubuntu2

Daniel Holbach (dholbach) wrote :

 OsAbort ()
 AbortServer ()
 FatalError ()
 dix_main ()
 __libc_start_main (main=0x557f8180ff00 <main>, argc=11, argv=0x7fffc9e34fd8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc9e34fc8) at libc-start.c:289

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

Still an issue when trying to log into the unity8 desktop session.

information type: Private → Public
jerrylamos (jerrylamos) wrote :

Just got the bug 2016-3-29 fresh install today from xenial-desktop-amd64.iso
DISTRIB_DESCRIPTION="Ubuntu Xenial Xerus (development branch)"
Linux Lenovo2 4.4.0-16-generic #32-Ubuntu SMP Thu Mar 24 22:38:01 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
model name : Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
model name : Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

tags: added: bugpattern-needed
tags: added: yakkety
miked (miked11) wrote :

miked@free-yak:~$ lsb_release -rd
Description: Ubuntu Yakkety Yak (development branch)
Release: 16.10

miked@free-yak:~$ apt-cache policy xserver-xorg-core
  Installed: 2:1.18.4-1ubuntu6
  Candidate: 2:1.18.4-1ubuntu6
  Version table:
 *** 2:1.18.4-1ubuntu6 500
        500 http://archive.ubuntu.com/ubuntu yakkety/main amd64 Packages
        100 /var/lib/dpkg/status

tags: added: zesty
Charles Lee (charles-lee) wrote :

Crash occurred while running benchmark inside Dirt Rally (xubuntu 17.04 Beta 1).

Description: Ubuntu Zesty Zapus (development branch)
Release: 17.04

  Installed: 2:1.18.4-1ubuntu9
  Candidate: 2:1.18.4-1ubuntu9
  Version table:
 *** 2:1.18.4-1ubuntu9 500
        500 http://nz.archive.ubuntu.com/ubuntu zesty/main amd64 Packages
        100 /var/lib/dpkg/status

fcole90 (fcole90) wrote :

It happens to me every time I unlock my session

summary: - Xorg crashed with SIGABRT in OsAbort()
+ Xorg crashed with SIGABRT in OsAbort() ["no screens found"]
description: updated
Changed in xorg-server (Ubuntu):
importance: Medium → High
tags: added: artful

I am having the same problem in my new Dell XPS 15, every time I boot up (16.04). Is there any one who might have some advice on how we can fix this?

Any help would be greatly appreciated.

kerryland (p-kerry) wrote :

Happened to me in 17.10. Like @fcole90 seemed to happen after unlocking my session after unsuspending my machine in the morning. The unlocking itself seemed to be stuck displaying some message about letting me continue in a few moments, but it never did. I used ctrl-alt-f6 then crtl-alt-f7 to 'wake it up', and that causes an unlock dialog to finally appear.

Apologies for the vagueness of this!

Robert Baumgartner (rwb) wrote :

I'm getting this in 16.04 very frequently as well. If you want my system info as well, or if I can help debug in some other way let me know and I will be happy to help get this fixed.

tags: added: bionic
Vinchenzo (mdmwm) wrote :

Hardware: NVidia GeForce GTX 850M/PCIe/SSE2
          Intel® Core™ i7-5500U CPU @ 2.40GHz × 4

Steps to reproduce on Bionic (18.04 dev)

1. Install normal (Gnome desktop on wayland)
2. Install xubuntu-desktop
3. At some point the installation will ask for changing display manager to lightdm. Agree.
4. Logout from Xfce and change session back to Gnome
   - At this point, note that it will still start up via lightdm
5. Error observed when logging in to Gnome

It happens to me to. Usually, when I click (with mouse) at some panel element (calendar, configuration icon etc.).

I've a Dell Notebook with NVidia on it.

M Grmn (mgrmn) wrote :

Might not be helpful. I edited my radeon.conf (which had "Detail") so I removed that.
Plus I had to chown {user}:{user} .Xauthority to be able to login (otherwise it would just kick me back to login screen) It helpt me logging in, but ofcourse not as it should.

summary: - Xorg crashed with SIGABRT in OsAbort() ["no screens found"]
+ Xorg crashed with SIGABRT in OsAbort() from AbortServer() from
+ FatalError() from dix_main() ["no screens found"]


I ran into the no screens bug. Logging in resulted in a black screen for many minutes after which the login screen reappeared and I am able to login fine. A systemd watchdog kicks in during the many minutes to restart systemd-logind. I don't know why the 2nd login attempt works when the first failed. I can restart systemd-logind after the first login but before the watchdog to speed up the process but if I restart systemd-logind before the first login it doesn't help...

May 9 11:04:06 jcormier-MS-7A93 /usr/lib/gdm3/gdm-x-session[2581]: (EE) Screen(s) found, but none have a usable configuration.
May 9 11:04:06 jcormier-MS-7A93 /usr/lib/gdm3/gdm-x-session[2581]: (EE)
May 9 11:04:06 jcormier-MS-7A93 /usr/lib/gdm3/gdm-x-session[2581]: Fatal server error:
May 9 11:04:06 jcormier-MS-7A93 /usr/lib/gdm3/gdm-x-session[2581]: (EE) no screens found(EE)

I had caused this by disabling wayland in /etc/gdm3/custom.conf. Re-enabling wayland removed this problem but I am still seeing various other X related issues which cause gnome to kick me back to login screen or reset the computer. :(

Shawn (shawn.waldon) wrote :

I just updated to Xubuntu 18.04 (from 17.10) and I have started getting this when I log in.

Jonathan (jjcf89) wrote :

Shawn can you check /etc/gdm3/custom.conf and make sure wayland isn't disabled?

Shawn (shawn.waldon) wrote :

That file (/etc/gdm3/custom.conf) doesn't exist on my system. I haven't been getting the popup for an error occurring today though. (The details in that dialog said it was a duplicate of this issue, which is how I found this)

I still have an issue where if I lock the screen it goes black with a blinking _ in the upper left. I can ssh in and reboot, but the UI is unresponsive no matter how long I wait (even Ctrl+Shift+F1-6 key combos do nothing). I'm not sure that is related, but the 'system error has occurred' dialog with this crash only happened after I did a reboot to get out of this. I'm going to do more debugging on this later this afternoon.

Shawn (shawn.waldon) wrote :

Just to close the loop on this, it seems that my problem was a corrupted dist-upgrade and reinstalling a fresh Xubuntu 18.04 fixed it.

Jonathan (jjcf89) wrote :

At least some of my issue was triggered by a yet unfixed NIS/systemd bug. systemd-logind would hang (and watchdog kicks in) if it tried to contact the NIS service because of a new IP firewall they implemented. I don't think this was entirely all of my problems but it certainly confused the issue.

See https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1745664

Bronek Kozicki (bronek0) wrote :

Apparently, I am able to reproduce this quite easily with Xubuntu 18.04 as seen in bug #1815429 . The workaround which works for me is to add the ppa:xubuntu-dev/experimental and upgrade xfwm4 to version 4.13

summary: Xorg crashed with SIGABRT in OsAbort() from AbortServer() from
- FatalError() from dix_main() ["no screens found"]
+ FatalError("no screens found") from dix_main()
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers