Session crashes when second monitor is connected

Bug #1542629 reported by Marlin Cremers
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

The Unity session crashes when I connect a second monitor. It happens when I connect a second monitor to my working session but it also crashes when I login while my second monitor is connected already. It appears to crash the same way.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: nvidia-352 352.63-0ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-2.16-generic 4.4.0
Uname: Linux 4.4.0-2-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
.tmp.unity.support.test.0:

ApportVersion: 2.19.4-0ubuntu2
Architecture: amd64
BootLog:

CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sat Feb 6 13:19:22 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.4.0-2-generic, x86_64: installed
 nvidia-352, 352.63, 4.4.0-2-generic, x86_64: installed
 virtualbox, 5.0.14, 4.4.0-2-generic, x86_64: installed
GraphicsCard:
 Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: CLEVO/KAPOK Computer 4th Gen Core Processor Integrated Graphics Controller [1558:6502]
MachineType: Notebook W65_67SF
ProcKernelCmdLine: BOOT_IMAGE=/root/ubuntu-16.04@/boot/vmlinuz-4.4.0-2-generic.efi.signed root=ZFS=ssd-boot/root/ubuntu-16.04 ro boot=zfs rpool=ssd-boot bootfs=ssd-boot/root/ubuntu-16.04 quiet splash vt.handoff=7
SourcePackage: nvidia-graphics-drivers-352
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/24/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.05.01
dmi.board.asset.tag: Tag 12345
dmi.board.name: W65_67SF
dmi.board.vendor: Notebook
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: Notebook
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.05.01:bd07/24/2015:svnNotebook:pnW65_67SF:pvrNotApplicable:rvnNotebook:rnW65_67SF:rvrNotApplicable:cvnNotebook:ct9:cvrN/A:
dmi.product.name: W65_67SF
dmi.product.version: Not Applicable
dmi.sys.vendor: Notebook
version.compiz: compiz 1:0.9.12.2+16.04.20151211-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.66-2
version.libgl1-mesa-dri: libgl1-mesa-dri 11.1.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.1.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.17.3-2ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.6.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160127-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1
xserver.bootTime: Sat Feb 6 13:18:27 2016
xserver.configfile: default
xserver.errors: systemd-logind: failed to get session: PID 24257 does not belong to any known session
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 4845
 vendor AUO
xserver.version: 2:1.17.3-2ubuntu2

Revision history for this message
Marlin Cremers (marlinc) wrote :
Timo Aaltonen (tjaalton)
no longer affects: xorg (Ubuntu)
Revision history for this message
Marlin Cremers (marlinc) wrote :

I've attached a log of X crashing

Revision history for this message
Marlin Cremers (marlinc) wrote :
Revision history for this message
Marlin Cremers (marlinc) wrote :

I've attached a log of me starting a completely clean environment (removed dconf config directory and monitors.xml) with the second monitor unplugged. Then attaching the monitor (which worked fine). Then I tried to move the second monitor to the left of my laptop screen and got two errors which I'll attach below. Applying the config appeared to work just fine. Then I unplugged the second monitor which worked fine as well. When I then reattached the second monitor the X server segfaulted as can be seen in the log.

Revision history for this message
Marlin Cremers (marlinc) wrote :
Revision history for this message
Marlin Cremers (marlinc) wrote :
Timo Aaltonen (tjaalton)
affects: nvidia-graphics-drivers-352 (Ubuntu) → xorg-server (Ubuntu)
Revision history for this message
Marlin Cremers (marlinc) wrote :

I'm no longer having this specific issue so I guess an update has been released that fixed the issue.

Changed in xorg-server (Ubuntu):
status: New → Fix Released
Revision history for this message
Ian Caunce (iancaunce123) wrote :

I am also suffering from this issue. It occurs with and without nvidia-361 drivers installed. Loading ubuntu causes the computer to freeze. When I use my second window manager, awesome wm, the second monitor isnt detected but the system does not crash. It seems I am only affected by the issue with HDMI. Using DSUB causes no issue.

Revision history for this message
Daniel Podlejski (underley) wrote :

Same issue on Toshiba Z30 after update to 16.04.
When laptop is booted from old kernel (4.2 from Ubuntu14.10) everything is fine.

To post a comment you must log in.