Ubuntu GNOME 16.04 daily wont boot in virtualbox

Bug #1525451 reported by Tim Lunn on 2015-12-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
X.Org X server
Fix Released
Unknown
xorg-server (Ubuntu)
High
Unassigned

Bug Description

Current images don't boot using virtualbox 5.

[ 25.023] (WW) xf86OpenConsole: VT_ACTIVATE failed: Input/output error
[ 25.030] (EE)
Fatal server error:
[ 25.030] (EE) xf86OpenConsole: Switching VT failed
[ 25.030] (EE)
[ 25.031] (EE)
Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
[ 25.032] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 25.032] (EE)
[ 25.034] (WW) xf86CloseConsole: KDSETMODE failed: Input/output error
[ 25.034] (WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
[ 25.034] (WW) xf86CloseConsole: VT_ACTIVATE failed: Input/output error
[ 25.034] (EE) Server terminated with error (1). Closing log file.

ProblemType: BugDistroRelease: Ubuntu 16.04
Package: xserver-xorg 1:7.7+12ubuntu1
ProcVersionSignature: Ubuntu 4.3.0-2.11-generic 4.3.0
Uname: Linux 4.3.0-2-generic x86_64
ApportVersion: 2.19.3-0ubuntu2
Architecture: amd64
CasperVersion: 1.366
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Sat Dec 12 00:58:31 2015
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
LiveMediaBuild: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151211)
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash --- maybe-ubiquity
Renderer: SoftwareSourcePackage: xorg
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.65-3
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.7-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.7-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.17.3-2ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.6.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20151019-1~exp1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Sat Dec 12 00:54:53 2015
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.17.3-2ubuntu2

Tim Lunn (darkxst) wrote :
description: updated
Tim Lunn (darkxst) on 2015-12-12
description: updated
Changed in ubuntu-gnome:
milestone: none → xenial
Tim Lunn (darkxst) on 2015-12-12
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server:
status: Unknown → New
Timo Aaltonen (tjaalton) wrote :

if it's a vbox bug why is this (and 1525735) filed against the xserver?

Tim Lunn (darkxst) wrote :

It is not specifically a vbox bug, it appears it would affect any system that uses a UMS kernel driver and VESA. In that case you need xserver-xorg-legacy, but if you put that on the images, you turn off rootless Xorg for everyone.

Tim Lunn (darkxst) wrote :

Admittedly though there probably are not many other UMS drivers around these days apart from vbox.

Malena Vasquez (malevasquez) wrote :

Found this bug in today's image of GNOME when running it in Vbox. Seems that the issue is still around...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1525451

tags: added: iso-testing
Changed in ubuntu-gnome:
status: New → Confirmed
Changed in xorg-server (Ubuntu):
importance: Undecided → High
Tim Lunn (darkxst) on 2016-03-21
Changed in ubuntu-gnome:
milestone: xenial → yy
Changed in xorg-server:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.