Unable to set 1920x1080 resolution in Ubuntu 16.04 as a VMWare Fusion guest

Bug #1517046 reported by Luca Ciavatta on 2015-11-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

I'm testing Ubuntu 16.04 as a guest of a VMWare Fusion guest under Mac OS X 10.11.1.
All works fine, but I'm unable to set 1920x1080 resolution (monitor native) on external display. I can do 1920x1600 or more, but not 1920x1080. I have tried open-vm-tools and vmware-tools, but problem persists. On display-setting, the monitor is marked as unknown display.

1) Ubuntu Xenial Xerus (development branch) - release 16.04
2) xorg 1:7.7+12ubuntu1
3) Looking to change external display resolution as 1920x1080
4) I have not found the 1920x1080 setting

Luca Ciavatta (cialu) wrote :

I found a workaround.
In a terminal:
xrandr --newmode "1920x1080" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
xrandr --addmode Virtual1 1920x1080
xrandr --output Virtual1 --mode 1920x1080

And the display is set to the correct resolution and all works fine.
The problem is when I restart the system, I have an error window with:

Could not apply the stored configuration for monitors
none of the selected modes were compatible with the possible modes:
CRTC 63: Trying modes for ......... with output at 1920x1080@60hz (pass 0)
....
CRTC 63: Trying modes for 800x600@60hz with output at 1920x1080@60hz (pass 1)
....
and the monitor starts with 800x600 resolution.

So, I did again the commands of above and the resolution go fine to 1920x1080.

yuval (yuvharpaz) wrote :

I have a similar issue with built in screen in a laptop, it has smaller than usual pixels so the default resolution 3840x2160 (15.6", Dell Precision M3800 PM-RD33-928) gives tiny icons and buttons and text. I tried to change to 2048x1152 by fiddling with xrandr and by changing text files I don't remember where, but on restart it reverted to 3840x2160.

Allan Bogh (ajbogh) wrote :

@yuval can fix the issue by creating a ~/.xprofile file with the xrandr lines (change the lines to match your configuration):

xrandr --newmode "1920x1080" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
xrandr --addmode eDP-1 1920x1080

use "cvt 1920 1080 60" to get the --newmode line

I am getting similar results as OP with an HP 2711x using Ubuntu 17.04 beta. The monitor is detected but it doesn't list the native 1920 x 1080 @ 60Hz resolution. Adding the resolution with xrandr makes the external monitor go black, but the displays application still shows it on and connected.

Two other new Dell monitors won't detect at all, however one is using USB-C->HDMI to HDMI->DP adapters which I think is causing issues. The other is using Thinkpad's DisplayLink with the latest drivers.

Allan Bogh (ajbogh) wrote :

I'm sorry, I made a mistake and said it doesn't list the native resolution. This was wrong. The displays application lists the native 1920x1080 but the display goes blank when this is selected. Using a lower setting (1280x720) works. Adding a higher setting (2048x1152) fails for obvious reasons.

Allan Bogh (ajbogh) wrote :

I've changed my HDMI cable and discovered that part of the problem or the problem as a whole is due to the HDMI cable that I was using. The monitor stated that the frequency was out of range when I used a DVI adapter so I tried playing around with various frequencies to no avail. Finally I switched to a sturdier HDMI cable, with the DVI adapter as well, and the picture shows up at 1920x1080@60hz again.

It's very frustrating to find out that a poorly manufactured HDMI cable can work in some computers and monitors but not others. It would be nice if Ubuntu were a little more forgiving, but I'm glad to have found a solution.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers