please merge xorg-server from debian

Bug #1511649 reported by Gianfranco Costamagna on 2015-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Wishlist
Unassigned

Bug Description

I would like to have the new xorg-legacy package to fix the virtualbox installation.

NOTE: I'm not asking for a sponsor, I'm providing a debdiff just for your best convenience.

This merge will introduce the new rootless X mode, but AFAICS systemd-logind is already in place here.

builds ongoing on
https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/locutusofborg-ppa/+build/8220795

The attachment "debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Timo Aaltonen (tjaalton) wrote :

it's merged in git

Changed in xorg-server (Ubuntu):
status: New → In Progress
Mathew Hodson (mhodson) on 2015-11-09
Changed in xorg-server (Ubuntu):
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

unsubscribing sponsors, it has been handled and is up to the xorg team to do their next upload

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.17.3-2ubuntu1

---------------
xorg-server (2:1.17.3-2ubuntu1) xenial; urgency=medium

  [ Robert Ancell ]
  * debian/patches/xmir.patch:
    - Update to latest version
  * debian/patches/xmir-rootless.patch:
    - Merged into xmir.patch

  [ Timo Aaltonen ]
  * Merge from Debian. (LP: #1511649)
  * glamor-make-current-in-prepare-paths.diff,
    linux-Do-not-call-FatalError-from-xf86CloseConsole.patch:
    Dropped, upstream.

xorg-server (2:1.17.3-2) unstable; urgency=medium

  * Finalize xserver-xorg-core.NEWS. Thanks, Michael Biebl!

xorg-server (2:1.17.3-1) unstable; urgency=medium

  [ Julien Cristau ]
  * New upstream release
    - mi: fix typo in warning about overflowing queue (closes: #726041)
  * Refresh 02_kbsd-input-devd.diff and 03_static-nettle.diff.
  * Replace xorg-wrapper-envp.diff with a cherry-pick from master.
  * New patch xext-fix-udeb-build.diff to fix build regression in 1.17.3.
  * Add NEWS file for xserver-xorg-core with info about the -legacy split
    (closes: #801487).
  * Recommend libpam-systemd (closes: #802544, #802618, #802327, #802566,
    probably others)

  [ Andreas Boll ]
  * Use the correct repository for the Vcs-Git field (Closes: #801340).
    Thanks, Vagrant Cascadian.
  * Document new location for non-root Xorg log in the NEWS file.

  [ Samuel Thibault ]
  * Fix xorg-wrapper on hurd (cherry-picked from master).

xorg-server (2:1.17.2-3) unstable; urgency=medium

  * Team upload.
  [ Laurent Bigonville ]
  * Move Xorg.wrap.1 man page from the xserver-xorg-core to
    xserver-xorg-legacy package (Closes: #797661)
  * Add a Breaks against systemd (<< 226-4~), before that version logind was
    restarted on upgrade which makes the X server crash (See #798097)
  * Bump Standards-Version to 3.9.6 (no further changes)

  [ Andreas Boll ]
  * Update Vcs-* fields.
  * Add upstream url.

  [ Julien Cristau ]
  * Only reset environment in the Xorg wrapper if we didn't drop privileges.

xorg-server (2:1.17.2-2) experimental; urgency=medium

  [ Laurent Bigonville ]
  * Enable logind support for the main build on Linux.
  * Build and ship the setuid root wrapper from upstream, replacing
    xserver-xorg's.

  [ Julien Cristau ]
  * Take over x11-common's handling of the X wrapper; ship the wrapper in a
    new xserver-xorg-legacy package.
  * Patch the wrapper to reset Xorg's environment. I don't believe it needs
    any variable there, and if that turns out to be wrong we can add a
    whitelist or hardcode some values.

xorg-server (2:1.17.2-1.1) unstable; urgency=medium

  * Non-Maintainer Upload.

  [ Sven Joachim ]
  * Install the whole usr/share/man/man4 directory into xserver-xorg-core,
    fixes FTBFS on hurd where modesetting.4 does not exist (Closes: #794644).

 -- Timo Aaltonen <email address hidden> Tue, 10 Nov 2015 18:20:55 +0200

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches