Xorg crashed with SIGABRT in OsAbort()

Bug #1505904 reported by C Schilder on 2015-10-14
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Just started my Gnome Ubuntu box. After logging in, this error surfaced.
In the 'report a problem' interface, it showed me the Xorg error.
However I think this might has to do with Compiz. I noticed the following message in the error summary display:
No value set for `/apps/compiz-1/general/screen0/options/active_plugins'.
Then I searched the problem on the internet. Found a post which I thought was a good starting point for the investigation:
http://askubuntu.com/questions/74313/list-and-enable-disable-compiz-plugins-on-command-line
Turns out compiz is not even installed, i checked this with aptitude.

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: xserver-xorg-core 2:1.17.2-1ubuntu9
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.1-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CrashCounter: 1
CurrentDesktop: GNOME
Date: Tue Oct 13 17:13:16 2015
DistUpgraded: Fresh install
DistroCodename: wily
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0152] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:2ade]
InstallationDate: Installed on 2015-09-18 (25 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150915)
Lsusb:
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Hewlett-Packard HP Compaq Pro 4300 SFF PC
ProcCmdline: /usr/bin/X vt7 -displayfd 3 -auth /run/user/120/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-16-generic root=UUID=018176c1-88ee-46b1-be76-dfc1466d72c4 ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 OsAbort ()
 FatalError ()
 ?? ()
 xf86CloseConsole ()
 ddxGiveUp ()
Title: Xorg crashed with SIGABRT in OsAbort()
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 01/23/2013
dmi.bios.vendor: AMI
dmi.bios.version: 8.10
dmi.board.asset.tag: CZC3211FPH
dmi.board.name: 2ADE
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 1.0
dmi.chassis.asset.tag: CZC3211FPH
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnAMI:bvr8.10:bd01/23/2013:svnHewlett-Packard:pnHPCompaqPro4300SFFPC:pvr:rvnHewlett-Packard:rn2ADE:rvr1.0:cvnHewlett-Packard:ct3:cvr:
dmi.product.name: HP Compaq Pro 4300 SFF PC
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.2-1ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.2-1ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Wed Oct 14 06:50:54 2015
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Video Bus KEYBOARD, id 7
 input Power Button KEYBOARD, id 8
 input Microsoft Microsoft 3-Button Mouse with IntelliEye(TM) MOUSE, id 9
 input AT Translated Set 2 keyboard KEYBOARD, id 10
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.17.2-1ubuntu9

C Schilder (cschilder) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1237904, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Andrey Pozdnyakov (andreypz) wrote :

Hmm,
Why is this a duplicate of #1237904. The #1237904 seems to be fixed, but I'm getting this compiz error, just as reported here.
I'm on Xubuntu 18.04.

Andrey Pozdnyakov (andreypz) wrote :

Side note:
"Add attachment" functionality s broken.
Firefox 63.0 on Xubuntu 18.08

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers