Xorg crashed with SIGABRT in OsAbort()

Bug #1503934 reported by Ashley Robjohns on 2015-10-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Running incomplete Ubuntu Gnome 15.10 Beta, error after logon.

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: xserver-xorg-core 2:1.17.2-1ubuntu9
ProcVersionSignature: Ubuntu 4.2.0-14.16-generic 4.2.2
Uname: Linux 4.2.0-14-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 355.11 Wed Aug 26 16:35:41 PDT 2015
 GCC version: gcc version 5.2.1 20151003 (Ubuntu 5.2.1-21ubuntu2)
ApportVersion: 2.19-0ubuntu1
Architecture: amd64
BootLog:
 fsck from util-linux 2.26.2
 /dev/sda3: clean, 426150/30449664 files, 5311436/121773056 blocks
CrashCounter: 1
CurrentDesktop: GNOME
Date: Wed Oct 7 22:38:41 2015
DistUpgraded: Fresh install
DistroCodename: wily
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 NVIDIA Corporation GK104 [GeForce GTX 680] [10de:1180] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation Device [10de:0969]
 NVIDIA Corporation GK104 [GeForce GTX 680] [10de:1180] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation Device [10de:0969]
InstallationDate: Installed on 2015-08-24 (44 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Release amd64 (20150422)
MachineType: Alienware Aurora-R4
ProcCmdline: /usr/bin/X vt7 -displayfd 3 -auth /run/user/121/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
ProcEnviron:
 SHELL=/bin/false
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_AU.UTF-8
 LANGUAGE=en_AU:en
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.2.0-14-generic.efi.signed root=UUID=b3240048-dc06-4ef7-9b79-155902590916 ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 OsAbort ()
 FatalError ()
 ?? ()
 xf86CloseConsole ()
 ddxGiveUp ()
Title: Xorg crashed with SIGABRT in OsAbort()
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 11/26/2013
dmi.bios.vendor: Alienware
dmi.bios.version: A11
dmi.board.name: 07JNH0
dmi.board.vendor: Alienware
dmi.board.version: A02
dmi.chassis.type: 3
dmi.chassis.vendor: Alienware
dmi.chassis.version: 00
dmi.modalias: dmi:bvnAlienware:bvrA11:bd11/26/2013:svnAlienware:pnAurora-R4:pvr00:rvnAlienware:rn07JNH0:rvrA02:cvnAlienware:ct3:cvr00:
dmi.product.name: Aurora-R4
dmi.product.version: 00
dmi.sys.vendor: Alienware
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64+git20150818.ab2fadab-0ubuntu0sarvatt~vivid
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.0-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.0-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.99+git20150521.d64a13eb-0ubuntu0ricotz~vivid
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150826.300319e2-0ubuntu0sarvatt~vivid
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11+git20150804.62961456-0ubuntu0sarvatt~vivid
xserver.bootTime: Thu Oct 8 11:29:02 2015
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.17.2-1ubuntu9

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1237904, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers