Xorg crashed with SIGABRT in OsAbort()

Bug #1503728 reported by Jonathan Moerman on 2015-10-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

A window telling me that Xorg has crashed tends to show up some time after booting.
This crash does not occur while logged in and I do not know when it happens exactly (it does not help that the last message came 20 minutes after the event), it happens either when booting or when shutting down, probably the latter.

I am running Ubuntu Gnome 15.10 (fresh install, updated), with Xorg 1:7.7+7ubuntu4 and Linux 4.2.0-14-generic x84_64, nvidia proprietary driver version 352.41.

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: xserver-xorg-core 2:1.17.2-1ubuntu9
ProcVersionSignature: Ubuntu 4.2.0-14.16-generic 4.2.2
Uname: Linux 4.2.0-14-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 352.41 Fri Aug 21 23:09:52 PDT 2015
 GCC version: gcc version 5.2.1 20151003 (Ubuntu 5.2.1-21ubuntu2)
ApportVersion: 2.19-0ubuntu1
Architecture: amd64
BootLog:

CrashCounter: 1
CurrentDesktop: GNOME
Date: Wed Oct 7 16:12:50 2015
DistUpgraded: Fresh install
DistroCodename: wily
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.7, 4.1.0-3-generic, x86_64: installed
 bbswitch, 0.7, 4.2.0-14-generic, x86_64: installed
 nvidia-352, 352.41, 4.1.0-3-generic, x86_64: installed
 nvidia-352, 352.41, 4.2.0-14-generic, x86_64: installed
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 NVIDIA Corporation GF108 [GeForce GT 440] [10de:0de0] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation Device [10de:0828]
InstallationDate: Installed on 2015-10-05 (2 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150826.1)
MachineType: MSI MS-7623
ProcCmdline: /usr/bin/X vt7 -displayfd 3 -auth /run/user/120/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
ProcEnviron:
 SHELL=/bin/false
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=nl_NL.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-14-generic root=UUID=019d27d6-f3bb-4e1c-b31f-90e0b1b257ad ro quiet splash
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 OsAbort ()
 FatalError ()
 ?? ()
 xf86CloseConsole ()
 ddxGiveUp ()
Title: Xorg crashed with SIGABRT in OsAbort()
UdevLog: Error: [Errno 2] Bestand of map bestaat niet: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 04/27/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V11.11
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 880GM-E41 (MS-7623)
dmi.board.vendor: MSI
dmi.board.version: 2.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 2.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV11.11:bd04/27/2011:svnMSI:pnMS-7623:pvr2.0:rvnMSI:rn880GM-E41(MS-7623):rvr2.0:cvnMSI:ct3:cvr2.0:
dmi.product.name: MS-7623
dmi.product.version: 2.0
dmi.sys.vendor: MSI
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.0-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.0-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Wed Oct 7 16:14:39 2015
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.17.2-1ubuntu9

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1237904, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers