Xorg crashed with SIGABRT in OsAbort()

Bug #1503388 reported by Daniel Neilson on 2015-10-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

This appears to happen after the first login after booting.

I am running kernel 4.3 RC4, but this occurred while running 4.2, 4.3 RC2, and RC3 as well. Doesn't appear to matter whether an application is launched immediately after logging in or not. So this does not take user interaction other than logging in to trigger.

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: xserver-xorg-core 2:1.17.2-1ubuntu9
Uname: Linux 4.3.0-040300rc3-generic x86_64
ApportVersion: 2.19-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CrashCounter: 1
CurrentDesktop: GNOME
Date: Fri Oct 2 16:18:28 2015
DistUpgraded: Fresh install
DistroCodename: wily
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Microsoft Corporation Device [1414:0166]
InstallationDate: Installed on 2015-09-30 (6 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150924)
MachineType: Microsoft Corporation Surface with Windows 8 Pro
ProcCmdline: /usr/bin/X vt7 -displayfd 3 -auth /run/user/120/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
ProcEnviron:
 SHELL=/bin/false
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.UTF-8
 LANGUAGE=en_CA:en
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.3.0-040300rc4-generic root=UUID=11a9e99a-5a5c-4265-8a8d-22c35a9de106 ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 OsAbort ()
 FatalError ()
 ?? ()
 xf86CloseConsole ()
 ddxGiveUp ()
Title: Xorg crashed with SIGABRT in OsAbort()
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 11/28/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.07.0050
dmi.board.asset.tag: 0
dmi.board.name: Surface with Windows 8 Pro
dmi.board.vendor: Microsoft Corporation
dmi.board.version: 1
dmi.chassis.asset.tag: 0
dmi.chassis.type: 17
dmi.chassis.vendor: Microsoft Corporation
dmi.chassis.version: 1
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.07.0050:bd11/28/2014:svnMicrosoftCorporation:pnSurfacewithWindows8Pro:pvr1:rvnMicrosoftCorporation:rnSurfacewithWindows8Pro:rvr1:cvnMicrosoftCorporation:ct17:cvr1:
dmi.product.name: Surface with Windows 8 Pro
dmi.product.version: 1
dmi.sys.vendor: Microsoft Corporation
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.0-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.0-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Tue Oct 6 12:03:29 2015
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 12866
 vendor SEC
xserver.version: 2:1.17.2-1ubuntu9

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1237904, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers