Xorg crashed with SIGABRT in RRTellChanged()

Bug #1495796 reported by Walter Garcia-Fontes on 2015-09-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

I got updates this morning and lightdm would not restart. Changing to the nouveau driver solved the problem, but it seems that the 352 version of the nvidia propietary drivers don't work of this stage of wily.

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: xserver-xorg-core 2:1.17.2-1ubuntu6
ProcVersionSignature: Ubuntu 4.2.0-7.7-generic 4.2.0
Uname: Linux 4.1.0-3-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 352.30 Tue Jul 21 18:53:45 PDT 2015
 GCC version: gcc version 5.2.1 20150911 (Ubuntu 5.2.1-17ubuntu1)
ApportVersion: 2.18.1-0ubuntu1
Architecture: amd64
Date: Tue Sep 15 07:21:59 2015
DistUpgraded: 2015-09-01 10:11:16,778 DEBUG running apport_crash()
DistroCodename: wily
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.7, 3.19.0-26-generic, x86_64: installed
 bbswitch, 0.7, 4.1.0-3-generic, x86_64: installed
 bbswitch, 0.7, 4.2.0-7-generic, x86_64: installed
 virtualbox, 5.0.4, 4.1.0-3-generic, x86_64: installed
 virtualbox, 5.0.4, 4.2.0-7-generic, x86_64: installed
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0535]
 NVIDIA Corporation GF108GLM [NVS 5200M] [10de:0dfc] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:1535]
InstallationDate: Installed on 2013-11-28 (655 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MachineType: Dell Inc. Latitude E6530
ProcCmdline: /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-7-generic root=UUID=409b2104-0062-403c-8b6b-f07948051f69 ro quiet splash
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 RRTellChanged ()
 ?? () from /usr/lib/xorg/modules/drivers/intel_drv.so
 ?? () from /usr/lib/xorg/modules/drivers/intel_drv.so
 ?? () from /usr/lib/xorg/modules/drivers/intel_drv.so
 ?? () from /usr/lib/xorg/modules/drivers/intel_drv.so
Title: Xorg crashed with SIGABRT in RRTellChanged()
UpgradeStatus: Upgraded to wily on 2015-09-01 (13 days ago)
UserGroups:

dmi.bios.date: 08/27/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A13
dmi.board.name: 07Y85M
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA13:bd08/27/2013:svnDellInc.:pnLatitudeE6530:pvr01:rvnDellInc.:rn07Y85M:rvrA01:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6530
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.12.2+15.10.20150908-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.6.3-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.6.3-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Tue Sep 15 07:35:14 2015
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 [drm] KMS not enabled
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 8685
 vendor AUO
xserver.version: 2:1.17.2-1ubuntu6

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1494488, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
To post a comment you must log in.