black screen when enabling rotation on a gpu screen

Bug #1489696 reported by Shih-Yuan Lee on 2015-08-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
Medium
Timo Aaltonen
xorg-server (Ubuntu)
Medium
Timo Aaltonen
Trusty
Undecided
Unassigned
Vivid
Medium
Unassigned
xorg-server-lts-vivid (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned
Vivid
Medium
Unassigned

Bug Description

Running with the proprietary nvidia drivers in an optimus config works, but enabling reflection or rotation on the intel screen causes a black screen to appear.

[Impact]
 * Causes a black screen if rotation or reflection is enabled.

[Test Case]
 * Run xrandr --output SOMEOUTPUT --rotation left
    - Expected: Screen should rotate, or the call should fail.
    - Bad behavior: Succeeds, but causes a black screen.

[Regression Potential]
 * The affected codepaths have reflection and rotation disabled for gpu screens. Another fix could be fixing reflection/rotation, but that will be more involved and likely require driver fixes.

[Other Info]
 * This issue is copied from https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1308515 for vivid and wily.

tags: added: vivid wily
Timo Aaltonen (tjaalton) on 2015-08-28
Changed in xorg-server-lts-vivid (Ubuntu):
status: New → Invalid
Changed in xorg-server (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → In Progress
Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
Changed in xorg-server (Ubuntu Vivid):
importance: Undecided → Medium
Changed in xorg-server-lts-vivid (Ubuntu):
importance: Undecided → Medium
Changed in xorg-server-lts-vivid (Ubuntu Vivid):
importance: Undecided → Medium
Keng-Yu Lin (lexical) on 2015-09-01
Changed in hwe-next:
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.17.2-1ubuntu5

---------------
xorg-server (2:1.17.2-1ubuntu5) wily; urgency=medium

  * disable-rotation-transform-gpuscreens.patch: Revert back to disabling
    rotations on GPU screens. It won't work before 1.18. (LP: #1489696)

 -- Timo Aaltonen <email address hidden> Wed, 02 Sep 2015 15:56:03 +0300

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu Vivid):
status: New → Confirmed
Changed in xorg-server-lts-vivid (Ubuntu Vivid):
status: New → Confirmed

Hello Shih-Yuan, or anyone else affected,

Accepted xorg-server into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xorg-server/2:1.17.1-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xorg-server (Ubuntu Trusty):
status: New → Invalid
Changed in xorg-server-lts-vivid (Ubuntu Vivid):
status: Confirmed → Invalid
Changed in xorg-server (Ubuntu Vivid):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in xorg-server-lts-vivid (Ubuntu Trusty):
status: New → Fix Committed
Timo Aaltonen (tjaalton) wrote :

Hello Shih-Yuan, or anyone else affected,

Accepted xorg-server-lts-vivid into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xorg-server-lts-vivid/2:1.17.1-0ubuntu3.1~trusty1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Shih-Yuan Lee (fourdollars) wrote :

I have verified xorg-server-lts-vivid/2:1.17.1-0ubuntu3.1~trusty1.
The rotation and reflection are disabled for NVIDIA Optimus performance mode.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for xorg-server has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server-lts-vivid - 2:1.17.1-0ubuntu3.1~trusty1

---------------
xorg-server-lts-vivid (2:1.17.1-0ubuntu3.1~trusty1) trusty; urgency=medium

  * Backport vivid package for lts-vivid stack.

xorg-server (2:1.17.1-0ubuntu3.1) vivid; urgency=medium

  * disable-rotation-transform-gpuscreens.patch:
    Revert back to disabling rotations on GPU screens. (LP: #1489696)

 -- Timo Aaltonen <email address hidden> Wed, 02 Sep 2015 16:28:30 +0300

Changed in xorg-server-lts-vivid (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.17.1-0ubuntu3.1

---------------
xorg-server (2:1.17.1-0ubuntu3.1) vivid; urgency=medium

  * disable-rotation-transform-gpuscreens.patch:
    Revert back to disabling rotations on GPU screens. (LP: #1489696)

 -- Timo Aaltonen <email address hidden> Wed, 02 Sep 2015 16:21:04 +0300

Changed in xorg-server (Ubuntu Vivid):
status: Fix Committed → Fix Released
Robert Hooker (sarvatt) on 2015-10-08
Changed in hwe-next:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers