2:1.17.1-0ubuntu4 broke xmir ABI

Bug #1462994 reported by Iain Lane
22
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Critical
Robert Ancell
xserver-xorg-video-ati (Ubuntu)
Critical
Robert Ancell
xserver-xorg-video-ati (Ubuntu RTM)
Undecided
Łukasz Zemczak
xserver-xorg-video-intel (Ubuntu)
Critical
Robert Ancell
xserver-xorg-video-intel (Ubuntu RTM)
Undecided
Łukasz Zemczak
xserver-xorg-video-nouveau (Ubuntu)
Critical
Robert Ancell
xserver-xorg-video-nouveau (Ubuntu RTM)
Undecided
Łukasz Zemczak

Bug Description

I noticed this morning that after I logged in unity-settings-daemon was getting an assertion failure.

  ERROR:gsd-rr-config.c:661:gsd_rr_config_load_current: assertion failed: (gsd_rr_config_match (config, config))

  ** (unity-settings-daemon:2293): WARNING **: Attempted to init Xsync, found version 3.1 error base 134 event base 83

which was terminating it and leaving me with a not really functional desktop.

After debugging for a while I found this in Xorg.0.log

  [ 81.641] (EE) Failed to load /usr/lib/xorg/modules/drivers/nouveau_drv.so: /usr/lib/xorg/modules/drivers/nouveau_drv.so: undefined symbol: xorgMir

i.e. my driver was failing to load which had these knock on effects.

It seems that nouveau is using this symbol from xorg, and it's now gone as of the latest xmir related upload (http://launchpadlibrarian.net/208141145/xorg-server_2%3A1.17.1-0ubuntu3_2%3A1.17.1-0ubuntu4.diff.gz). After rebuilding it works again, but I think that xmir support probably got disabled, because of the following in xxv-nouveau's src/nv_type.h:

  #ifdef XMIR
  #include "xmir.h"
  #include "xf86Priv.h"
  #else
  typedef struct xmir_screen xmir_screen;
  #define xorgMir 0
  #endif

XMIR isn't defined any more.

Please could you investigate if there is any other breakage and fix up as necessary? I'm going to upload a rebuild of nouveau so nobody else has these problems but there will be further cleanup required. Would be ideal to use packaging to force users to never be in a broken situation, even if just versioned Breaks if you want to avoid doing a transition.

Iain Lane (laney)
Changed in xorg-server (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Revision history for this message
Benedikt (benedikt-klotz) wrote :

[ 31.877] (II) LoadModule: "intel"
[ 31.891] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 31.897] (EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so: /usr/lib/xorg/modules/drivers/intel_drv.so: undefined symbol: xorgMir
[ 31.897] (II) UnloadModule: "intel"
[ 31.897] (II) Unloading intel
[ 31.897] (EE) Failed to load module "intel" (loader failed, 7)

confirmed for the intel driver

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Revision history for this message
Robert Ancell (robert-ancell) wrote :

The old XMir required the drivers to detect they were in XMir by checking for a global variable "xorgMir". Since we dropped the old XMir we don't need these driver changes for the new glamor based implementation.

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in xserver-xorg-video-nouveau (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → Critical
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Critical
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → High
importance: High → Critical
Changed in xorg-server (Ubuntu):
status: Confirmed → Won't Fix
importance: Undecided → Critical
Revision history for this message
Robert Ancell (robert-ancell) wrote :

Since it's unlikely any other driver relied on this there's no point patching Xorg to have this variable for ABI compatibility.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.917-1~exp1ubuntu3

---------------
xserver-xorg-video-intel (2:2.99.917-1~exp1ubuntu3) wily; urgency=medium

  * debian/patches/xmir.patch:
    - Drop XMir patch, we don't need it with new glamor based XMir (LP: #1462994)
  * debian/patches/fix-sna-fstat-include.patch:
  * debian/patches/fix-uxa-fstat-include.patch:
    - Fix missing include for fstat

 -- Robert Ancell <email address hidden> Tue, 09 Jun 2015 15:17:18 +1200

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-ati - 1:7.5.0-1ubuntu3

---------------
xserver-xorg-video-ati (1:7.5.0-1ubuntu3) wily; urgency=medium

  * debian/patches/xmir.patch:
    - Drop XMir patch, we don't need it with new glamor based XMir (LP: #1462994)

 -- Robert Ancell <email address hidden> Tue, 09 Jun 2015 15:16:34 +1200

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-nouveau - 1:1.0.11-1ubuntu3

---------------
xserver-xorg-video-nouveau (1:1.0.11-1ubuntu3) wily; urgency=medium

  * debian/patches/xmir.patch:
    - Drop XMir patch, we don't need it with new glamor based XMir (LP: #1462994)

 -- Robert Ancell <email address hidden> Tue, 09 Jun 2015 15:18:16 +1200

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Fix Released
Revision history for this message
Andrea Bernabei (faenil) wrote :

I hit this bug today
on vivid overlay PPA.

My laptop was not booting anymore. I was adviced to reinstall the older xserver-xorg-core (1.17.1-0ubuntu3) and that fixed it.

The overlay ppa currently offers:
xserver-xorg-core ---> 1.17.2-1ubuntu0.1~overlay1 (and this is the version causing issues)
xserver-xorg-video-intel ----> 2:2.99.917-1~exp1ubuntu2.2 (and this version doesn't seem to contain the fix)

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Adding the Ubuntu-RTM tasks to the bug. Normally we do not recommend using the overlay PPA for desktop uses as it's generally the 'stable phone overlay' - so in theory it's only for phone usage. But I suppose there are certain uses of the overlay for things like the desktop next and similar. Anyway, probably not top priority tasks.

Changed in xserver-xorg-video-intel (Ubuntu RTM):
assignee: nobody → Łukasz Zemczak (sil2100)
status: New → In Progress
Changed in xserver-xorg-video-nouveau (Ubuntu RTM):
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in xserver-xorg-video-ati (Ubuntu RTM):
assignee: nobody → Łukasz Zemczak (sil2100)
status: New → In Progress
Changed in xserver-xorg-video-nouveau (Ubuntu RTM):
status: New → In Progress
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2.1~overlay1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

xserver-xorg-video-nouveau (1:1.0.11-1ubuntu2.1~overlay1) vivid; urgency=medium

  [ Robert Ancell ]
  * debian/patches/xmir.patch:
    - Drop XMir patch, we don't need it with new glamor based XMir (LP: #1462994)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 06 Aug 2015 15:40:10 +0200

Changed in xserver-xorg-video-nouveau (Ubuntu RTM):
status: In Progress → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package xserver-xorg-video-intel 2:2.99.917-1~exp1ubuntu2.3~overlay1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

xserver-xorg-video-intel (2:2.99.917-1~exp1ubuntu2.3~overlay1) vivid; urgency=medium

  [ Robert Ancell ]
  * debian/patches/xmir.patch:
    - Drop XMir patch, we don't need it with new glamor based XMir (LP: #1462994)
  * debian/patches/fix-sna-fstat-include.patch:
  * debian/patches/fix-uxa-fstat-include.patch:
    - Fix missing include for fstat

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 06 Aug 2015 15:33:16 +0200

Changed in xserver-xorg-video-intel (Ubuntu RTM):
status: In Progress → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package xserver-xorg-video-ati 1:7.5.0-1ubuntu2.1~overlay1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

xserver-xorg-video-ati (1:7.5.0-1ubuntu2.1~overlay1) vivid; urgency=medium

  [ Robert Ancell ]
  * debian/patches/xmir.patch:
    - Drop XMir patch, we don't need it with new glamor based XMir (LP: #1462994)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 06 Aug 2015 15:36:57 +0200

Changed in xserver-xorg-video-ati (Ubuntu RTM):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers