incorrect screen resolution on gutsy beta using intel

Bug #144956 reported by Sebastien Bacher on 2007-09-25
28
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Bryce Harrington

Bug Description

The screen resolution is incorrectly set to 1024x768 instead of 1280x800 on my laptop using gutsy beta (intel 855 video). Other users complained on IRC about similar issues. The bug seems to be due to 143_fedora_xserver-1.3.0-randr12-config-hack.patch, without it xresprobe lists 1280x800 correctly

Related branches

description: updated
Bryce Harrington (bryce) wrote :

I'll roll out an xserver with this patch disabled. The issue it fixes is a minor corner case; it's more important that the resolution get detected properly.

Changed in xorg-server:
assignee: nobody → bryceharrington
importance: Undecided → High
status: New → In Progress
Bryce Harrington (bryce) wrote :

Here's the debdiff for this change.

Albert Damen (albrt) wrote :

As part of testing for bug 127008, I tested this patch.
I rebuilt it for AMD64 and customized the beta CD.
After the 1st reboot my laptop came up with 1280x800 as it should. Previously the 1st reboot would give 1024x800. Tested on Intel GM965 with Intel driver.

Bryce Harrington (bryce) wrote :

Thanks for confirming albert. I've put this up for upload here:
http://people.ubuntu.com/~bryce/Uploads/xorg-server_1.3.0.0.dfsg-12ubuntu7*

Changed in xorg-server:
status: In Progress → Fix Committed
Bryce Harrington (bryce) wrote :

xorg-server (2:1.3.0.0.dfsg-12ubuntu7) gutsy; urgency=low

  * Drop 143_fedora_xserver-1.3.0-randr12-config-hack.patch
    as it causes failure to detect proper resolution on some intel
    hardware. (closes LP: #144956)

 -- Bryce Harrington <email address hidden> Tue, 25 Sep 2007 14:42:59 -0700

Changed in xorg-server:
status: Fix Committed → Fix Released
M. Vefa Bicakci (mvb) wrote :

Hello,

I am having the same problem on my laptop.
I am glad that a resolution was reached.

Thank you,

situert

Albert Damen (albrt) wrote :

Possible regression in bug 147846 and bug 147189. They get higher resolutions then their systems can handle.
In both cases the problem is solved after downgrading xserver-xorg-core.

I had this issue yesterday when installing kubuntu 7.10 beta on my c2d macbook. I can't tell by the above dates if this patch has been put in past beta release, but as of the beta .iso build it still occurs.

Bryce Harrington (bryce) wrote :

Christer, the patch causing the issue described in this bug was dropped for Gutsy, so there really isn't a chance that your issue is being caused by the bug described in this report. You'll need to start a new report, and explain all your details for it, if it still is occurring in Gutsy final.

albert, thanks for pointing those out. I'm not sure "regression" is the right term, since really we've just restored the original behavior since the patch had unwanted side effects.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers