1680x1050 resolution is not available

Bug #138820 reported by lux on 2007-09-11
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
X.Org X server
Invalid
Medium
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

For some reason, 1680x1050 resolution has never been available for me. When the generic LCD monitor (1680x1050) is chosen, and also when the actual monitor definition file is loaded ViewSonic vx2235-wm

I can select what would seem to be almost every other resolution, but 1680x1050.

I'll admit my xorg.conf has been raped by ATI Catalyst, however it seems that DisplayConfig should essentially be able to overcome this, since the display is being re-configured.

This is on a Dell e1705 w/ ATI X1400, Gutsy, fglrx.

/etc/X11/xorg.conf
--------------
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
 Identifier "Default Layout"
   Screen 0 "aticonfig-Screen[0]" LeftOf "aticonfig-screen[1]"
   Screen 1 "aticonfig-Screen[1]" 0 0
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
 InputDevice "stylus" "SendCoreEvents"
 InputDevice "cursor" "SendCoreEvents"
 InputDevice "eraser" "SendCoreEvents"
 InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

 # path to defoma fonts
 FontPath "/usr/share/X11/fonts/misc"
 FontPath "/usr/share/X11/fonts/cyrillic"
 FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/Type1"
 FontPath "/usr/share/X11/fonts/100dpi"
 FontPath "/usr/share/X11/fonts/75dpi"
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "type1"
 Load "vbe"
 Load "dbe"
 Load "GLcore"
EndSection

Section "ServerFlags"
 Option "AIGLX" "off"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
 Option "XkbOptions" "altwin:super_win"
 Option "SHMConfig" "on"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ExplorerPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Identifier "Synaptics Touchpad"
 Driver "synaptics"
 Option "SendCoreEvents" "true"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "HorizScrollDelta" "0"
 Option "SHMConfig" "on"
 Option "LeftEdge" "1700"
 Option "RightEdge" "5300"
 Option "TopEdge" "1700"
 Option "BottomEdge" "4200"
 Option "FingerLow" "25"
 Option "FingerHigh" "30"
 Option "MaxTapTime" "180"
 Option "MaxTapMove" "220"
 Option "VertScrollDelta" "100"
 Option "MinSpeed" "0.09"
 Option "MaxSpeed" "0.18"
 Option "AccelFactor" "0.015"
 Option "EdgeMotionMinZ" "17"
 Option "EdgeMotionMaxZ" "21"
 Option "EdgeMotionMinSpeed" "30"
 Option "EdgeMotionMaxSpeed" "35"
 Option "LeftRightScrolling" "1"
 Option "UpDownScrolling" "1"
 Option "EmulateMidButtonTime" "75"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
 Identifier "stylus"
 Driver "wacom"
 Option "Device" "/dev/wacom" # Change to
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
 Identifier "eraser"
 Driver "wacom"
 Option "Device" "/dev/wacom" # Change to
 Option "Type" "eraser"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
 Identifier "cursor"
 Driver "wacom"
 Option "Device" "/dev/wacom" # Change to
 Option "Type" "cursor"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
 Identifier "Generic Monitor"
 Option "DPMS"
EndSection

Section "Monitor"
 Identifier "aticonfig-Monitor[0]"
 Option "VendorName" "ATI Proprietary Driver"
 Option "ModelName" "Generic Autodetecting Monitor"
 Option "DPMS" "true"
 HorizSync 28-96
 VertRefresh 43-60
EndSection

Section "Monitor"
 Identifier "aticonfig-Monitor[1]"
 Option "VendorName" "ATI Proprietary Driver"
 Option "ModelName" "Generic Autodetecting Monitor"
 Option "DPMS" "true"
 HorizSync 28-96
 VertRefresh 43-60
EndSection

Section "Device"
   Identifier "aticonfig-Device[0]"
   Driver "fglrx"
   Option "VideoOverlay" "on"
   Option "OpenGLOverlay" "off"
   Option "DesktopSetup" "horizontal"
   BusID "PCI:1:0:0"
EndSection

Section "Device"
   Identifier "aticonfig-Device[1]"
   Driver "fglrx"
   Option "VideoOverlay" "on"
   Option "OpenGLOverlay" "off"
   BusID "PCI:1:0:1"
   Screen 1
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]"
   Device "aticonfig-Device[0]"
   Monitor "aticonfig-Monitor[0]"
   DefaultDepth 24
   SubSection "Display"
      Viewport 0 0
      Depth 24
      Modes "1680x1050"
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[1]"
   Device "aticonfig-Device[1]"
   Monitor "aticonfig-Monitor[1]"
   DefaultDepth 24
   SubSection "Display"
      Viewport 0 0
      Depth 24
      Modes "1680x1050"
   EndSubSection
EndSection

Section "DRI"
 Mode 0666
EndSection

Section "Extensions"
 Option "Composite" "Disable"
EndSection

William F Pearson (wfpearson) wrote :

I can confirm this bug. I have an LG L204WT with a native 1680x1050@60 Hz native resolution. The monitor in xorg.conf had to be configured manually.

Gauthic (gauthic) wrote :

The same here, Acer 8200 using fglrx driver

Attached is my results for:
sudo /usr/sbin/ddcprobe >> sysinfo.txt

Please feel free to request any more data :-)

I'll subscribe to this list.

Alan Tam (at) wrote :

Same here for Dell E228WFP. I even tried choosing the generic "LCD Panel 1680x1050" but still the 1680x1050 resolution is not available! Totally unacceptable.

Sebastian Heinlein (glatzor) wrote :

@Alan: Open source software gives you new opportunities. You should be glad to get as far as you can.

Alan Tam (at) wrote :

@Sebastian: I am personally glad to modify xorg.conf myself, but I know the press and bloggers that will evaluate Ubuntu won't. I am an open source evangelist, but that doesn't stop me from criticizing how reality deviate from the utopia.

Display configuration is inherently hard. Making use of what you detected from the display card and monitor, you can construct a config but you are never 100% it will work. This is the reason you have a "Test" button! Under this circumstance, I don't see the reason why we should not add much more commonly used resolutions to the list, even if they are not detected. Even adding a pair of text boxes to type any arbitrary resolution makes sense.

The real reason it looks unacceptable: What is the "LCD Panel 1680x1050" for? I would guess it is used in case I know my monitor supports this resolution, but I cannot find it in the list and don't have the Windows inf file on hand. Then how come 1680x1050 resolution is given as a choice?

Sebastian Heinlein (glatzor) wrote :

I was annoyed by the words "totally unacceptable".

There is a either a bug in the frequence ranges of the generic 1680 model or your monitor reports wrong resolutions.

Please append to output of "sudo get-edid|parse-edid" and "sudo ddcprobe".

Alan Tam (at) wrote :

Sorry for that. I meant the software in that form was unacceptable for release.

This is an Thinkpad T40 with built-in 1024x768 and external Dell 22" LCD.

Alan Tam (at) wrote :
Mr. H (thomas-hecker) wrote :

Are there any new ideas about this bug? I have the same problems with my Samsung 206BW external VGA TFT connected to intel GM945 hardware.

Sander D (sanderd) on 2010-02-23
affects: displayconfig-gtk → xorg-server
Sander D (sanderd) wrote :

The same problem still appears on a 10.04 install done today. I have an Intel 945G Express Chipset within a notebook, and an external LG 204WT monitor. In gnome-display-properties I could not choose the appropriate 1680x1050 resolution for this monitor.

A workaround was creating /etc/X11/xorg.conf as attached. Using this, also 1600x1200 and 1792x1344 became available, which should not happen.

This seems to be a general problem with some monitors supporting 1680x1050. Any idea what could be going wrong?

Sander D (sanderd) wrote :

There seems to be something wrong with the get-edid output here.

Sander D (sanderd) wrote :
shankao (shankao) wrote :

Um... Is there any reason why this bug is filled against the general ubuntu? It should have an ubuntu package associated instead.
I have changed it to xorg-server and confirmed it after the comments here.

affects: ubuntu → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Download full text (6.0 KiB)

In Ubuntu lux reported:

For some reason, 1680x1050 resolution has never been available for me. When the generic LCD monitor (1680x1050) is chosen, and also when the actual monitor definition file is loaded ViewSonic vx2235-wm

I can select what would seem to be almost every other resolution, but 1680x1050.

I'll admit my xorg.conf has been raped by ATI Catalyst, however it seems that DisplayConfig should essentially be able to overcome this, since the display is being re-configured.

This is on a Dell e1705 w/ ATI X1400, Gutsy, fglrx.

/etc/X11/xorg.conf
--------------
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
 Identifier "Default Layout"
   Screen 0 "aticonfig-Screen[0]" LeftOf "aticonfig-screen[1]"
   Screen 1 "aticonfig-Screen[1]" 0 0
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
 InputDevice "stylus" "SendCoreEvents"
 InputDevice "cursor" "SendCoreEvents"
 InputDevice "eraser" "SendCoreEvents"
 InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

 # path to defoma fonts
 FontPath "/usr/share/X11/fonts/misc"
 FontPath "/usr/share/X11/fonts/cyrillic"
 FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/Type1"
 FontPath "/usr/share/X11/fonts/100dpi"
 FontPath "/usr/share/X11/fonts/75dpi"
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "type1"
 Load "vbe"
 Load "dbe"
 Load "GLcore"
EndSection

Section "ServerFlags"
 Option "AIGLX" "off"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
 Option "XkbOptions" "altwin:super_win"
 Option "SHMConfig" "on"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ExplorerPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Identifier "Synaptics Touchpad"
 Driver "synaptics"
 Option "SendCoreEvents" "true"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "HorizScrollDelta" "0"
 Option "SHMConfig" "on"
 Option "LeftEdge" "1700"
 Option "RightEdge" "5300"
 Option "TopEdge" "1700"
 Option "BottomEdge" "4200"
 Option "FingerLow" "25"
 Option "FingerHigh" "30"
 Option "MaxTapTime" "180"
 Option "MaxTapMove" ...

Read more...

Not a server bug afaict.

Angel Abad (angelabad) on 2010-03-04
Changed in xorg-server:
importance: Undecided → Unknown
status: New → Unknown
Changed in xorg-server:
status: Unknown → Confirmed

Closing as INVALID; fglrx no longer supports your chipset. If you have similar problems with the radeon driver, please check to see if there is already an existing bug before opening a new one.

Closed upstream as INVALID; fglrx no longer supports the reporter's chipset. In addition, we consider a working setup with radeon to be a valid resolution, although the reporter never tried it.

Please close this, thanks.

~ C.

Timo Aaltonen (tjaalton) wrote :

thanks, closing.

Changed in xorg-server (Ubuntu):
status: Confirmed → Won't Fix
Changed in xorg-server:
status: Confirmed → Invalid
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.