Caps lock delay

Bug #1376903 reported by Kenan Gutić on 2014-10-02
46
This bug affects 11 people
Affects Status Importance Assigned to Milestone
X.Org X server
Confirmed
Wishlist
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

I'm having a problem with Ubuntu, to be precise I have problem with its CAPS LOCK DELAY.
I have a habit to use caps lock when I need a capital letter in my sentence, but problem is that I changing Caps lock in Ubuntu is slow, so I end up with sentence like this:

 - THis is a test. CAn you see how the first two letters are capital. THis happens only on UBuntu, not on my WIndows!

Instead of holding shift like a normal person to capitalize my works, I hit Caps Lock, then hit the letter, then hit Caps Lock again. I know this is a strange habit, but I tried to change it to use Shift but I just can't. I want to contiunue using Caps lock, but the delay on Ubuntu is causing to have two capital letters in one word, and that is a problem, specially if you are typing very fast (like I). In 5 out of 10 cases I enter my password wrong beacuse of this delay.

I'm guessing this may have somthing with X org or something.
IS there a fix?

If not, this should be reported as a BUG!

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1376903/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Kenan Gutić (kenan-gutic) wrote :

I'm guessing that this bug is connected with Xorg but I'm not sure.
FOrgot to mention, I'm using Ubuntu 14.04 LTS with all the latest updates installed.

affects: ubuntu → xorg-lts-transitional (Ubuntu)
affects: xorg-lts-transitional (Ubuntu) → xserver-xorg-input-keyboard (Ubuntu)
tags: added: trusty
removed: bot-comment
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-keyboard (Ubuntu):
status: New → Confirmed
apavlov (apavlov) wrote :

This bug appears to affect all state modifiers, including the keyboard layout switch (the 'Win' key for me). As a result, you cannot hit 'Win' and immediately start typing in a different layout. You have to wait a bit (which is pretty tedious, as I have to switch layouts quite often) before typing, otherwise you get the first few letters of the word typed in the previous layout (language). Very annoying.

Paul Seo (dhseo1011) wrote :

I would like to note that this bug is still being overlooked by the community.
It really is aggravating to know while Linux as a whole claims to be free and open and customizable and user friendly due to the freedom to get what the users want, anything that the majority does not use as much is just... disregarded.

I have for almost 3 years of Linux used variants of the anti-caps lock delay solution. The current one is :
https://github.com/HexValid/Linux-CapsLock-Delay-Fixer

However, recently while I started writing essays, I started noticing that this never did fix the problem as a whole. In fact, there is a newer issue with this anti-caps lock delay solution.
1. The delay of caps lock still does exist. In fact, unlike Windows and Mac, Linux never seemed to have solved this issue fully. And it is noticeable if one is a fast typer (I am around ~150 WPM during my natural typing for essays) and from this speed, it gets frustrating since the caps delay issue becomes noticeable even with the anti-caps-delay fixer from time to time.
2. This anti-caps-lock-delay actually affects keys outside the alphabets also. In fact, if one types a ". , / ; [ ] \ " fast right after the caps lock like:
CAPSLOCK -> 'd' -> CAPSLOCK -> '.'
Instead of getting:
'D.'
I get:
'D>'
So basically a period becomes the shifted key of itself.

I really hope that this issue gets fixed because it is somewhat embarrassing how the community was unable to fix this issue for years now.

Considering this is probably rather very simple to fix, I don't understand why the community has not fixed this issue.
https://ubuntuforums.org/showthread.php?t=1556152
https://ubuntuforums.org/showthread.php?t=2286420
https://ubuntuforums.org/showthread.php?t=1410893
https://ubuntuforums.org/showthread.php?t=1462333
http://unix.stackexchange.com/questions/80441/caps-lock-delay-problem
http://superuser.com/questions/947087/how-do-you-eliminate-the-caps-lock-key-delay-on-ubuntu

And please don't give me the 'SHIFT' key argument. I have used CAPS LOCK for all my life and considering I am able to type from 110~180 WPM with the CAPS LOCK, I do not think it's a fair argument as some people are faster with CAPS LOCK rather than SHIFT key.
Also, I have used Linux for being able to have the freedom to customize. However, as this side is not my field of knowledge, I just really wish there was an official patch to fix this rather minor but critical update.
The anti-caps-delay fixer by various people does not work fully and is most noticeable with periods and commas and I would honestly like an official patch on this. Windows and Mac has never had this issue.
Linux (no matter what distro) has always had this issue even after constant forums for bug fixing.
I love Ubuntu and its customizability in the terminal but this everyday typing is starting to quite bug me after years of Ubuntu usage.

Domain Controller (quiret) wrote :

I find it disrespectful to Microsoft to NOT implement a switch for Windows-native capslock behavior because Canonical and Microsoft cooperated on BashOnWindows. Please stop this religious bs and help us Windows users get comfy with Ubuntu.

Timo Aaltonen (tjaalton) on 2017-05-09
affects: xserver-xorg-input-keyboard (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
importance: Undecided → Low
Changed in xorg-server:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Paul Seo (dhseo1011) wrote :

So is this halted again?
Is there basically no hope to fixing this bug that drives me crazy day and night?

I'm honestly starting to feel Windows and Macs have better support and faster responses. But then I guess that's the penalty of having an open source OS.
Just frustrating how I really need the bash of Ubuntu but not only games but also the keyboard isn't fully supported on Ubuntu.

At least the mouse is supported though I must add my touchscreen too is worthless on Ubuntu. Sigh

Paul Seo (dhseo1011) wrote :

That said, Swing applications like IntelliJ , JEdit are all having issues with this caps lock delay regardless of a simple caps delay fixer (which doesn't work properly in the first place especially with periods and commas, etc)

Derek Rogers (drogers24) wrote :

It appears this would also affect numlock as well.

(and yes, it's a problem that's affecting me as well--which makes it impossible to type stuff in Linux since I routinely use the caps lock key for a lot of different scenarios).

mari (waterfountains) wrote :

Yes and it is not a delay. The Caps and NUm Locks keys are set to turn off on release. CHanging this will solve it immediately.

galeo (galeo1) wrote :

The solution at his problem is here

https://www.cuevadeclasicos.org/comunidad/temas/delay-block-mayus-en-ubuntu.16331/

post is in spanish but can be easily understood.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.