Immediately after login, the screen freezes--except for the cursor

Bug #1362903 reported by Bryan Agee on 2014-08-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

In kernel 3.16, I could still launch a terminal and see that it was open by the changing of the cursor; the window did not draw (nor did anything else aside from the cursor).

On switching back to 3.13, untiy does not load at all, and the Ctrl+Alt+t short cut does not work.

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: xserver-xorg-core 2:1.15.1-0ubuntu9
ProcVersionSignature: Ubuntu 3.13.0-30.55-generic 3.13.11.2
Uname: Linux 3.16.0-10-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.6-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
Date: Sun Aug 24 19:33:40 2014
DistUpgraded: 2014-07-27 16:28:53,249 DEBUG entry '# deb http://ppa.launchpad.net/mjblenner/ppa-hal/ubuntu utopic main # disabled on upgrade to utopic' was disabled (unknown mirror)
DistroCodename: utopic
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:165a]
 Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT] [1002:6740] (rev ff) (prog-if ff)
InstallationDate: Installed on 2013-12-30 (241 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131230)
MachineType: Hewlett-Packard HP Pavilion dv7 Notebook PC
ProcCmdline: /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.13.0-30-generic root=UUID=069a73c1-787c-4f66-a9a7-4ad2d98128e8 ro quiet splash
SegvAnalysis:
 Segfault happened at: 0x7f2625ee7780: subl $0x1,0x18(%rdx)
 PC (0x7f2625ee7780) ok
 source "$0x1" ok
 destination "0x18(%rdx)" (0x00000018) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: xorg-server
StacktraceTop:
 ?? () from /usr/lib/xorg/modules/drivers/intel_drv.so
 ?? () from /usr/lib/xorg/modules/drivers/intel_drv.so
 ?? () from /usr/lib/xorg/modules/drivers/intel_drv.so
 ?? ()
 ?? ()
Title: Xorg crashed with SIGSEGV
UpgradeStatus: Upgraded to utopic on 2014-07-27 (32 days ago)
UserGroups:

dmi.bios.date: 04/25/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.13
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 165A
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 10.25
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.13:bd04/25/2011:svnHewlett-Packard:pnHPPaviliondv7NotebookPC:pvr058F110000244610000620100:rvnHewlett-Packard:rn165A:rvr10.25:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion dv7 Notebook PC
dmi.product.version: 058F110000244610000620100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.12+14.10.20140812-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.6-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.6-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu9
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Aug 28 20:14:37 2014
xserver.configfile: default
xserver.errors:
 Failed to load module "ati" (module does not exist, 0)
 Failed to load module "ati" (module does not exist, 0)
 intel: Failed to load module "dri3" (module does not exist, 0)
 intel: Failed to load module "present" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 5534
 vendor AUO
xserver.version: 2:1.15.1-0ubuntu9

Bryan Agee (bryanagee) wrote :

StacktraceTop:
 intel_get_master (scrn=scrn@entry=0x7f262bd0c760) at ../../src/intel_device.c:646
 I830EnterVT (arg=0x7f262bd0c760) at ../../../src/uxa/intel_driver.c:1102
 I830ScreenInit (screen=0x7f262bd16310, argc=1, argv=0x7f262b3a50c0 <AllSockets>) at ../../../src/uxa/intel_driver.c:1060
 ?? ()
 ?? ()

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
To post a comment you must log in.