no man page for Xephyr

Bug #134906 reported by Peter Berry
8
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
xorg-server (Debian)
Fix Released
Unknown
xorg-server (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: xserver-xephyr

There seems to be no manual page for Xephyr (though there is a usage note enabled with --help or any other unrecognised option).

Related branches

Revision history for this message
Peter Berry (pwberry) wrote :

Binary package hint: xserver-xephyr

There seems to be no manual page for Xephyr (though there is a usage note enabled with --help or any other unrecognised option).

Changed in xorg-server:
importance: Undecided → Low
status: New → Confirmed
Timo Aaltonen (tjaalton)
Changed in xorg-server:
importance: Low → Wishlist
Revision history for this message
Savvas Radevic (medigeek) wrote :

You would extra points if you would find someone to write the manual page :)
A lot of them are missing (look for "binary-without-manpage" errors):
http://<email address hidden>#xorg-server

Changed in xorg-server:
status: Unknown → Confirmed
Bryce Harrington (bryce)
Changed in xorg-server:
status: Confirmed → Triaged
Changed in xorg-server:
status: Unknown → Confirmed
Revision history for this message
Charlie_Smotherman (cjsmo) wrote :

Going to give this one a shot. I've done one or two man pages but this one looks like it could be rather complex. Well see how it goes.

Changed in xorg-server:
assignee: nobody → cjsmo
status: Triaged → In Progress
Revision history for this message
Charlie_Smotherman (cjsmo) wrote :

Here is my feeble attempt at this man page. Not sure if I have the xserver-xephyr.1 in the right place in the branch so I am attaching a diff of the manpage.

Revision history for this message
Charlie_Smotherman (cjsmo) wrote :

Added manpage patch to debian BTS

Changed in xorg-server (Ubuntu):
assignee: cjsmo → nobody
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.6.0-0ubuntu9

---------------
xorg-server (2:1.6.0-0ubuntu9) jaunty; urgency=low

  * local/xvfb-run: Fixes race condition with concurrent invocations
    (LP: #348052)
  * local/xvfb-run, xvfb-run.1: Add correct docs about error codes
    (LP: #328205)
  * local/xserver-xephyr.1, rules, xserver-xephyr.install: Add man page
    for xephyr
    (LP: #134906)

 -- Bryce Harrington <email address hidden> Wed, 01 Apr 2009 20:37:22 -0700

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
In , Alan Coopersmith (alan-coopersmith) wrote :

Fixed in git last year, included in Xserver 1.6 release:

commit 6a1b2fed7e465a9c652e8ee250b8eab440945862
Author: Matthieu Herrb <email address hidden>
Date: Sun Sep 28 12:18:16 2008 +0200

    Add a man page for Xephyr, with information from the README file.

Changed in xorg-server:
status: Confirmed → Fix Released
Changed in xorg-server (Debian):
status: Confirmed → Fix Released
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.