Xorg crashed with SIGABRT in do_sigtimedwait(), black screen after boot

Bug #1283719 reported by GOESSEL Guillaume on 2014-02-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

I'm using Ubuntu gnome 14.04,everything up to date.
Since yesterday I couldn't start Ubuntu: after plymouth the screen remained all black. I could only access to ttyx and typed startx (after I logged on) and it keept saying "no protocol specified"

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: xserver-xorg-core 2:1.15.0-1ubuntu6
ProcVersionSignature: Ubuntu 3.13.0-12.32-generic 3.13.4
Uname: Linux 3.13.0-12-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CrashCounter: 1
Date: Sun Feb 23 12:02:17 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
ExtraDebuggingInterest: Yes
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] RV560 [Radeon X1650 XT] [1002:7291] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited / Sapphire Technology Device [174b:e140]
   Subsystem: PC Partner Limited / Sapphire Technology Device [174b:e141]
InstallationDate: Installed on 2014-01-26 (27 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha amd64 (20140121.1)
MachineType: MSI MS-7519
ProcCmdline: /usr/bin/X :0 -background none -verbose -auth /var/run/gdm/auth-for-gdm-YHFhlX/database -seat seat0 -nolisten tcp vt7
ProcEnviron:
 LANG=fr_FR.UTF-8
 TERM=linux
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-3.13.0-12-generic root=UUID=a38cfe0c-de6f-4f34-8c1e-61fd6aa3c9af ro rootflags=subvol=@ quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 vbeDoEDID () from /usr/lib/xorg/modules/libvbe.so
 ?? () from /usr/lib/xorg/modules/drivers/vesa_drv.so
 InitOutput ()
 ?? ()
 __libc_start_main (main=0x7f36f091ee50, argc=12, argv=0x7fff19147d48, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff19147d38) at libc-start.c:285
Title: Xorg crashed with SIGABRT in vbeDoEDID()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 01/18/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.12
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P43 Neo-F (MS-7519)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.12:bd01/18/2010:svnMSI:pnMS-7519:pvr1.0:rvnMSI:rnP43Neo-F(MS-7519):rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7519
dmi.product.version: 1.0
dmi.sys.vendor: MSI
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52+git20140121.46d451c9-0ubuntu0sarvatt
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.0~git20140221.9b2fe7cf-0ubuntu0sarvatt3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.0~git20140221.9b2fe7cf-0ubuntu0sarvatt3
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.99+git20140206.8de6f7b2-0ubuntu0sarvatt
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910+git20140221.0b92b128-0ubuntu0sarvatt
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10+git20140220.480f0998-0ubuntu0sarvatt
xserver.bootTime: Sun Feb 23 14:25:35 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.0-1ubuntu6
xserver.video_driver: radeon

StacktraceTop:
 do_sigtimedwait (timeout=<optimized out>, info=0x1, set=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/../../../../../sysdeps/unix/sysv/linux/sigtimedwait.c:60
 __GI___sigtimedwait (set=<optimized out>, info=0x1, timeout=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/../../../../../sysdeps/unix/sysv/linux/sigtimedwait.c:75
 ?? ()
 ?? ()

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
summary: - Xorg crashed with SIGABRT in vbeDoEDID(), black screen after boot
+ Xorg crashed with SIGABRT in do_sigtimedwait(), black screen after boot
tags: removed: need-amd64-retrace
information type: Private → Public
To post a comment you must log in.