Xorg crashed with SIGABRT in RRCrtcDetachScanoutPixmap()

Bug #1280743 reported by VasiaUVI on 2014-02-16
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Maarten Lankhorst
Saucy
High
Unassigned

Bug Description

1) Ubuntu Trusty Tahr 14.04
2) nvidia-prime 0.5.5
3) after installing and restarting the system the above error apeared. In this moment I don't see any other issues but I will report if something else is appearing.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: xserver-xorg-core 2:1.15.0-1ubuntu6
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 331.38 Wed Jan 8 19:32:30 PST 2014
 GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-15ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 2.13.2-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sun Feb 16 11:48:18 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.7, 3.13.0-8-generic, x86_64: installed
 nvidia-331, 331.38, 3.13.0-8-generic, x86_64: installed
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:04ca]
 NVIDIA Corporation GF108M [GeForce GT 525M] [10de:0df5] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:04ca]
InstallationDate: Installed on 2014-02-16 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140215)
MachineType: Dell Inc. Inspiron N5110
ProcCmdline: /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-8-generic root=UUID=d4b2ed66-3f0a-415c-b5d3-b252d06d0bc4 ro quiet splash
Signal: 6
SourcePackage: nvidia-graphics-drivers
StacktraceTop:
 RRCrtcDetachScanoutPixmap ()
 ?? ()
 ?? ()
 FreeClientResources ()
 FreeAllResources ()
Title: Xorg crashed with SIGABRT in RRCrtcDetachScanoutPixmap()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 03/22/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A10
dmi.board.name: 0HVRTT
dmi.board.vendor: Dell Inc.
dmi.board.version: A10
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA10:bd03/22/2012:svnDellInc.:pnInspironN5110:pvrNotSpecified:rvnDellInc.:rn0HVRTT:rvrA10:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Inspiron N5110
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.0.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.0.1-1ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2

VasiaUVI (vasiauvi) wrote :

StacktraceTop:
 RRCrtcDetachScanoutPixmap (crtc=crtc@entry=0x7fc2b30d32f0) at ../../randr/rrcrtc.c:371
 RRCrtcDestroyResource (value=0x7fc2b30d32f0, pid=<optimized out>) at ../../randr/rrcrtc.c:680
 doFreeResource (res=0x7fc2b30aa0c0, skip=skip@entry=0) at ../../dix/resource.c:873
 FreeClientResources (client=0x7fc2b30879c0) at ../../dix/resource.c:1139
 FreeAllResources () at ../../dix/resource.c:1154

Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
information type: Private → Public
Changed in xorg-server (Ubuntu):
importance: Undecided → High
assignee: nobody → Maarten Lankhorst (mlankhorst)
no longer affects: nvidia-graphics-drivers (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.15.0-1ubuntu7

---------------
xorg-server (2:1.15.0-1ubuntu7) trusty; urgency=medium

  * Fix crash in RRCrtcDetachScanoutPixmap. (LP: #1280743)
 -- Maarten Lankhorst <email address hidden> Thu, 13 Mar 2014 13:10:52 +0100

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Released

Hello VasiaUVI, or anyone else affected,

Accepted xorg-server into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server/2:1.14.6-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xorg-server (Ubuntu Saucy):
importance: Undecided → High
status: New → Fix Committed
tags: added: verification-needed
VasiaUVI (vasiauvi) wrote :

Hello Brian,

I have Package: xserver-xorg-core 2:1.15.1-1ubuntu2
Now, the error DOES NOT appear anymore!
Also the nVidia XServer Settings is OK and switching between video cards is working.

tags: added: verification-done
removed: verification-needed
VasiaUVI (vasiauvi) wrote :

I forgot to tell that I have Ubuntu 14.04 Trusty.

Adam Conrad (adconrad) on 2014-05-15
tags: removed: verification-done
Brian Murray (brian-murray) wrote :

Hello VasiaUVI, or anyone else affected,

Accepted xorg-server-lts-saucy into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server-lts-saucy/2:1.14.6-0ubuntu1~precise2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Maarten Lankhorst (mlankhorst) wrote :

Confirmed fixed on xorg-server-lts-saucy, shutting down xserver works as expected.

Changed in xorg-server (Ubuntu Saucy):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for xorg-server-lts-saucy has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.14.6-0ubuntu1

---------------
xorg-server (2:1.14.6-0ubuntu1) saucy-proposed; urgency=medium

  * New upstream release (MRE).
  * Disable support for rotations and transforms
    on gpu screens for now. (LP: #1308515)
  * Only set RR caps that are appropriate to main/gpu screen. (LP: #1277014)
  * Fix crash in RRCrtcDetachScanoutPixmap. (LP: #1280743)
 -- Maarten Lankhorst <email address hidden> Tue, 22 Apr 2014 12:37:21 +0200

Changed in xorg-server (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.