tearing with vsync enabled

Bug #1278012 reported by David Gnedt on 2014-02-09
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Unassigned

Bug Description

I get some really bad tearing issues with my i965 card in trusty since xserver-xorg-core update to 2:1.15.0-1ubuntu3 and xserver-xorg-video-intel 2:2.99.909-0ubuntu2.
I first tried downgrading xserver-xorg-video-intel to 2:2.99.907-0ubuntu2, which is still compatibile to xorg 1.15.0. The problem remained.
Next I tried downgrading xserver-xorg-core to 2:1.15.0-1ubuntu1. Problem remained.
Downgrading xserver-xorg-core to 2:1.14.5-1ubuntu4 and xserver-xorg-video-intel to 2:2.99.907-0ubuntu1, resolved the problem.
I expect the problem in the upstream xorg version update, as there is no effective change between xserver-xorg-video-intel 2:2.99.907-0ubuntu1 and 2.99.907-0ubuntu2.

Summary:
xserver-xorg-core xserver-xorg-video-intel Status
2:1.15.0-1ubuntu3 2:2.99.909-0ubuntu2 Tearing
2:1.15.0-1ubuntu3 2:2.99.907-0ubuntu2 Tearing
2:1.15.0-1ubuntu1 2:2.99.907-0ubuntu2 Tearing
2:1.14.5-1ubuntu4 2:2.99.907-0ubuntu1 No tearing

Test environment:
System: Shuttle XH61V
CPU: Intel Pentium G2130
Output: HDMI 1920x1080 @ 24 Hz
Software: XBMC 13.0 (OpenGL, VSync enabled)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xserver-xorg-core 2:1.15.0-1ubuntu3
ProcVersionSignature: Ubuntu 3.13.0-8.27-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
Date: Sun Feb 9 03:25:40 2014
SourcePackage: xorg-server
UpgradeStatus: No upgrade log present (probably fresh install)

David Gnedt (lxp13) wrote :
Chris Wilson (ickle) wrote :

That's odd. Can you also please play around with the compositor settings and different desktop enviroments? (In particular I wonder if it fails to unredirect xbmc, or something like that.)

David Gnedt (lxp13) wrote :

I am not using any compositor or desktop environment, just plain xorg with nodm (the no display manager) and xbmc running on top.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Teeedubb (teeedubb) wrote :

Same with a nvidia 660ti with 304, 331, 334 nvidia drivers on x64 14.04 + xserver-xorg-core_1.14.5-1ubuntu1_amd64. Downgrading to 2:1.14.5-1ubuntu gets rid of the tearing. Running xbmc in its own xsession with alsa. Problem only occours in XBMC.

kimothy (kimtengh) wrote :

I have the same issue with Intel Celeron 1037U CPU. VLC and Totem works fine. I played aroud with all the settings in compiz and xbmc without any results. Is downgrading a viable short term solution?

David Gnedt (lxp13) wrote :

It seems the problem is caused by the backing store function of xorg. It is disabled by default in 1.14.5 and enabled by default in 1.15.0. If I disable it with -bs on xorg startup, I have no tearing with 1.15.0.

It prevents the package (or a dependent one) from functioning correctly at all.

Changed in xorg-server (Ubuntu):
importance: Undecided → High
jebbiss (jebbiss) wrote :

I too have this problem. I searched and Arch has a sdl-nobackingstore package that solves this issue.

jebbiss (jebbiss) wrote :

Yesterday`s update to xserver-xorg-core 2:1.15.1-0ubuntu1 did not fix. The tearing still persists.

luke (lukeg007) wrote :

same problem 14.04 with latest xbmc nightlies... any viable solution? shame the pi is playing video smoother than my i7 laptop

Uveges Valentin (iuv-vali) wrote :

A workaround for ubuntu 14.04 with nvidia driver is to disable backing store in xorg:

Make sure you have the "-bs" option in lightdm config file:
cat /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[SeatDefaults]
# Dump core
xserver-command=X -bs -core

jebbiss (jebbiss) wrote :

Thanks Uveges this did the trick for me. The tearing was really annoying me.

pcworld (pcworld) wrote :

After upgrading from 13.10 to 14.04 (xorg-edgers PPA enabled), I had tearing in Teeworlds with vsync enabled, nvidia proprietary drivers. Disabling Xorg's backing store as outlined in #12 fixed it.

Timo Jyrinki (timo-jyrinki) wrote :

If you don't mind, I'd mark this bug as duplicate of (later filed) bug #1280665 which correctly attributes the bug to be in SDL 1.2 which enables backingstore wrongly in composited environment (if I understood correctly).

Please give out your test result there on the PPA version, and if I incorrectly marked this as duplicate please remove the duplicate status.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers