Xorg assert failure: X: ../../dix/dispatch.c:3920: DetachUnboundGPU: Assertion `slave->isGPU' failed.

Bug #1277014 reported by Adauto Serpa on 2014-02-06
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned

Bug Description

This error occurred when I started my notebook without connecting to power source. This probably happened because I'm using the beta driver from nvidia optimus.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: xserver-xorg-core 2:1.15.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-7.25-generic 3.13.1
Uname: Linux 3.13.0-7-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
AssertionMessage: X: ../../dix/dispatch.c:3920: DetachUnboundGPU: Assertion `slave->isGPU' failed.
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Thu Feb 6 08:46:47 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.7, 3.13.0-6-generic, x86_64: installed
 bbswitch, 0.7, 3.13.0-7-generic, x86_64: installed
 nvidia-331, 331.38, 3.13.0-6-generic, x86_64: installed
 nvidia-331, 331.38, 3.13.0-7-generic, x86_64: installed
ExecutablePath: /usr/bin/Xorg
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Samsung Electronics Co Ltd Device [144d:c0d1]
 NVIDIA Corporation GF108M [GeForce GT 630M] [10de:0de9] (rev ff) (prog-if ff)
InstallationDate: Installed on 2014-01-28 (8 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140128)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 550P5C/550P7C
ProcCmdline: /usr/bin/X -core :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-7-generic.efi.signed root=UUID=a3adce6a-3b61-48e0-82d6-ac3ec5a24dcb ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 __assert_fail_base (fmt=0x7f18ee23cbe0 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x7f18f075ad57 "slave->isGPU", file=file@entry=0x7f18f075ad22 "../../dix/dispatch.c", line=line@entry=3920, function=function@entry=0x7f18f075ade0 "DetachUnboundGPU") at assert.c:92
 __GI___assert_fail (assertion=0x7f18f075ad57 "slave->isGPU", file=0x7f18f075ad22 "../../dix/dispatch.c", line=3920, function=0x7f18f075ade0 "DetachUnboundGPU") at assert.c:101
 DetachUnboundGPU ()
 ?? ()
 ProcRRSetProviderOutputSource ()
Title: Xorg assert failure: X: ../../dix/dispatch.c:3920: DetachUnboundGPU: Assertion `slave->isGPU' failed.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 09/17/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P05ABI.016.130917.dg
dmi.board.asset.tag: No Asset Tag
dmi.board.name: SAMSUNG_NP1234567890
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: SEC_SW_REVISION_1234567890ABCD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP05ABI.016.130917.dg:bd09/17/2013:svnSAMSUNGELECTRONICSCO.,LTD.:pn550P5C/550P7C:pvrP05ABI:rvnSAMSUNGELECTRONICSCO.,LTD.:rnSAMSUNG_NP1234567890:rvrSEC_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: 550P5C/550P7C
dmi.product.version: P05ABI
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.0.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.0.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.909-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Feb 6 08:49:54 2014
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 [drm] KMS not enabled
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 12874
 vendor SEC
xserver.version: 2:1.15.0-1ubuntu1

Adauto Serpa (adautoserpa) wrote :

StacktraceTop:
 __assert_fail_base (fmt=0x7f18ee23cbe0 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x7f18f075ad57 "slave->isGPU", file=file@entry=0x7f18f075ad22 "../../dix/dispatch.c", line=line@entry=3920, function=function@entry=0x7f18f075ade0 <__PRETTY_FUNCTION__.18250> "DetachUnboundGPU") at assert.c:92
 __GI___assert_fail (assertion=assertion@entry=0x7f18f075ad57 "slave->isGPU", file=file@entry=0x7f18f075ad22 "../../dix/dispatch.c", line=line@entry=3920, function=function@entry=0x7f18f075ade0 <__PRETTY_FUNCTION__.18250> "DetachUnboundGPU") at assert.c:101
 DetachUnboundGPU (slave=<optimized out>) at ../../dix/dispatch.c:3920
 xf86RandR14ProviderSetOutputSource (pScreen=0x44a, provider=0x44a, source_provider=0x6) at ../../../../hw/xfree86/modes/xf86RandR12.c:1806
 dixLookupPrivate (key=<optimized out>, privates=0x7f18f2774d88) at ../../include/privates.h:165

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Dave Morley (davmor2) on 2014-02-10
information type: Private → Public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.15.0-1ubuntu4

---------------
xorg-server (2:1.15.0-1ubuntu4) trusty; urgency=low

  * Only set RR caps that are appropriate to main/gpu screen. (LP: #1277014)
 -- Maarten Lankhorst <email address hidden> Mon, 10 Feb 2014 18:51:19 +0100

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Maarten Lankhorst (mlankhorst) wrote :

Minimal testcase:
xrandr --setprovideroutputsource intel intel

Hello Adauto, or anyone else affected,

Accepted xorg-server into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server/2:1.14.6-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xorg-server (Ubuntu Saucy):
importance: Undecided → Medium
status: New → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello Adauto, or anyone else affected,

Accepted xorg-server-lts-saucy into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server-lts-saucy/2:1.14.6-0ubuntu1~precise1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Adauto, or anyone else affected,

Accepted xorg-server-lts-saucy into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server-lts-saucy/2:1.14.6-0ubuntu1~precise2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Maarten Lankhorst (mlankhorst) wrote :

Fix works on saucy too.

tags: added: verification-done
removed: verification-needed
Maarten Lankhorst (mlankhorst) wrote :

I mean xserver-xorg-lts-saucy.

The verification of the Stable Release Update for xorg-server-lts-saucy has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.14.6-0ubuntu1

---------------
xorg-server (2:1.14.6-0ubuntu1) saucy-proposed; urgency=medium

  * New upstream release (MRE).
  * Disable support for rotations and transforms
    on gpu screens for now. (LP: #1308515)
  * Only set RR caps that are appropriate to main/gpu screen. (LP: #1277014)
  * Fix crash in RRCrtcDetachScanoutPixmap. (LP: #1280743)
 -- Maarten Lankhorst <email address hidden> Tue, 22 Apr 2014 12:37:21 +0200

Changed in xorg-server (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.